Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! ERROR: dev-lang/perl-5.8.5-r5 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Fri Mar 11, 2005 7:55 pm    Post subject: !!! ERROR: dev-lang/perl-5.8.5-r5 failed Reply with quote

Hi,

Prior to installing kde, I did the following:
- First I did emerge --update --deep --newuse world with emerge --depclean and revdep-rebuild. ll whent well.
- Then, I did a emerge sync, system, and now world and 1/2 way through I got stuck here:

Code:
Extracting lib.pm (with variable substitutions)
        AutoSplitting perl library
./miniperl -Ilib -e 'use AutoSplit; \
autosplit_lib_modules(@ARGV)' lib/*.pm
Errno architecture (i686-linux-2.6.9-gentoo-r1) does not match executable architecture (i686-linux-2.6.10-gentoo-r6) at /usr/lib/perl5/5.8.5/i686-linux/Errno.pm line 11.
Compilation failed in require at lib/File/Path.pm line 166.
BEGIN failed--compilation aborted at lib/File/Path.pm line 166.
Compilation failed in require at lib/AutoSplit.pm line 8.
BEGIN failed--compilation aborted at lib/AutoSplit.pm line 8.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
make: *** [preplibrary] Error 9

!!! ERROR: dev-lang/perl-5.8.5-r5 failed.
!!! Function src_compile, Line 246, Exitcode 2
!!! Unable to make
!!! If you need support, post the topmost build error, NOT this status message.


I tried to compile perl by itself but I got the same error.
I could not figure out what is causing this or what the error is.

Can anyone tell me what is causing this and most important how to fix it?

Thank you,
Spiro
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Fri Mar 11, 2005 7:57 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=84868
Back to top
View user's profile Send private message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Fri Mar 11, 2005 9:10 pm    Post subject: Reply with quote

Hi,

ha, this makes me fell better, thinking that I did not screw-up but that something else is chasing my PC.
Now, here is the last comment to the but list:

Quote:
The problem is the patch uses ENOENT on line 166, which requires Errno.pm. Since that hasn't been built when AutoSplit uses File::Path, it ends up using the already installed version of it. This checks it's hardcoded $Config{'osver'} with the current one, failing if you previously installed perl while using a different kernel. I'm not sure if you can build Errno.pm before it gets to this point, so really the only option is to not use ENOENT.


Now, I bet the only way to get away with this is "the only option is to not use ENOENT"
But, how do I translate this in actions? :? And, is this is?

Please AlterEgo, if you could explain what to do next because I do not have a feeling for this. Do I have to edit some files and remove ENOENT? Please advice...

Thank you,
Spiro
Back to top
View user's profile Send private message
WladyX
Guru
Guru


Joined: 25 Nov 2004
Posts: 503
Location: Romania

PostPosted: Fri Mar 11, 2005 11:05 pm    Post subject: Reply with quote

I edited the file and changed the kernel version, before i saw this thread.Anyway it bugged me big time!!
_________________
We are not alone.
Back to top
View user's profile Send private message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Sat Mar 12, 2005 7:02 am    Post subject: Reply with quote

Hi,

I did edit this file /usr/lib/perl5/5.8.5/i686-linux/Errno.pm and modified the Linux version to my current one (retrieved by uname -a).
It now compiles fine.

Thank you for your always courtesy and prompt support.

Spiro
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Sun Mar 13, 2005 7:42 am    Post subject: Reply with quote

Moved from Installing Gentoo in favour of https://forums.gentoo.org/viewtopic-t-307099.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum