Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
C compiler cannot create executables
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Bungopolis
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 198
Location: San Francisco, CA, USA

PostPosted: Mon Mar 14, 2005 6:38 pm    Post subject: C compiler cannot create executables Reply with quote

I'm having an error with a stage 1 bootstrap on a clean system with the 2004.3 liveCD:

Code:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log` for more details.
...
!!! ERROR: sys-apps/sed-4.0.9 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed


Here is my make.conf

Code:
CFLAGS="-march=athlon-xp -mcpu=athlon-xp -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
USE="3dnow sse nvidia xinerama alsa java cdr dvd gnome -kde -qt -oss -arts -nls -cups"


I have tried various changes in make.conf, including commenting out all USE flags (where I get the same error, except with gettext instead of sed), and using the lowest possible optimization settings.

I can also post my sed config.log if it might help.

Thanks
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Mar 14, 2005 6:50 pm    Post subject: Re: bootstrap: C compiler cannot create executables Reply with quote

Bungopolis wrote:
I'm having an error with a stage 1 bootstrap on a clean system with the 2004.3 liveCD:

Code:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log` for more details.
...
!!! ERROR: sys-apps/sed-4.0.9 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed


Here is my make.conf

Code:
CFLAGS="-march=athlon-xp -mcpu=athlon-xp -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
USE="3dnow sse nvidia xinerama alsa java cdr dvd gnome -kde -qt -oss -arts -nls -cups"


I have tried various changes in make.conf, including commenting out all USE flags (where I get the same error, except with gettext instead of sed), and using the lowest possible optimization settings.

I can also post my sed config.log if it might help.

Thanks

Your make.conf looks ok. Are you sure your cpu is an athlon-xp and not an athlon thunderbird or an early duron?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
transient
l33t
l33t


Joined: 13 Jan 2005
Posts: 759

PostPosted: Mon Mar 14, 2005 7:03 pm    Post subject: Reply with quote

Code:
CFLAGS="" bootstrap.sh

Try that. If it works, then its not your CFLAGS causing the issue.
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon Mar 14, 2005 7:15 pm    Post subject: Reply with quote

Some moderator should really make a sticky topic for "Bootstrapping: Compiler cannot create executables". Verify you have the correct subarchitecture (athlon-xp) with cat /proc/cpuinfo and post your config.log.
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon Mar 14, 2005 7:42 pm    Post subject: Reply with quote

Nevermind the sticky, here is the thread you should be looking at.
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
Bungopolis
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 198
Location: San Francisco, CA, USA

PostPosted: Mon Mar 14, 2005 8:21 pm    Post subject: Reply with quote

I had in fact read those posts, but they do not solve my issue.

I have no doubt that my CPU is indeed an athlon-xp. My make.conf was actually copied from another Gentoo installation on the same system on a different partition. I have tried a very simple make.conf configuration with no USE flags and simply CFLAGS="-march=athlon-xp" but the problem still occurs.

I will mess around with it a bit more, and post my config.log once I get back home later.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Mar 14, 2005 8:58 pm    Post subject: Reply with quote

Hmmm... does using -mtune instead of -mcpu solve the problem?
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon Mar 14, 2005 9:03 pm    Post subject: Reply with quote

Why use -mcpu at all, -march implies -mcpu, it's redundant.
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
Bungopolis
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 198
Location: San Francisco, CA, USA

PostPosted: Mon Mar 14, 2005 11:08 pm    Post subject: Reply with quote

I've read about a few minor compatibility issues with leaving out mcpu. I just added it in for good luck. It cant hurt...
Back to top
View user's profile Send private message
Bungopolis
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 198
Location: San Francisco, CA, USA

PostPosted: Tue Mar 15, 2005 2:09 am    Post subject: Reply with quote

This is clearly not a CFLAGS issue, as I tried bootstrapping as follows to no avail:

Code:
CFLAGS="" scripts/bootstrap.sh


Here is the relevent (I think) part of my sed config.log from earlier:

Code:
configure:2112: checking for C compiler default output file name
configure:2115: gcc -march=athlon-xp -mcpu=athlon-xp -O3 -pipe   conftest.c  >&5
/lib/libc.so.6: undefined reference to `___tls_get_addr@GLIBC_2.3'
collect2: ld returned 1 exit status
configure:2118: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME "sed"
| #define PACKAGE_TARNAME "sed"
| #define PACKAGE_VERSION "4.0.9"
| #define PACKAGE_STRING "sed 4.0.9"
| #define PACKAGE_BUGREPORT "bonzini@gnu.org"
| #define PACKAGE "sed"
| #define VERSION "4.0.9"
| #define SED_FEATURE_VERSION "4.0"
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:2157: error: C compiler cannot create executables
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Tue Mar 15, 2005 2:25 am    Post subject: Reply with quote

Bungopolis wrote:
This is clearly not a CFLAGS issue, as I tried bootstrapping as follows to no avail:

Code:
CFLAGS="" scripts/bootstrap.sh

How about commenting out your CFLAGS in make.conf and then bootstrapping? Setting them on the command line has no effect, as Portage will always read from make.conf, and thus nullifying your commandline tweak.

@transient:
Code:
CFLAGS="" emerge --info
would have told you that setting CFLAGS on the command line like that has no effect. bootstrap.sh is just a monkey that calls emerge with certain special options.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
Bungopolis
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 198
Location: San Francisco, CA, USA

PostPosted: Tue Mar 15, 2005 2:43 am    Post subject: Reply with quote

Actually kimchi_sg setting them on the commandline DOES override the contents of make.conf (its just like running ACCEPT_KEYWORDS="~x86" emerge foo).

And as I mentioned earlier, I have also tried a minimal make.conf. It doesn't make any difference. I'm using the same make.conf as I have on my working install on the same system. This is not a CFLAGS issue.
Back to top
View user's profile Send private message
transient
l33t
l33t


Joined: 13 Jan 2005
Posts: 759

PostPosted: Tue Mar 15, 2005 3:24 am    Post subject: Reply with quote

It looks like a very strange glibc error.
I dunno what though.....
Code:
/lib/libc.so.6: undefined reference to `___tls_get_addr@GLIBC_2.3'
is the offending line, but im not sure why it wouldnt be able to find tls..
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Tue Mar 15, 2005 3:38 am    Post subject: Reply with quote

I had an error simaler to that when I tried to upgrade glibc, I fixed it by downgrading. I never actually got to the root of that problem though.
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
eike.com
n00b
n00b


Joined: 12 Mar 2004
Posts: 25
Location: Hamburg, GERMANY

PostPosted: Tue Mar 15, 2005 11:44 am    Post subject: Reply with quote

I'm having the same problem doing a stage3 install from a 2004.1 UNI CD on a Pentium2 notepook (64MB RAM).
emerge gentoo-dev-sources
econf failed

emerge gentoo-sources
econf failed

TIA,
Eike
Back to top
View user's profile Send private message
racoontje
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1290

PostPosted: Tue Mar 15, 2005 11:56 am    Post subject: Reply with quote

Try a stage1on3 install.
Back to top
View user's profile Send private message
Bungopolis
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 198
Location: San Francisco, CA, USA

PostPosted: Tue Mar 15, 2005 7:08 pm    Post subject: Reply with quote

eike.com wrote:
I'm having the same problem doing a stage3 install from a 2004.1 UNI CD on a Pentium2 notepook (64MB RAM).
emerge gentoo-dev-sources
econf failed


I don't think this is the same problem eike.com -- 'econf failed' is a generic message for a failed emerge, if you aren't getting a "C compiler cannot create executables" message (I don't see why you would, gentoo-dev-sources simply installs the kernel source to /usr/src), then this is not the same problem.
Back to top
View user's profile Send private message
Rollbar
n00b
n00b


Joined: 16 Sep 2004
Posts: 26
Location: Sweden, STHLM

PostPosted: Sat Mar 26, 2005 4:47 pm    Post subject: Reply with quote

Heh, I'm also having this stupid problem during bootstrap. I'm positive there's nothing wrong with my make.conf, still the script breaks with the "cannot create executable"-message. It'd be kinda nice to get an official fix for this problem, as we're so many having it.

I'm also running Gentoo 64, and the script breaks when it's supposed to install sys-apps/sed-4.0.9

*edit*

Uh, got it working for now. Much earlier, I had the boostrap failing because of an erronous -march-setting (was -march=athlon64, changed it to march=k8). That changed, bootstrap ran for like an hour or so, but then failed _again_ all of a sudden at the compiliation of sed. Knowing that there wasn't anything wrong with my make.conf (I checked it character by character with a working one, and it had worked well so far), I didn't bother to check it again. But eventually I did anyway, and the first thing I noticed was that the "-" was missing from the -pipe-flag. :|
This is totally strange, as I know that it was there from the beginning (just copied an old working CFLAGS-line).
Back to top
View user's profile Send private message
Bernie01
n00b
n00b


Joined: 27 Apr 2005
Posts: 11
Location: Melbourne, Australia

PostPosted: Sat May 07, 2005 9:01 pm    Post subject: Reply with quote

I am now having problems with this too. My install is a stage 3 2005.0.
I have checked make.conf and my CLAGS line is :;

CFLAGS="-O2 -march=x86 -pipe"

I think i have followed all the instructions to ensure these are correct for my Pentium 266 and am not sure what to do next
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun May 08, 2005 7:15 pm    Post subject: Reply with quote

Quote:
CFLAGS="-O2 -march=x86 -pipe"
try -march=i686 instead
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
biohazrd
n00b
n00b


Joined: 14 Feb 2005
Posts: 5
Location: Vancouver, British Columbia, Canada

PostPosted: Sat May 28, 2005 1:38 am    Post subject: Reply with quote

I'm also having problems. I'm trying to do a deep world update. I just ran emerge --sync to get the latest versions. Here is my make.conf file. I've checked others and I don't believe this is the problem.

Code:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
USE="radeon -sis -rage128 -matrox -3dfx -gamma -i8x0 alsa oss opengl xmms mpeg mpg321 real firefox thunderbird qt quicktime kde samba lisa 3dnow mmx cups xosd -kdetoys -arts -gnome"
ACCEPT_KEYWORDS="x86"
FEATURES="candy"
GENTOO_MIRRORS="ftp://gentoo.agsn.ca/"
ALSA_CARDS="intel8x0,ens1371"


And here's the output of my config.log file after running emerge. I tried searching for the conftest.c file that it attempts to compile, but I was unable to find it. Not sure if that may be the problem.

Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by GNU diffutils configure 2.8.7, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls

## --------- ##
## Platform. ##
## --------- ##

hostname = duffman
uname -m = i686
uname -r = 2.6.10-gentoo-r6
uname -s = Linux
uname -v = #3 Sun Feb 13 20:05:36 EST 2005

/usr/bin/uname -p = AMD Athlon(tm) XP 2800+
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /sbin
PATH: /usr/sbin
PATH: /usr/lib/portage/bin
PATH: /bin
PATH: /usr/bin
PATH: /usr/local/bin
PATH: /opt/bin
PATH: /usr/i686-pc-linux-gnu/gcc-bin/3.4.3-20050110
PATH: /opt/sun-jdk-1.4.2.07/bin
PATH: /opt/sun-jdk-1.4.2.07/jre/bin
PATH: /opt/sun-jdk-1.4.2.07/jre/javaws
PATH: /usr/qt/3/bin
PATH: /usr/kde/3.3/sbin
PATH: /usr/kde/3.3/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1401: checking for a BSD-compatible install
configure:1456: result: /bin/install -c
configure:1467: checking whether build environment is sane
configure:1510: result: yes
configure:1567: checking for gawk
configure:1583: found /bin/gawk
configure:1593: result: gawk
configure:1603: checking whether make sets $(MAKE)
configure:1623: result: yes
configure:1702: checking for i686-pc-linux-gnu-strip
configure:1731: result: no
configure:1740: checking for strip
configure:1767: result: :
configure:1808: checking for style of include used by make
configure:1836: result: GNU
configure:1869: checking for i686-pc-linux-gnu-gcc
configure:1885: found /usr/bin/i686-pc-linux-gnu-gcc
configure:1895: result: i686-pc-linux-gnu-gcc
configure:2177: checking for C compiler version
configure:2180: i686-pc-linux-gnu-gcc --version </dev/null >&5
i686-pc-linux-gnu-gcc (GCC) 3.4.3-20050110 (Gentoo Linux 3.4.3.20050110, ssp-3.4.3.20050110-0, pie-8.7.7)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2183: $? = 0
configure:2185: i686-pc-linux-gnu-gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc/i686-pc-linux-gnu/3.4.3-20050110/specs
Configured with: /var/tmp/portage/gcc-3.4.3.20050110/work/gcc-3.4.3/configure --enable-version-specific-runtime-libs --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/3.4.3-20050110 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/3.4.3-20050110/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.3-20050110 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.3-20050110/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/3.4.3-20050110/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/3.4.3-20050110/include/g++-v3 --host=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --enable-__cxa_atexit --enable-clocale=gnu --with-system-zlib --disable-checking --disable-werror --disable-libunwind-exceptions --disable-multilib --disable-libgcj --enable-languages=c,c++,f77 --enable-shared --enable-threads=posix
Thread model: posix
gcc version 3.4.3-20050110 (Gentoo Linux 3.4.3.20050110, ssp-3.4.3.20050110-0, pie-8.7.7)
configure:2188: $? = 0
configure:2190: i686-pc-linux-gnu-gcc -V </dev/null >&5
i686-pc-linux-gnu-gcc: `-V' option must have argument
configure:2193: $? = 1
configure:2216: checking for C compiler default output file name
configure:2219: i686-pc-linux-gnu-gcc -O2 -march=athlon-xp -pipe   conftest.c  >&5
i686-pc-linux-gnu-gcc: installation problem, cannot exec `as': No such file or directory
conftest.c:19: fatal error: error closing -: Broken pipe
compilation terminated.
The bug is not reproducible, so it is likely a hardware or OS problem.
configure:2222: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME "GNU diffutils"
| #define PACKAGE_TARNAME "diffutils"
| #define PACKAGE_VERSION "2.8.7"
| #define PACKAGE_STRING "GNU diffutils 2.8.7"
| #define PACKAGE_BUGREPORT "bug-gnu-utils@gnu.org"
| #define PACKAGE "diffutils"
| #define VERSION "2.8.7"
| #define _GNU_SOURCE 1
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:2261: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=athlon-xp -pipe'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_DEFAULT_POSIX2_VERSION_set=
ac_cv_env_DEFAULT_POSIX2_VERSION_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=set
ac_cv_env_host_alias_value=i686-pc-linux-gnu
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/bin/install -c'
ac_cv_prog_AWK=gawk
ac_cv_prog_CC=i686-pc-linux-gnu-gcc
ac_cv_prog_ac_ct_STRIP=:
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/missing --run aclocal-1.8'
ALLOCA=''
ALLOCA_H=''
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='${SHELL} /var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/missing --run tar'
AUTOCONF='${SHELL} /var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/missing --run autoconf'
AUTOHEADER='${SHELL} /var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/missing --run autoheader'
AUTOMAKE='${SHELL} /var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/missing --run automake-1.8'
AWK='gawk'
CC='i686-pc-linux-gnu-gcc'
CCDEPMODE=''
CFLAGS='-O2 -march=athlon-xp -pipe'
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFAULT_POSIX2_VERSION=''
DEFS=''
DEPDIR='.deps'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
FNMATCH_H=''
GMSGFMT=''
HAVE__BOOL=''
HELP2MAN=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
INTLLIBS=''
LDFLAGS=''
LIBICONV=''
LIBINTL=''
LIBOBJS=''
LIBS=''
LIB_CLOCK_GETTIME=''
LTLIBICONV=''
LTLIBINTL=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/missing --run makeinfo'
MKINSTALLDIRS=''
MSGFMT=''
MSGMERGE=''
OBJEXT=''
PACKAGE='diffutils'
PACKAGE_BUGREPORT='bug-gnu-utils@gnu.org'
PACKAGE_NAME='GNU diffutils'
PACKAGE_STRING='GNU diffutils 2.8.7'
PACKAGE_TARNAME='diffutils'
PACKAGE_VERSION='2.8.7'
PATH_SEPARATOR=':'
POSUB=''
PR_PROGRAM=''
RANLIB=''
SET_MAKE=''
SHELL='/bin/sh'
STDBOOL_H=''
STRIP=':'
USE_NLS=''
VERSION='2.8.7'
XGETTEXT=''
ac_ct_CC=''
ac_ct_RANLIB=''
ac_ct_STRIP=':'
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include='include'
am__leading_dot='.'
am__quote=''
bindir='${exec_prefix}/bin'
build=''
build_alias=''
build_cpu=''
build_os=''
build_vendor=''
datadir='/usr/share'
exec_prefix='NONE'
host='i686-pc-linux-gnu'
host_alias='i686-pc-linux-gnu'
host_cpu=''
host_os=''
host_vendor=''
includedir='${prefix}/include'
infodir='/usr/share/info'
install_sh='/var/tmp/portage/diffutils-2.8.7-r1/work/diffutils-2.8.7/config/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='/var/lib'
mandir='/usr/share/man'
mkdir_p='mkdir -p -- .'
oldincludedir='/usr/include'
prefix='/usr'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE "diffutils"
#define PACKAGE_BUGREPORT "bug-gnu-utils@gnu.org"
#define PACKAGE_NAME "GNU diffutils"
#define PACKAGE_STRING "GNU diffutils 2.8.7"
#define PACKAGE_TARNAME "diffutils"
#define PACKAGE_VERSION "2.8.7"
#define VERSION "2.8.7"
#define _GNU_SOURCE 1

configure: exit 77


It also mentions

Code:
configure:2219: i686-pc-linux-gnu-gcc -O2 -march=athlon-xp -pipe   conftest.c  >&5
i686-pc-linux-gnu-gcc: installation problem, cannot exec `as': No such file or directory
Back to top
View user's profile Send private message
[Mad]Masenko
n00b
n00b


Joined: 23 Jul 2004
Posts: 40

PostPosted: Tue Jun 14, 2005 2:47 am    Post subject: Similar Problem [Solved] Reply with quote

Solved a similar problem (as i'd tried everything above and nothing had worked - but it did pick up on some incorrect library versions) by doing this
Code:
binutils-config 1

then everything work normal again
original error:
Code:
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output... configure: error: C compiler cannot create

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/ncurses-5.4.20050319/work/narrowc/config.log

!!! ERROR: sys-libs/ncurses-5.4.20050319 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.
Code:
>>> Source unpacked.
i686-pc-linux-gnu-gcc: installation problem, cannot exec `as': No such file or directory

!!! ERROR: sys-devel/gcc-config-1.3.11-r3 failed.
!!! Function src_compile, Line 25, Exitcode 1
!!! compile wrapper
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
pandaemonium
n00b
n00b


Joined: 05 Apr 2004
Posts: 6

PostPosted: Tue Jun 14, 2005 8:16 am    Post subject: Reply with quote

@[Mad]Masenko:
thx, your solution saved my day and solved the problem for me, too
Back to top
View user's profile Send private message
rafaelkafka
n00b
n00b


Joined: 03 Feb 2005
Posts: 28

PostPosted: Tue Jun 14, 2005 4:45 pm    Post subject: Re: Similar Problem [Solved] Reply with quote

[Mad]Masenko wrote:
Solved a similar problem (as i'd tried everything above and nothing had worked - but it did pick up on some incorrect library versions) by doing this
Code:
binutils-config 1

then everything work normal again
original error:
Code:
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output... configure: error: C compiler cannot create

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/ncurses-5.4.20050319/work/narrowc/config.log

!!! ERROR: sys-libs/ncurses-5.4.20050319 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.
Code:
>>> Source unpacked.
i686-pc-linux-gnu-gcc: installation problem, cannot exec `as': No such file or directory

!!! ERROR: sys-devel/gcc-config-1.3.11-r3 failed.
!!! Function src_compile, Line 25, Exitcode 1
!!! compile wrapper
!!! If you need support, post the topmost build error, NOT this status message.


Thank you very much!God bless you!

Rafael Kafka
Back to top
View user's profile Send private message
Ma3oxuct
Guru
Guru


Joined: 18 Apr 2003
Posts: 523

PostPosted: Tue Jun 14, 2005 8:42 pm    Post subject: Reply with quote

Same thing on my end :D...How in the world did you figure out such a simple solution ??

...And to think, I was doing to reinstall my entire system from scratch :lol:

Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum