Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compilation error in kde-base/kdelibs-3.3.2-r5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
elCorazon
n00b
n00b


Joined: 11 Jan 2005
Posts: 7

PostPosted: Wed Mar 16, 2005 11:28 am    Post subject: compilation error in kde-base/kdelibs-3.3.2-r5 Reply with quote

Hi

I'm trying to do an emerge -uD world but I get a compilation error in kde-base/kdelibs-3.3.2-r5 and I don't know what to do... What's wrong?
Thanks for your help...

Code:

[...]
.libs/artskde.o(.gnu.linkonce.d._ZTCN4Arts19KIOInputStream_stubE52_NS_16SynthModule_stubE+0xa8): undefined reference to `virtual thunk to Arts::SynthModule_stub::autoSuspend()'
.libs/artskde.o(.gnu.linkonce.d._ZTCN4Arts19KIOInputStream_stubE52_NS_16SynthModule_stubE+0xac): undefined reference to `virtual thunk to Arts::SynthModule_stub::start()'
.libs/artskde.o(.gnu.linkonce.d._ZTCN4Arts19KIOInputStream_stubE52_NS_16SynthModule_stubE+0xb0): undefined reference to `virtual thunk to Arts::SynthModule_stub::stop()'
.libs/artskde.o(.gnu.linkonce.d._ZTCN4Arts19KIOInputStream_stubE52_NS_16SynthModule_stubE+0xb4): undefined reference to `virtual thunk to Arts::SynthModule_stub::streamInit()'

[...]

.libs/artskde.o(.gnu.linkonce.d._ZTVN4Arts19KIOInputStream_stubE+0x78): undefined reference to `virtual thunk to Arts::SynthModule_stub::autoSuspend()'
.libs/artskde.o(.gnu.linkonce.d._ZTVN4Arts19KIOInputStream_stubE+0x7c): undefined reference to `virtual thunk to Arts::SynthModule_stub::start()'
.libs/artskde.o(.gnu.linkonce.d._ZTVN4Arts19KIOInputStream_stubE+0x80): undefined reference to `virtual thunk to Arts::SynthModule_stub::stop()'
.libs/artskde.o(.gnu.linkonce.d._ZTVN4Arts19KIOInputStream_stubE+0x84): undefined reference to `virtual thunk to Arts::SynthModule_stub::streamInit()'
.libs/artskde.o(.gnu.linkonce.d._ZTVN4Arts19KIOInputStream_stubE+0x88): undefined reference to `virtual thunk to Arts::SynthModule_stub::streamStart()'
.libs/artskde.o(.gnu.linkonce.d._ZTVN4Arts19KIOInputStream_stubE+0x8c): undefined reference to `virtual thunk to Arts::SynthModule_stub::streamEnd()'
.libs/artskde.o(.gnu.linkonce.d._ZTCN4Arts17KDataRequest_stubE48_NS_16SynthModule_stubE+0xa8): undefined reference to `virtual thunk to Arts::SynthModule_stub::autoSuspend()'

[...]

.libs/kdatarequest_impl.o(.gnu.linkonce.d._ZTVN4Arts17KDataRequest_implE+0xf0): undefined reference to `virtual thunk toArts::StdSynthModule::stop()'
.libs/kdatarequest_impl.o(.gnu.linkonce.d._ZTVN4Arts17KDataRequest_implE+0xf8): undefined reference to `virtual thunk toArts::StdSynthModule::streamStart()'
collect2: ld returned 1 exit status
make[3]: *** [libartskde.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdelibs-3.3.2-r5/work/kdelibs-3.3.2/arts/kde'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.3.2-r5/work/kdelibs-3.3.2/arts'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdelibs-3.3.2-r5/work/kdelibs-3.3.2'
make: *** [all] Error 2

!!! ERROR: kde-base/kdelibs-3.3.2-r5 failed.
!!! Function kde_src_compile, Line 166, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.

Code:
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

Code:
[ebuild     U ] kde-base/kdelibs-3.3.2-r5 [3.3.2-r1] +alsa +arts +cups -debug -doc +ipv6 -kdeenablefinal -kerberos +ldap+spell +ssl +tiff -xinerama 0 kB
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Wed Mar 16, 2005 11:30 am    Post subject: Reply with quote

Right off my head... hope it might just help ;) :
  1. Re-emerge arts
  2. Take out USE=arts (either in make.conf, or using package.use), then emerge --resume

_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
elCorazon
n00b
n00b


Joined: 11 Jan 2005
Posts: 7

PostPosted: Wed Mar 16, 2005 10:59 pm    Post subject: what about arts? Reply with quote

OK, thanks, that worked... but what about arts? Don't I need it?
XMMS works fine with arts-plugin, Control-Center Sound-Test is ok.

But
JuK doesn't start anymore (crashes juk: error while loading shared libraries: libartskde.so.1: cannot open shared object file: No such file or directory)
System-Sound doesn't play

I never really understood the sound-system: arts, alsa, oss... which do I need?
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Thu Mar 17, 2005 12:16 am    Post subject: Reply with quote

You might need to compile the rest of your kde apps with USE="arts" also. :?
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed May 18, 2005 6:26 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-338861.html

Moved from Desktop Environments.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum