Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mod_php portage error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Gentoo Server
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 279

PostPosted: Wed Mar 16, 2005 1:54 pm    Post subject: mod_php portage error Reply with quote

I have php5 installed but now when i make a emerge gentoo want to downgrade php!!!!

gaia root # emerge -s mod_php
Searching...
[ Results for search key : mod_php ]
[ Applications found : 1 ]

* dev-php/mod_php
Latest version available: 4.3.10-r1
Latest version installed: 5.0.3
Size of downloaded files: 3,932 kB
Homepage: http://www.php.net/
Description: Apache module for PHP
License: PHP-3


gaia root # emerge -Up world

*** Warning: --upgradeonly is a deprecated option in portage-2.0.51.19
*** and will likely be removed in a future version.

>>> --upgradeonly implies --update... adding --update to options.

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild U ] dev-php/mod_php-4.3.10-r1 [4.3.2]
[ebuild U ] sys-apps/net-tools-1.60-r11 [1.60-r9]
[ebuild U ] sys-devel/prelink-20041123 [20040707]
gaia root #

looks like emerge thinks for some reason I have 4.3.2 installed!
Back to top
View user's profile Send private message
seank
l33t
l33t


Joined: 08 Jul 2004
Posts: 686

PostPosted: Wed Mar 16, 2005 5:26 pm    Post subject: Reply with quote

Code:
# echo "dev-php/mod_php ~x86" >> /etc/portage/package.keywords
Back to top
View user's profile Send private message
Gentoo Server
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 279

PostPosted: Wed Mar 16, 2005 7:11 pm    Post subject: Reply with quote

sean_micken wrote:
Code:
# echo "dev-php/mod_php ~x86" >> /etc/portage/package.keywords


this is my config with this error

gaia root # cat /etc/portage/package.keywords
dev-db/mysql ~x86
dev-perl/DBD-mysql ~x86
dev-php/mod_php ~x86
dev-php/php ~x86
dev-db/mysql-administrator ~x86

gaia root #
Back to top
View user's profile Send private message
powdahound
n00b
n00b


Joined: 21 Jan 2004
Posts: 26
Location: NH, USA

PostPosted: Wed Mar 16, 2005 11:11 pm    Post subject: Reply with quote

This also happened to me on all 3 of my gentoo machines the other day. All the updates want to go to mod_php 4 when I clearly have mod_php in my packages.keywords and mod_php 5 currently installed. `emerge php` still goes to version 5 however.

It's a bug. :(
Back to top
View user's profile Send private message
Benny007
n00b
n00b


Joined: 10 Feb 2003
Posts: 43
Location: U.K.

PostPosted: Thu Mar 17, 2005 12:01 am    Post subject: it's not bug Reply with quote

It is becouse in file /usr/portage/profiles/package.mask was added lines:

# Stuart Herbert <stuart@gentoo.org> (12th march 2005)
# automatically activates ZTS mode when any threaded MPMs are installed,
# even if mpm_prefork is the default
=dev-php/mod_php-5*

It means that mod_php is masked at the moment.
Unmask it (with risk), or downgrade. That is the solution :(
Back to top
View user's profile Send private message
powdahound
n00b
n00b


Joined: 21 Jan 2004
Posts: 26
Location: NH, USA

PostPosted: Thu Mar 17, 2005 1:43 am    Post subject: Reply with quote

putting mod_php in packages.unmask then wants me to get a newer version of apache, then some gentoo-webroot thing, then something else. Seems a little crazy. Hopefully it gets unmasked soon. PHP5 is plenty stable.
Back to top
View user's profile Send private message
Gentoo Server
Apprentice
Apprentice


Joined: 21 Jul 2003
Posts: 279

PostPosted: Thu Mar 17, 2005 7:17 am    Post subject: Reply with quote

i have this already in my /etc/portage/package.unmask

dev-db/mysql
dev-perl/DBD-mysql
dev-php/php5
dev-php/mod_php5
dev-db/mysql-administrator


what should i add to resolve the php5 issue?
Back to top
View user's profile Send private message
powdahound
n00b
n00b


Joined: 21 Jan 2004
Posts: 26
Location: NH, USA

PostPosted: Thu Mar 17, 2005 6:35 pm    Post subject: Reply with quote

I think we just have to wait for this to be fixed in portage. :(
Back to top
View user's profile Send private message
feardapenguin
Guru
Guru


Joined: 23 Jul 2003
Posts: 414
Location: Texas

PostPosted: Fri Mar 18, 2005 4:06 am    Post subject: Reply with quote

Has anyone found a bug report associated with this?
Back to top
View user's profile Send private message
feardapenguin
Guru
Guru


Joined: 23 Jul 2003
Posts: 414
Location: Texas

PostPosted: Sat Mar 19, 2005 1:04 am    Post subject: Reply with quote

See thread https://forums.gentoo.org/viewtopic-t-310095-highlight-.html
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Apr 04, 2005 2:25 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-296192.html

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum