Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Client.o.lock and fam.o.lock driving me insane
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nomind
Apprentice
Apprentice


Joined: 03 Feb 2005
Posts: 270

PostPosted: Fri Mar 18, 2005 6:28 pm    Post subject: Client.o.lock and fam.o.lock driving me insane Reply with quote

Hello,
When I try to emerge kdebase, the process gets stuck at a certain point. Essentially, I get two messages repeatedly (alternating), which read like the following:
Waiting for Client.o.lock to be removed
Waiting for fam.o.lock to be removed
What exactly is causing this? A google search for this problem only shows a couple of pages in Polish, but I can't read Polish, so I'm stuck.
Thanks in advance

(the same problem appears when I try to emerge mozilla-firefox)
Back to top
View user's profile Send private message
j3rm
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2002
Posts: 148
Location: Tennessee

PostPosted: Fri Mar 25, 2005 4:27 am    Post subject: Reply with quote

same thing is happening to me for multiple packages. the last package i tried to install that did this was gnet-2.0.5. here's the relevant code:

Quote:
make all-recursive
make[1]: Entering directory `/var/tmp/portage/gnet-2.0.5/work/gnet-2.0.5'
Making all in src
make[2]: Entering directory `/var/tmp/portage/gnet-2.0.5/work/gnet-2.0.5/src'
source='gnet.c' object='gnet.lo' libtool=yes \
depfile='.deps/gnet.Plo' tmpdepfile='.deps/gnet.TPlo' \
depmode=gcc3 /bin/sh ../depcomp \
/bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.
-I.. -DG_LOG_DOMAIN=\"GNet\" -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -mcpu=athl
on-xp -O3 -pipe -D_REENTRANT -DGNET_EXPERIMENTAL -Wall -Wstrict-prototypes -
Wmissing-prototypes -Wmissing-declarations -c -o gnet.lo `test -f gnet.c || echo
'./'`gnet.c
source='gnet-private.c' object='gnet-private.lo' libtool=yes \
depfile='.deps/gnet-private.Plo' tmpdepfile='.deps/gnet-private.TPlo' \
depmode=gcc3 /bin/sh ../depcomp \
/bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.
-I.. -DG_LOG_DOMAIN=\"GNet\" -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -mcpu=athl
on-xp -O3 -pipe -D_REENTRANT -DGNET_EXPERIMENTAL -Wall -Wstrict-prototypes -
Wmissing-prototypes -Wmissing-declarations -c -o gnet-private.lo `test -f gnet-p
rivate.c || echo './'`gnet-private.c
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
Waiting for gnet-private.o.lock to be removed
Waiting for gnet.o.lock to be removed
... (on into infinity)

_________________
"We can't run from who we are, our destiny chooses us."
-- Professor Petrovsky ("Rounders")
Back to top
View user's profile Send private message
ooky
n00b
n00b


Joined: 25 Oct 2004
Posts: 35

PostPosted: Mon Apr 11, 2005 7:05 pm    Post subject: Reply with quote

Any solution to this? I am running into the same problem with fam.

So sad.
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Mon Apr 11, 2005 7:14 pm    Post subject: Reply with quote

Please follow up to https://forums.gentoo.org/viewtopic-t-299454.html

If the solution there (patch) solves it for you, please either add your email adress in the bugreport or add a comment there. Otherwise it might never be fixed :-s

Edit: @j3rm: Please try
Code:
EXTRA_ECONF=--disable-libtool-lock emerge --oneshot gnet
. If it doesn't help, please write a pm and I split your post out of this.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum