Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New AMD64 installs dying at bootstrap?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
racoontje
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1290

PostPosted: Fri Mar 18, 2005 10:16 pm    Post subject: New AMD64 installs dying at bootstrap? Reply with quote

Worked before. Have some bugs been introduced?

Quote:
livecd64 / # /usr/portage/scripts/bootstrap.sh

Gentoo Linux 2005.0; http://www.gentoo.org/
Copyright 1999-2005 Gentoo Foundation; Distributed under the GPLv2
Starting Bootstrap of base system ...
-------------------------------------------------------------------------------
[[ (0/6) Locating packages ]]
* Using baselayout : >=sys-apps/baselayout-1.9.4
* Using portage : >=sys-apps/portage-2.0.51
* Using os-headers : virtual/os-headers
* Using binutils : >=sys-devel/binutils-2.15.90.0.1.1-r1
* Using gcc : >=sys-devel/gcc-3.3.4
* Using libc : virtual/libc
* Using texinfo : sys-apps/texinfo
* Using zlib : sys-libs/zlib
* Using ncurses : sys-libs/ncurses
-------------------------------------------------------------------------------
[[ (1/6) Configuring environment ]]
* GENTOO_MIRRORS='ftp://ftp.belnet.be/mirrors/rsync.gentoo.org/gentoo'
* PORTDIR='/usr/portage'
* DISTDIR='/usr/portage/distfiles'
* PKGDIR='/usr/portage/packages'
* PORTAGE_TMPDIR='/var/tmp'
* CFLAGS='-Os -march=athlon64 -pipe'
* CHOST='x86_64-pc-linux-gnu'
* CXXFLAGS='-Os -march=athlon64 -pipe -fvisibility-inlines-hidden'
* MAKEOPTS='-j2'
* ACCEPT_KEYWORDS='amd64 ~amd64'
* FEATURES='autoaddcvs autoconfig ccache distcc distlocks'
* STAGE1_USE='multilib'
-------------------------------------------------------------------------------
[[ (2/6) Updating portage ]]
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/portage-2.0.51.19 to /
>>> md5 src_uri ;-) portage-2.0.51.19.tar.bz2
>>> Unpacking source...
>>> Unpacking portage-2.0.51.19.tar.bz2 to /var/tmp/portage/portage-2.0.51.19/work
>>> Source unpacked.
gcc: /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.2/: Is a directory
* No valid multilib environment found!
* Building without multilib support. If
* you want to have multilib support,
* emerge gcc with "multilib" in your
* useflags.
./create-localdecls
Checking truncate argument type... off_t
Checking libc version... gcc: /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.2/: Is a directory
ldd: ./libctest: No such file or directory

rm: cannot remove `libctest': No such file or directory

gcc -O1 -pipe -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT -Wall -c libsandbox.c
gcc: /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.2/: Is a directory
make: *** [libsandbox.o] Error 1

!!! ERROR: sys-apps/portage-2.0.51.19 failed.
!!! Function src_compile, Line 79, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

livecd64 / # emerge --info
Portage 2.0.51-r2 (default-linux/amd64/2004.3, gcc-3.4.2, unavailable, 2.6.11-morph2 x86_64)
=================================================================
System uname: 2.6.11-morph2 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.4.16
Autoconf:
Automake:
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:
Libtools:
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CFLAGS="-Os -march=athlon64 -pipe"
CHOST="x86_64-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=athlon64 -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirrors/rsync.gentoo.org/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.nl.gentoo.org/gentoo-portage"
USE="amd64"
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Sat Mar 19, 2005 1:09 am    Post subject: Reply with quote

Moved from Installing Gentoo.
Back to top
View user's profile Send private message
racoontje
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1290

PostPosted: Sun Mar 20, 2005 11:15 am    Post subject: Reply with quote

Fixed. Default gcc profile was broken.
Back to top
View user's profile Send private message
Gruffi
Apprentice
Apprentice


Joined: 15 Aug 2003
Posts: 209
Location: Antwerpen - Flanders - Belgium

PostPosted: Sun Mar 20, 2005 9:49 pm    Post subject: Reply with quote

Thanks for the fix.
_________________
... and we will show Microsoft, that they cannot take whatever they want. And that Free Software is our software!
Back to top
View user's profile Send private message
Gruffi
Apprentice
Apprentice


Joined: 15 Aug 2003
Posts: 209
Location: Antwerpen - Flanders - Belgium

PostPosted: Sun Mar 20, 2005 10:22 pm    Post subject: Reply with quote

Hmm... what should i do? i synced again. didn't help.
deleted everything and started over with stage 1.
Still this error.
_________________
... and we will show Microsoft, that they cannot take whatever they want. And that Free Software is our software!
Back to top
View user's profile Send private message
Gruffi
Apprentice
Apprentice


Joined: 15 Aug 2003
Posts: 209
Location: Antwerpen - Flanders - Belgium

PostPosted: Mon Mar 21, 2005 1:33 pm    Post subject: Reply with quote

Found the solution here: https://forums.gentoo.org/viewtopic-t-311407.html
_________________
... and we will show Microsoft, that they cannot take whatever they want. And that Free Software is our software!
Back to top
View user's profile Send private message
racoontje
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1290

PostPosted: Mon Mar 21, 2005 2:33 pm    Post subject: Reply with quote

Wow. Dude. Use the edit button!

Remember, you're using the hardened profile now, so after gcc-config 2, run:

'emerge --sync && emerge linux26-headers glibc gcc binutils emul-linux-x86-glibc"

And then switch to the gcc-3.4.3 profile (using gcc-config).
Back to top
View user's profile Send private message
Biker
Apprentice
Apprentice


Joined: 11 Jun 2003
Posts: 165
Location: A very dark, cold and moisty place...

PostPosted: Tue Mar 22, 2005 9:52 am    Post subject: Re: New AMD64 installs dying at bootstrap? Reply with quote

racoontje wrote:
* CFLAGS='-Os -march=athlon64 -pipe'
* CXXFLAGS='-Os -march=athlon64 -pipe -fvisibility-inlines-hidden'


As mentioned in this document, you may want to avoid compiling with -Os.

Biker
_________________
The Internet never forgets.
Where 'never' points in the direction of a moment in the very, very far future.
Back to top
View user's profile Send private message
ahorn
Guru
Guru


Joined: 01 Nov 2004
Posts: 366
Location: Ol' europe

PostPosted: Tue Mar 22, 2005 4:18 pm    Post subject: Reply with quote

i'm to late, but https://forums.gentoo.org/viewtopic-t-305594.html :-)
_________________
Too many connections. Please try again later.
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Tue Mar 22, 2005 4:21 pm    Post subject: Reply with quote

ahorn wrote:
i'm to late, but https://forums.gentoo.org/viewtopic-t-305594.html :-)


Moved to Duplicate Threads. Thank you ahorn.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum