Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge transcode errors?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
ilusiv
n00b
n00b


Joined: 08 Mar 2005
Posts: 12

PostPosted: Sat Mar 19, 2005 9:36 am    Post subject: Emerge transcode errors? Reply with quote

Hey when I try to emerge transcode I get the following error

: undefined reference to `yuv2rgb_init_mmxext'
collect2: ld returned 1 exit status
make[3]: *** [tcdecode] Error 1
make[3]: Leaving directory `/var/tmp/portage/transcode-0.6.14/work/transcode-0.6.14/import'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/transcode-0.6.14/work/transcode-0.6.14/import'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/transcode-0.6.14/work/transcode-0.6.14'
make: *** [all] Error 2


Any ideas?

Ash
Back to top
View user's profile Send private message
sandro123
n00b
n00b


Joined: 25 Apr 2003
Posts: 25

PostPosted: Wed Mar 23, 2005 10:06 am    Post subject: Re: Emerge transcode errors? Reply with quote

I have the same error, but no solution.

-----------------------------------------------------------------------------
tcdecode-decode_mov.o(.text+0x8da): In function `decode_mov':
: undefined reference to `quicktime_read_audio'
../libvo/.libs/libvout.a(yuv2rgb.o)(.text+0x11d): In function `yuv2rgb_init':
: undefined reference to `yuv2rgb_init_mmx'
../libvo/.libs/libvout.a(yuv2rgb.o)(.text+0x163): In function `yuv2rgb_init':
: undefined reference to `yuv2rgb_init_mmxext'
collect2: ld returned 1 exit status
-----------------------------------------------------------------------------
_________________
--------------System overview-----------------
-Desktop: Dual AthlonMP 2400 1GB Ram Dual Screen
-Server: Dual PIII 1000 Mhz 1GB Ram Raid5
-Development: PIII 350 256MB Ram
Back to top
View user's profile Send private message
Lion
Apprentice
Apprentice


Joined: 23 Jun 2002
Posts: 207

PostPosted: Wed Mar 23, 2005 3:49 pm    Post subject: Solution: search! Reply with quote

A quick search found the following thread, just four days ago:
https://forums.gentoo.org/viewtopic-t-297721.html
Just use
Code:
USE="mmx" emerge transcode
Back to top
View user's profile Send private message
nutznboltz
Apprentice
Apprentice


Joined: 23 Apr 2004
Posts: 239

PostPosted: Fri Mar 25, 2005 12:31 pm    Post subject: Reply with quote

This is not an MMX issue, it is a quicktime one.
That being said
Code:
USE="-quicktime" emerge transcode
will cut off your nose to spite your face.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Mar 25, 2005 12:48 pm    Post subject: Re: Solution: search! Reply with quote

Lion wrote:
A quick search found the following thread, just four days ago:
https://forums.gentoo.org/viewtopic-t-297721.html

Thanks Lion! Please follow up to that thread.

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum