Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kmix crashes often
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
rotux
n00b
n00b


Joined: 23 Dec 2003
Posts: 72

PostPosted: Sun Mar 20, 2005 8:36 am    Post subject: kmix crashes often Reply with quote

I hope someone can help me.
My kmix crashes when I close a program that plays a sound, when I start amarok and on other occassions. (Always with Signal 11) I use alsa-driver-1.0.8 and tested both 2.6.10-ck7 and 2.6.11-gentoo kernels. Happens on both, either with the built-in alsa drivers or the emerged 1.0.8.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4990
Location: Dark side of the mood

PostPosted: Sun Mar 20, 2005 12:02 pm    Post subject: Reply with quote

I have he same problem. KMix crashes systematically after a certain time (5-10 secs). I'm using kernel 2.6.9-r12. Here's a part of the stack dump:
Code:
[New Thread 16384 (LWP 17368)]
0xb6cb5318 in waitpid ()
   from /lib/libpthread.so.0
#0  0xb6cb5318 in waitpid () from /lib/libpthread.so.0

Do you use NPTL with your 2.6 kernel?

EDIT: I found this in a mandrake forum. The problem seems to be related to libalsa2 but there no such package in gentoo, I think. The latest version of alsa-lib is 1.0.8.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!


Last edited by VinzC on Sun Mar 20, 2005 12:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
rotux
n00b
n00b


Joined: 23 Dec 2003
Posts: 72

PostPosted: Sun Mar 20, 2005 12:19 pm    Post subject: Reply with quote

Yes, I use NPTL. And i forgot to mention that I use emu10k1 (sblive).
And by the way, kmix works flawlessly with OSS (So I'll stick to that for now.....)
Back to top
View user's profile Send private message
saebla
n00b
n00b


Joined: 05 May 2004
Posts: 48
Location: Sweden

PostPosted: Tue Mar 22, 2005 9:45 am    Post subject: Reply with quote

rotux wrote:
Yes, I use NPTL. And i forgot to mention that I use emu10k1 (sblive).
And by the way, kmix works flawlessly with OSS (So I'll stick to that for now.....)


I just want to say I have the exact same problem. I have sblive and kmix crashes all the time, 5-10 just like yours.
The problem started some emerge -u some week ago. but I don't remember what I upgraded, not any kde packs anyway..

I don't know if I run NPTL, how do I see that? i checked trough the kernel config (2.6.11, vanilla), didn't find any?
_________________
Where we're going.. we don't need roads..
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4990
Location: Dark side of the mood

PostPosted: Tue Mar 22, 2005 9:55 am    Post subject: Reply with quote

saebla wrote:
I don't know if I run NPTL, how do I see that? i checked trough the kernel config (2.6.11, vanilla), didn't find any?


It's in your USE flags. If you have a 2.6 kernel, check your make.conf for USE="... nptl...".

EDIT: you can check glibc was compiled with NPTL. See the wiki.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
saebla
n00b
n00b


Joined: 05 May 2004
Posts: 48
Location: Sweden

PostPosted: Tue Mar 22, 2005 10:06 am    Post subject: Reply with quote

aah thanks.. well I don't have it enabled.. wich brings me to the next question.. I want to enable it, how? I mean is there alot of packages I have to reemerge ?

edit: ok I didn't read your post correctly.. I've followed the link now ,)
_________________
Where we're going.. we don't need roads..
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4990
Location: Dark side of the mood

PostPosted: Tue Mar 22, 2005 10:13 am    Post subject: Reply with quote

saebla wrote:
I want to enable it, how? I mean is there alot of packages I have to reemerge ?

See my previous post for how to update. I've just EDITed the message. There are a couple of articles at the Wiki on how to install Gentoo and migrate.

GLIBC is the biggest package. On my laptop (Centrino 1.5 GHz) it took about 6 hours to just compile it 8O . But I might have missed some optimization steps. Anyway only a rebuild world with emerge -avuD --newuse world is enough after you have added nptl and nptlonly to your use flags.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
baraquda
n00b
n00b


Joined: 06 Jun 2004
Posts: 15
Location: München

PostPosted: Tue Mar 22, 2005 12:11 pm    Post subject: Reply with quote

Which version of alsa do you have installed? I had the same Problem (also xine not working) and I had alsa 1.0.8. I downgraded to alsa 1.0.7 and everything works fine (=> bug in alsa 1.0.8?)
_________________
______________________________________
Glaube mit dem gutem im Menschen und
Rechne mit dem schlechten in ihm
F. Dürrenmatt
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4990
Location: Dark side of the mood

PostPosted: Tue Mar 22, 2005 12:14 pm    Post subject: Reply with quote

baraquda wrote:
Which version of alsa do you have installed? I had the same Problem (also xine not working) and I had alsa 1.0.8. I downgraded to alsa 1.0.7 and everything works fine (=> bug in alsa 1.0.8?)

It might sound like these troubles come with ALSA 1.0.8. I'll try downgrading.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4990
Location: Dark side of the mood

PostPosted: Tue Mar 22, 2005 9:29 pm    Post subject: Reply with quote

Downgraded alsa-lib to version 1.0.7, alsa-headers to 1.0.7 and alsa-utils to 1.0.6 (had no 1.0.7). No more crash.

Thanks.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Mar 30, 2005 10:03 am    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-313030.html

Moved from Multimedia.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum