Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
glibc-2.3.4 (?) causes ALSA apps to segfault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
DrSpirograph
n00b
n00b


Joined: 05 Apr 2003
Posts: 69

PostPosted: Mon Mar 21, 2005 10:39 am    Post subject: glibc-2.3.4 (?) causes ALSA apps to segfault Reply with quote

As part of my weekly upgrade of world I did the following
Code:
emerge gnuconfig gettext sys-apps/texinfo m4 miscfiles cracklib pango glibc
openslp mysql openssh tunepimp usbutils opensp docbook-xsl-stylesheets device-ma
pper cryptsetup cdrtools net-tools rsync clamav

and since then all apps that use alsa sound segfault.

Apps using OSS (as in alsa's OSS emulation) are not affected.

XMMS plays fine, until something else tries to play sound (even if it's using OSS not ALSA) then XMMS segfaults.
XINE segfaults as soon as it tries to play sound.

XMMS and XINE can play using OSS output without problems

MPlayer is the only one that doesn't seem to suffer. (it defaults to OSS, but even if I force it to ALSA it still doesn't segfault)

I've tried remerging xine, and I've since upgraded XMMS with
Code:
emerge xmms xmms-vorbis xmms-jack xmms-oss xmms-alsa xmms-wav


But they're still problematic.

Any suggestions?
Back to top
View user's profile Send private message
tomvollerthun
Guru
Guru


Joined: 19 Mar 2005
Posts: 316

PostPosted: Mon Mar 21, 2005 11:27 am    Post subject: Reply with quote

Might well be that your problems come from upgrading the glibc.
I had problems after the upgrade as well.
Search the forums for glibc, somewhere is a thread on how to properly upgrade the toolchain (part of which is glibc).

To boil it all down to one (and a half) line:
Quote:
emerge linux26-headers && emerge linux26-headers glibc && emerge glibc binutils gcc && \
emerge binutils gcc

This should do the magic, according to what I've read.

But in another thread I found that combining the USE of "nptl" and not "nptlonly" (like, only having nptl in your USE flags) gives trouble.
It certainly did for me! After adding nptlonly to my USE flags (and rebuilding the toolchain the 3rd time) I was done.

Now everything's fine again.

hth, tom
_________________
Computer science is no more about computers than astronomy is about telescopes.
Dijsktra
---------------
Don't believe my "Guru" status!
Back to top
View user's profile Send private message
DrSpirograph
n00b
n00b


Joined: 05 Apr 2003
Posts: 69

PostPosted: Fri Mar 25, 2005 12:31 am    Post subject: Reply with quote

I did the emerges you suggested, followed by
Quote:
emerge alsa-headers alsa-lib alsa-jack alsa-oss alsa-utils xmms xmms-mikmod xmms-mad xmms-oss xmms-wav xmms-arts xmms-vorbis xine-lib xine-ui

but the problem still persists.
Back to top
View user's profile Send private message
tomvollerthun
Guru
Guru


Joined: 19 Mar 2005
Posts: 316

PostPosted: Fri Mar 25, 2005 7:16 am    Post subject: Reply with quote

DrSpirograph wrote:
I did the emerges you suggested <snip> but the problem still persists.

Sorry to hear that.
I'm afraid that I don't have a clue what's with your box.
_________________
Computer science is no more about computers than astronomy is about telescopes.
Dijsktra
---------------
Don't believe my "Guru" status!
Back to top
View user's profile Send private message
Amaranatha
n00b
n00b


Joined: 30 Nov 2004
Posts: 48
Location: Spain, Europe

PostPosted: Fri Mar 25, 2005 12:01 pm    Post subject: Reply with quote

Have you tried downgrading alsa? It's explained here:

https://forums.gentoo.org/viewtopic-t-313030.html

I had the same problem, and solved it this way ( masking alsa-libs-1.0.8 ).

Good luck!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sat Mar 26, 2005 9:39 am    Post subject: Reply with quote

Moved from Multimedia.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum