Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange err: absent firefox version conflicts with freetype
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
The_Saint
Tux's lil' helper
Tux's lil' helper


Joined: 15 Mar 2004
Posts: 108

PostPosted: Tue Mar 22, 2005 11:33 am    Post subject: Strange err: absent firefox version conflicts with freetype Reply with quote

Hi. I am trying for days to update my system and I cannot figure out what I am doing wrong.

When trying to
Code:
emerge --update world

I get this conflict:
Code:
!!! Error: the <www-client/mozilla-firefox-1.0-r3 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

Using --pretend I get a list which contains the following:
Code:
[blocks B     ] <www-client/mozilla-firefox-1.0-r3 (is blocking media-libs/freetype-2.1.9-r1)
...
[ebuild     U ] media-libs/freetype-2.1.9-r1 [2.1.5-r1]
...
[ebuild     U ] www-client/mozilla-firefox-1.0.1 [1.0]

As you see I have NOT installed mozilla-firefox-1.0-r3. I have installed the 1.0 version and emerge tries to upgrade into 1.0.1.
I have verified that packages:
    mozilla-firefox-1.0.1
    mozilla-firefox-1.0
    freetype-2.1.9-r1
    freetype-2.1.5-r1
...are all stable under x86 (which is the architecture I use).

mozilla-firefox-1.0-r3 is not stable under x86 but it shouldn΄t matter, since I have nothing to do with it.

So, what΄s wrong?
Back to top
View user's profile Send private message
psii
n00b
n00b


Joined: 15 Nov 2004
Posts: 9

PostPosted: Tue Mar 22, 2005 1:59 pm    Post subject: Reply with quote

It's alright.

I know that Firefox doesn't like Freetype >= 2.1.7. FreeType changed the API (removed some deprecated calls) and Firefox still uses them...

That's very annoying because I can't get GIMP 2.2.x and Firefox installed on the same machine :(
Back to top
View user's profile Send private message
The_Saint
Tux's lil' helper
Tux's lil' helper


Joined: 15 Mar 2004
Posts: 108

PostPosted: Tue Mar 22, 2005 2:30 pm    Post subject: Reply with quote

Even so, the question remains:
How come it complains for a package that I have not installed and I am not trying to install either?
Back to top
View user's profile Send private message
escitalopram
n00b
n00b


Joined: 05 Feb 2004
Posts: 60

PostPosted: Tue Mar 22, 2005 2:43 pm    Post subject: Reply with quote

i got firefox and gimp 2.2 to run on the same computer by manually compiling gimp and the new freetype and installing it to /usr/local
Back to top
View user's profile Send private message
mlsfit138
Guru
Guru


Joined: 20 Sep 2003
Posts: 406
Location: Washington

PostPosted: Tue Mar 22, 2005 8:47 pm    Post subject: Reply with quote

The_Saint wrote:
Even so, the question remains:
How come it complains for a package that I have not installed and I am not trying to install either?


No solution here, just wanted you to know that I'm in the same boat. I'd install manually, but i (generally) prefer having portage manage my packages.
_________________
"Everytime you justify
another good in you dies"

-Converge, The Saddest Day, Petitioning the Empty Sky
Back to top
View user's profile Send private message
Geshtar
n00b
n00b


Joined: 24 Aug 2004
Posts: 46

PostPosted: Wed Mar 23, 2005 4:32 am    Post subject: Reply with quote

Giving this a bump since I am having the same problem and was not getting any responses in my thread.

The firefox error is exactly the same on mine. This firefox portage bug basically prevents upgrading/installing any package that has a graphical user interface from what I can determine so far. It is very annoying. I also have an error with the same behavior (unused package blocking stuff) with Xorg and opengl-update.

I have searched on bugzilla and have not seen anything that directly pertains to this error that is being encountered, though I have seen several posts in the forums on it (none have any sort of solution so far). There is one bug that has to do with mozilla and freetype listed but I do not think it is neccessarily the same error (it might be, who knows. search in bugzilla with 'mozilla freetype' It should be the only entry that pops up.) I would post a bug report on my own but I am still a noob and don't want to be posting bugs and stuff when I don't completely understand whats going on.

Short of a solution, can anyone atleast give an idea on why this is happening? On one bugzilla entry on mozilla and freetype, it suggested that mozilla was using function calls that had been deprecated and that is why it blocks. That however does not make much sense though since a package that is not installed and will not be installed is causing the block.

Frustrated,

-Geshtar
_________________
-Geshtar
(~_~)
Back to top
View user's profile Send private message
tewlz
n00b
n00b


Joined: 28 Sep 2002
Posts: 53

PostPosted: Wed Mar 23, 2005 1:49 pm    Post subject: Reply with quote

Any news on this? Same thing happening on my laptop...
Back to top
View user's profile Send private message
DaveArb
Guru
Guru


Joined: 29 Apr 2004
Posts: 510
Location: Texas, USA

PostPosted: Thu Mar 24, 2005 5:18 pm    Post subject: Reply with quote

I was able to brute force past the Mozilla/Freetype block by editing the ebuild by:

1) unmerging any mozilla-based packages. In my case, that was Firefox and Thunderbird.
2) commenting out the RDEPEND in the Freetype ebuild. This is maybe 5 lines around line 26 that look like
Code:

RDEPEND="${DEPEND}
    |<www-client/mozilla-1.7.3-r3
    |<www-client/mozilla-firefox-1.0-r3
    |<mail-client/mozilla-thunderbird-0.9-r3
    |<media-libs/libwmf-0.2.8.2"

Commented them out by placing a # at the beginning of each line.
3) Emerged freetype
4) (might have synced portage here, might not)
5) Emerged the mozilla packages again.

This isn't a machine I use every day, but it seems to be working OK after this, I've run Firefox, Mozilla, and the Gimp successfully. I'm not a Portage hacker by any means, so proceed cautiously.

Dave
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Mar 24, 2005 5:25 pm    Post subject: Reply with quote

Please see this topic: https://forums.gentoo.org/viewtopic-t-294804.html

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum