Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GCC 3.4.3 Update error.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
sinetific
n00b
n00b


Joined: 05 Nov 2003
Posts: 26

PostPosted: Tue Mar 22, 2005 7:06 pm    Post subject: GCC 3.4.3 Update error. Reply with quote

I get this error while emerging gcc during an emerge -u system
Code:

/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/../../libc.so when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/../../libc.a when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: cannot find -lc
collect2: ld returned 1 exit status
make[3]: *** [32/libgcc_s_32.so] Error 1
make[3]: Leaving directory `/var/tmp/portage/gcc-3.4.3.20050110-r1/work/build/gcc'
make[2]: *** [stmp-multilib] Error 2
make[2]: Leaving directory `/var/tmp/portage/gcc-3.4.3.20050110-r1/work/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.3.20050110-r1/work/build/gcc'
make: *** [profiledbootstrap] Error 2

!!! ERROR: sys-devel/gcc-3.4.3.20050110-r1 failed.
!!! Function gcc_do_make, Line 1165, Exitcode 2
!!! make failed with profiledbootstrap
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
seyanora
n00b
n00b


Joined: 29 Oct 2004
Posts: 23
Location: Karlsruhe, Germany

PostPosted: Tue Mar 22, 2005 7:13 pm    Post subject: Reply with quote

same problem here :oops:
Back to top
View user's profile Send private message
Scottix
n00b
n00b


Joined: 11 Mar 2005
Posts: 57

PostPosted: Wed Mar 23, 2005 5:38 pm    Post subject: Reply with quote

Same Problem
Back to top
View user's profile Send private message
sinetific
n00b
n00b


Joined: 05 Nov 2003
Posts: 26

PostPosted: Wed Mar 23, 2005 11:10 pm    Post subject: Reply with quote

Hmm I read another thread and it seems there is a problem using multilib with the new version of GCC
Code:

USE="-multilib" emerge gcc

That seems to solve the problem and allows you to update, But I wonder if this will cause problems with any of the programs compiled with multilib?
Back to top
View user's profile Send private message
seyanora
n00b
n00b


Joined: 29 Oct 2004
Posts: 23
Location: Karlsruhe, Germany

PostPosted: Wed Mar 23, 2005 11:38 pm    Post subject: Reply with quote

yes ... i don't think it's a good solution .. have to wait ...
Back to top
View user's profile Send private message
brankob
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 183

PostPosted: Thu Mar 24, 2005 4:34 am    Post subject: Reply with quote

Sh*t.

I was just about to ask why all of the sudden I was left without "multilib" in the newest 2005.0 profile.

use.mask specifically disables it and LDPATH from /etc/env.d/04multilib is ignored


:roll:
Back to top
View user's profile Send private message
ziegs
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 119

PostPosted: Thu Mar 24, 2005 5:39 am    Post subject: Reply with quote

i had a similar problem. in order to fix it, make sure your symlinks to the 32-bit libs are correct. this is assuming you're using a 2004.3 profile, otherwise go back to the 2004.3 profile for now and reupgrade to it later as per the technotes.

make sure that /lib32 is a symlink pointing to /emul/linux/x86/lib and the /usr/lib32 is pointing to /emul/linux/x86/usr/lib

if you want to be sure they are you can do the following:

Code:
rm /lib32 /usr/lib32
ln -s /emul/linux/x86/lib /lib32
ln -s /emul/linux/x86/usr/lib /usr/lib32


also make sure your emul-* libraries are all installed and current. do an emerge search on them i guess, i don't remember which packages to re-emerge. after that try a merge of gcc:
Code:
USE="multilib" FEATURES="-sandbox" emerge gcc


that did it for me anyway and i had the exact same error message. theres a post about it on the forums somewhere, but its hard to find using the search terms you'd expect to use...but thats defintely what i did to fix it (did it last night).

EDIT: here's where i found it. https://forums.gentoo.org/viewtopic-p-2202085.html#2202085
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Mar 25, 2005 2:13 pm    Post subject: Reply with quote

ziegs wrote:
EDIT: here's where i found it. https://forums.gentoo.org/viewtopic-p-2202085.html#2202085


Moved from Gentoo on AMD64.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum