Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aaaargh !!!! Nvidia 2.6.11-r4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jerrykenny
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2005
Posts: 105

PostPosted: Wed Mar 23, 2005 12:26 am    Post subject: Aaaargh !!!! Nvidia 2.6.11-r4 Reply with quote

Aaargh ! :evil:

Nvidia :evil:

Ok heres what wont work for me . . .

Recompiling with/without nvidia Riva support
" " " SMP
" " " framebuffer/vesa
" " " 4k stacks
" " " agpgart module

nor will @emerge unmerge nvidia-kernel, or emerge sync, or emerge unmerge nvidia-glx. or making sure my linux symlink is pointing where its supposed to point . or downloading Nvidias driver, modprobing -q agpgart, and sh' ing NVIDIA whatever . . . . even when I tell the nvidia installer where exactly and what my kernel is called I always get .


nowhere FATAL: Error inserting nvidia (/lib/modules/2.6.11-gentoo-r4/kernel/drivers/video/nvidia.ko): Invalid module format


Apparently all my attempts have produced modules in an invalid format


So I'm off to bed


Disgusted


and what does this mean ? (from my dmesg)
nvidia: version magic '2.6.11-gentoo-r4 preempt PENTIUM4 4KSTACKS gcc-3.4' shoul d be '2.6.11-gentoo-r4 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'
nvidia: version magic '2.6.11-gentoo-r4 preempt PENTIUM4 4KSTACKS gcc-3.4' shoul d be '2.6.11-gentoo-r4 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'
nvidia: version magic '2.6.11-gentoo-r4 preempt PENTIUM4 4KSTACKS gcc-3.4' shoul d be '2.6.11-gentoo-r4 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'
nvidia: version magic '2.6.11-gentoo-r4 preempt PENTIUM4 4KSTACKS gcc-3.4' shoul d be '2.6.11-gentoo-r4 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'
nvidia: version magic '2.6.11-gentoo-r4 preempt PENTIUM4 4KSTACKS gcc-3.4' shoul d be '2.6.11-gentoo-r4 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'
Quote:

_________________
Hopeless tinkerer with things that are best left alone
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Wed Mar 23, 2005 2:43 am    Post subject: Re: Aaaargh !!!! Nvidia 2.6.11-r4 Reply with quote

jerrykenny wrote:
nvidia: version magic '2.6.11-gentoo-r4 preempt PENTIUM4 4KSTACKS gcc-3.4' shoul d be '2.6.11-gentoo-r4 SMP preempt PENTIUM4 4KSTACKS gcc-3.3'


Tells me that you need to re-compile the nvidia-kernel with the compiler you used to compile your kernel. Whenever you change kernel versions or use a new compiler to compile your kernel you will have to re-emerge the nvidia-kernel.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
jerrykenny
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2005
Posts: 105

PostPosted: Wed Mar 23, 2005 8:44 am    Post subject: Reply with quote

Yes but I've recompiled both kernel and nvidia, many times , usually within minutes of each other . . . . the whole system is up-to-date, so why should it decide to use gcc3.3 then change its mind and use gcc3.4 ?
_________________
Hopeless tinkerer with things that are best left alone
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Sep 20, 2005 5:07 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Duplicate Threads in favour of 'modprobe nvidia' fails.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum