Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ERROR 15 : File not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
thoray
n00b
n00b


Joined: 23 Mar 2005
Posts: 18

PostPosted: Wed Mar 23, 2005 9:21 pm    Post subject: ERROR 15 : File not found Reply with quote

i have just installed Gentoo from live cd.

fdisk

/dev/hda1 1 14 105808+ 83 Linux
/dev/hda2 15 81 506520 82 Linux swap
/dev/hda3 82 3876 28690200 83 Linux

/etc/fstab

/dev/BOOT /boot hda1 noauto,noatime 1 2
/dev/ROOT / hda3 noatime 0 1
/dev/SWAP none hda2 sw 0 0
/dev/cdroms /mnt/cdrom iso9660 noauto,ro 0 0
proc /proc proc defaults 0 0


grub> root (hd0,0)
grub> setup (hd0)
grub> quit


/boot/grub/grub.conf

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux(genkernel)
root (hd0,0)
kernel (hd0,0)/boot/kernel-KV root=/dev/hda3
initrd (hd0,0)/boot/initrd-KV


/etc/lilo.conf

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
lba32
default=linux

image=/boot/kernel-KV
label=gk_linux
root=/dev/hda3
initrd=/boot/initrd-KV
append="root=/dev/hda3 init=/linuxrc"



*******************************************************

but now when i startup i get this.

i get mine login "Gentoo Linux.

when i click on this he not boot.

root (hd0,0)
filesystem type is ext2f's partition type 0x83
kernel (hd0,0)/boot/kernel/-KV root=/dev/hda3

ERROR 15 : File not found

what i have make wrong so i have just read from the manual from the page or i make some mistakes.
but i just wanted to know how to fixed and to let it run

thank you
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 597
Location: east coast USA

PostPosted: Wed Mar 23, 2005 9:24 pm    Post subject: Reply with quote

well for one you need to choose either lilo or grub.
i recommend grub as it seems to be more popular among gentoo users.
Back to top
View user's profile Send private message
thoray
n00b
n00b


Joined: 23 Mar 2005
Posts: 18

PostPosted: Wed Mar 23, 2005 9:29 pm    Post subject: Reply with quote

ok i have reboot the systeem again and make boot from cd again so what i must make and doing to help this problem to make out

must i start from begin to make how it explain on gentoo site or what must i do

thank you


Last edited by thoray on Wed Mar 23, 2005 9:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
tukachinchila
Apprentice
Apprentice


Joined: 11 Mar 2005
Posts: 274
Location: Oregon

PostPosted: Wed Mar 23, 2005 9:29 pm    Post subject: Reply with quote

Your fstab needs some changes too:
Quote:
/dev/BOOT /boot hda1 noauto,noatime 1 2
/dev/ROOT / hda3 noatime 0 1
/dev/SWAP none hda2 sw 0 0
proc /proc proc defaults 0 0

Should be:
Code:
/dev/hda1 /boot ext2 noauto,noatime 1 2
/dev/hda3 / ext2 noatime 0 1
/dev/hda2 none swap sw 0 1
none /proc proc defaults 0 1
Back to top
View user's profile Send private message
tukachinchila
Apprentice
Apprentice


Joined: 11 Mar 2005
Posts: 274
Location: Oregon

PostPosted: Wed Mar 23, 2005 10:02 pm    Post subject: Reply with quote

I'm not 100% about grub, but if you choose it as your bootloader I would keep it simple and set it up like this:
Code:
default 0
timeout 30

title Gentoo Linux (genkernel)
root (hd0,0)
kernel /kernel-KV root=/dev/hda3
initrd /initrd-KV


Be sure that the file /boot/kernel-KV exists, and that /boot/initrd-KV exists.
Back to top
View user's profile Send private message
Bob P
Advocate
Advocate


Joined: 20 Oct 2004
Posts: 3355
Location: Jackass! Development Labs

PostPosted: Wed Mar 23, 2005 10:08 pm    Post subject: Reply with quote

have you looked at the Grub Error Collection?

https://forums.gentoo.org/viewtopic-t-122656.html
_________________
.
Stage 1/3 | Jackass! | Rockhopper! | Thanks | Google Sucks
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Mar 23, 2005 10:48 pm    Post subject: Reply with quote

Bob P wrote:
have you looked at the Grub Error Collection?

https://forums.gentoo.org/viewtopic-t-122656.html

Or the sanitised version: http://www.gentoo.org/doc/en/grub-error-guide.xml. As you might guess, this is a very common question. :wink:

Moved from Installing Gentoo.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum