Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Seg fault at end of glibc compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
immudium
Guru
Guru


Joined: 12 Oct 2004
Posts: 332
Location: Utah

PostPosted: Thu Mar 24, 2005 10:13 pm    Post subject: Seg fault at end of glibc compile Reply with quote

I am trying to perform a toolchain rebuild from a stage 3 install and glibc keeps Seg faulting at the same spot every time and I can't seem to track down what the problem is. When it fails, it looks like glibc is finished compiling but can't figure out where to copy something to. The bottom of the error is:
Code:
shell-init: could not get current directory: getcwd: cannot access parent directories: No such file or directory
 * Installing Info pages...
make -r PARALLELMFLAGS="-j2" CVSOPTS="" -C /var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3 objdir=`pwd` info
make[1]: Entering directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3'
make -j2 -C manual info
make[2]: Entering directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3/manual'
make[2]: Nothing to be done for `info'.
make[2]: Leaving directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3/manual'
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3'
 * Installing locales in /etc/locales.build...
make -r PARALLELMFLAGS="-j2 -j1" CVSOPTS="" -C /var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3 objdir=`pwd` localedata/install-locales
make[1]: Entering directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3'
make -j2 -j1 -C localedata install-locales
make[2]: Entering directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3/localedata'
.././scripts/mkinstalldirs /var/tmp/portage/glibc-2.3.4.20041102-r1/image//usr/lib/locale
mkdir /var/tmp/portage/glibc-2.3.4.20041102-r1/image/usr/lib/locale
en_US.ISO-8859-1... done
en_US.UTF-8... done
make[2]: Leaving directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3/localedata'
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3'
 * Installing man pages and docs...
/usr/lib/portage/bin/ebuild.sh: line 1732: 17383 Segmentation fault      env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} >/dev/null

!!! ERROR: sys-libs/glibc-2.3.4.20041102-r1 failed.
!!! Function src_install, Line 1008, Exitcode 139
!!! simple run test (ls) failed
!!! If you need support, post the topmost build error, NOT this status message.


And my make.conf consists of:
Code:

# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
#CFLAGS="-O2"
#CHOST="x86_64-pc-linux-gnu"
#CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64"
CXXFLAGS=${CFLAGS}
# "amd64" refers to the stable  software branch
# "~amd64" refers to the testing software branch
ACCEPT_KEYWORDS="amd64"
PORTAGE_TMPDIR=/var/tmp
PORTDIR=/usr/portage
DISTDIR=${PORTDIR}/distfiles
PKGDIR=${PORTDIR}/packages
PORT_LOGDIR=/var/log/portage
PORTDIR_OVERLAY=/usr/local/portage
GENTOO_MIRRORS="http://mirror.usu.edu/mirrors/gentoo/ http://cudlug.cudenver.edu/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://gentoo.netnitco.net/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT=180
MAKEOPTS="-j2"
PORTAGE_NICENESS=3
AUTOCLEAN="yes"
FEATURES="sandbox ccache distlocks"
CCACHE_SIZE="512M"
RSYNC_EXCLUDEFROM=/etc/portage/rsync_excludes
USE="acpi cups ithreads ldap multilib nls nptl pam pthreads python readline samba ssl tcpd"


I've read the technotes at http://www.gentoo.org/proj/en/base/amd64/technotes.xml?part=0&chap=0 several times, but perhaps I'm not connecting the dots properly. I am basically following the install Stage 1 from a stage 3 guide at https://forums.gentoo.org/viewtopic-t-274968.html and am at the point of doing the initial
Code:
emerge gcc-config glibc binutils gcc
toolchain build. I booted from the Athlon 64 2004.3 minimal LiveCD using "gentoo noapic". Oh and if it's helpful, I am using an NForce4 board, the MSI K8N Neo4 with drivers forcedeth and sata_nv. Can anyone offer any advice? Do I need to install the emul-linux-* libraries first? I am sorry if this is a dumb question. I've spent two days on it and I just don't see what I'm doing wrong. Thank you.
Back to top
View user's profile Send private message
noup
l33t
l33t


Joined: 21 Mar 2003
Posts: 917

PostPosted: Fri Mar 25, 2005 3:34 am    Post subject: Reply with quote

sorry, but you should have searched a little before posting. there are some threads and a bug report related to this. check this and this. you can get even more threads by searching for "glibc", but i don't think there is a solution ATM.
_________________
noup.
Back to top
View user's profile Send private message
immudium
Guru
Guru


Joined: 12 Oct 2004
Posts: 332
Location: Utah

PostPosted: Fri Mar 25, 2005 4:59 am    Post subject: Reply with quote

Oh geez, I swear those weren't there when I was banging my head against the problem at 3 AM. I should have searched again when I got up. I would have discovered that the bug fairy had visited. Talk about launching a big air ball with this one. Must be March madness or something. Sorry for the duplicate post. And thank you for taking the time to help me out.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Mar 25, 2005 2:10 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-313432.html

Moved from Gentoo on AMD64.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum