Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-lisp/openmcl build failure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
n2kra
n00b
n00b


Joined: 22 Jun 2003
Posts: 21
Location: East Coast, USA

PostPosted: Fri Mar 25, 2005 2:01 am    Post subject: dev-lisp/openmcl build failure Reply with quote

Yea! It's here - checks /usr/local/bin - nope don't have the binary installed on this machine
(original iBook) I thought I would try here in the forums first, In case I was just doing
something stupid. And registering for bugzilla seems a little intimidating - so


emerge -pv dev-lisp/openmcl
(also updates C-L-C from 3.something to 4 - previous from clisp)

masked by ~ppc

(Oops! append >> /dir/file, not overwrite >)
echo dev-lisp/openmcl ~ppc >> /etc/portage/package.keywords

emerge -pv dev-lisp/openmcl

dependency masked by ~ppc

echo dev-lisp/openmcl-build-tools ~ppc >> /etc/portage/package.keywords


emerge dev-lisp/openmcl


make[1]: Leaving directory `/var/tmp/portage/openmcl-0.14.2_p1/work/openmcl-0.14.2.p1/lisp-kernel/linux'
CCL_DEFAULT_DIRECTORY=/var/tmp/portage/openmcl-0.14.2_p1/work/openmcl-0.14.2.p1 ./ppccl --image-name /usr/lib/openmcl/PPCCL-orig --batch --no-init < debian/make-bootstrap.lisp
make: *** [all] Error 139

the ppccl loader by itself says - Couldn't load lisp heap image from ...
it only segment faults when you try include a PPCCL-orig image

I also tried knocking down the CFLAGS to nothing - ""

---

bugzilla info -

Summary: dev-lisp/openmcl build failure

Details: (above - make error 139 on ppccl PPCCL-orig < deb/make-bootstrap)

Reproducibility: Every Time

Actual Result: (same)

Expected Result: CL goodness :-)


Emerge Info -

Gentoo Base System version 1.4.16
Portage 2.0.51.19 (default-linux/ppc/2004.1, gcc-3.4.3, glibc-2.3.4.20041102-r1,
2.6.10-gentoo-r6 ppc)
=================================================================
System uname: 2.6.10-gentoo-r6 ppc 740/750
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 22 2005, 22:04:00)
]
dev-lang/python: 2.3.4-r1
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.8.5-r3, 1.5, 1.7.9-r1, 1.6.3, 1.4_p6, 1.9.4
sys-devel/binutils: 2.15.90.0.3-r3
sys-devel/libtool: 1.5.10-r4
virtual/os-headers: 2.4.22
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=750 -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/s
hare/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=750 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com http://gentoo.oregonstate.edu htt
p://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X alsa berkdb bidi bitmap-fonts canna cdr cjk cups dga dvd emacs emboss faa
d fbcon ffmpeg font-server foomaticdb fortran freewnn gdbm gif gpm gtk imlib jpe
g matroska motif mp3 mpeg ncurses nls opengl oss pam perl png ppc ppds python qu
icktime readline samba scanner sdk sdl sheep softmmu ssl stream streamout tcpd t
hreads tiff truetype truetype-fonts type1-fonts unicode usb vcd vnc wxwindows xm
ms xprint xv zlib video_cards_rage64"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
robbar
Apprentice
Apprentice


Joined: 21 Aug 2004
Posts: 156
Location: Saarbruecken, Germany

PostPosted: Tue Mar 29, 2005 10:45 am    Post subject: Reply with quote

You have to name the masked packages in two files: /etc/portage/package.unmask and /etc/portage/package.keywords like this
Code:
>=group/package-version
for package.unmask and
Code:
>=group/package-version ~keyword

In your case keyword should be ppc. For further advice, look here http://gentoo-wiki.com/HOWTO_Use_Portage_Correctly


Last edited by robbar on Fri Apr 01, 2005 8:04 am; edited 1 time in total
Back to top
View user's profile Send private message
n2kra
n00b
n00b


Joined: 22 Jun 2003
Posts: 21
Location: East Coast, USA

PostPosted: Fri Apr 01, 2005 6:52 am    Post subject: dev-lisp.openmcl needs 2.4 ? Reply with quote

robbar wrote:
You have to name the masked packages in two files: /etc/package.unmask and /etc/package.keywords like this...


/etc/portage/package.*

---

no, it started to build, but failed. My laptop is a 2.6 kernel. It did build
on a 2.4 machine I haven't updated in a while, and this might be why -

file /usr/lib/openmcl/ppccl
/usr/lib/openmcl/ppccl: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), for GNU/Linux 2.4.1, dynamically linked (uses shared libs), stripped

I tried copying from the 2.4 to 2.6 and it seg faults, I'm not surprised, I thought a
built-from-scratch openmcl would need gcc 2.9<last> (as well as a CL)
or is that for the (C / OS) interface (FFIgen) ?

I'm gunna try to update (emerge world) the 2.4 then rebuild openmcl
Back to top
View user's profile Send private message
robbar
Apprentice
Apprentice


Joined: 21 Aug 2004
Posts: 156
Location: Saarbruecken, Germany

PostPosted: Fri Apr 01, 2005 8:04 am    Post subject: Reply with quote

You're right with /etc/portage/package.* I corrected it above.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum