Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem updating glibc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
john7002
Apprentice
Apprentice


Joined: 21 Jan 2004
Posts: 238
Location: United Kingdom

PostPosted: Sun Mar 27, 2005 7:24 pm    Post subject: problem updating glibc Reply with quote

hello,

i have a problem with an emerge -u world when my laptop compiles glibc here is the result:

Code:


make[2]: Leaving directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3/localedata'
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.4.20041102-r1/work/glibc-2.3.3'
 * Installing man pages and docs...
/usr/lib/portage/bin/ebuild.sh: line 1874:  6462 Erreur de segmentation  env LD_LIBRARY_PATH="${D}/$(get_libdir)" ${x} >/dev/null

!!! ERROR: sys-libs/glibc-2.3.4.20041102-r1 failed.
!!! Function src_install, Line 1008, Exitcode 139
!!! simple run test (ls) failed
!!! If you need support, post the topmost build error, NOT this status message.



i am using gcc v3.3.5 with 2.6.10-gentoo-r6 kernel. Anyone has an idea about how to fix that???
_________________
la vrai bouffe me manque!!
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Sun Mar 27, 2005 8:47 pm    Post subject: Reply with quote

have you tried
Code:
emerge sync
and then
Code:
emerge glibc
?
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
kiwiman555
n00b
n00b


Joined: 25 Mar 2005
Posts: 2
Location: Troy, NY

PostPosted: Sun Mar 27, 2005 9:30 pm    Post subject: Reply with quote

I have a similar problem on my machine. emerge sync then emerge glibc throws the same error (in english for me though ;) )

This is after emerge -uD world
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Sun Mar 27, 2005 11:24 pm    Post subject: Reply with quote

Quote:

glibc should be fixed, sync up

this is on #gentoo @ freenode on the topic, its a known issue
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
Tron_5
n00b
n00b


Joined: 19 May 2004
Posts: 13

PostPosted: Mon Mar 28, 2005 12:11 am    Post subject: Reply with quote

had the same prob.
will try resyncing!
thanks!
Back to top
View user's profile Send private message
kiwiman555
n00b
n00b


Joined: 25 Mar 2005
Posts: 2
Location: Troy, NY

PostPosted: Mon Mar 28, 2005 1:00 am    Post subject: Reply with quote

resynching worked, sweet deal.
Thanks Devs!
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Mon Mar 28, 2005 11:56 am    Post subject: Reply with quote

Sweet, Get The topic Fixed too, its a simple issue :P
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Mar 28, 2005 12:16 pm    Post subject: Reply with quote

Please see this topic: https://forums.gentoo.org/viewtopic-t-313432.html

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum