Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updating to 2005.0 error on reboot!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
robbz
n00b
n00b


Joined: 27 Mar 2005
Posts: 33

PostPosted: Tue Mar 29, 2005 4:38 am    Post subject: Updating to 2005.0 error on reboot!!! Reply with quote

Here's my problem, I updated from 2004.3 to 2005.0 by folowing the instructionfromt he update page which is below:
# rm /etc/make.profile
# ln -s ../usr/portage/profiles/default-linux/x86/2005.0 /etc/make.profile

I may have screwed up when did this after, I wanted to make sure things were up to date:
# emerge --update --deep --newuse world
# emerge --depclean
# revdep-rebuild

When I rebooted, I get errors are
* Mounting devpts at /devpts...
* Starting devfsd
/sbin/rc: line 271: /sbin/devfsd: No such file or directory

* Activating (possible) swap...
* Remounting root fielsystem read-only (if necessary)...
* Checking root filesystem...
Failed to open the device '/dev/hda': No such file or directory

* Filesystem couldn't be fixed :(

Give root password for maintenance
(or type Control-D for normal startup):
/dev/hda4 is my / partition which is reiserfs.
_________________
RD
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Tue Mar 29, 2005 4:51 am    Post subject: Reply with quote

I believe that udev is replacing devfs with 2005.0, so devfsd probably got unmerged with your depclean. You have two choices, both require booting off the LiveCD and chrooting.

1. Re-emerge devfs

2. Setup udev. A bit harder but still really easy. Just see here: http://www.gentoo.org/doc/en/udev-guide.xml
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
robbz
n00b
n00b


Joined: 27 Mar 2005
Posts: 33

PostPosted: Tue Mar 29, 2005 5:52 am    Post subject: Reply with quote

Ok, I booted from the live cd and re-emerged devfs (emerge devfsd) and things are back to normal, I tried setting up udev, but didn't work. I'll check it out tommorow as I don't want to have to do this again, if I do any updates again. If anyone has any good details on setting up udev, they can post for me, this is my second week into Gentoo, I'm loving it so far.
_________________
RD
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Tue Mar 29, 2005 6:06 am    Post subject: Reply with quote

After installing Gentoo setting up udev will be easy, just follow the steps described in the guide I linked to above. It's really that easy.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
gregw
Tux's lil' helper
Tux's lil' helper


Joined: 20 Nov 2004
Posts: 106
Location: Warrington, Cheshire, England

PostPosted: Tue Mar 29, 2005 10:28 am    Post subject: Re: Updating to 2005.0 error on reboot!!! Reply with quote

robbz wrote:
Here's my problem, I updated from 2004.3 to 2005.0 by folowing the instructionfromt he update page which is below:


Hi Robbz,

Can you post the link to the update page, I can only find the AMD64 instructions and need the x86 page for one of my machines.

Cheers
GregW

Sorry, I just stumbled on it. For anyone else, it is at
http://www.gentoo.org/doc/en/gentoo-upgrading.xml
Back to top
View user's profile Send private message
robbz
n00b
n00b


Joined: 27 Mar 2005
Posts: 33

PostPosted: Wed Mar 30, 2005 5:23 am    Post subject: Reply with quote

Ok, so I switched back to using udev instead of devfs and everything is fine now. I followed the instructions at http://www.gentoo.org/doc/en/udev-guide.xml, which is pretty straight forward. The only change I had to made was for my mouse in /etc/X11/xorg.conf. The change is below if anyone has the same problem.

Change :
Option "Device" "/dev/mouse"
to:
Option "Device" "/dev/input/mice"

From a little research the possible values are:
/dev/input/mice
/dev/input/mouse0
/dev/psaux
_________________
RD
Back to top
View user's profile Send private message
QuietStorm
n00b
n00b


Joined: 02 Aug 2004
Posts: 44
Location: Texas

PostPosted: Wed Mar 30, 2005 7:33 am    Post subject: THX Reply with quote

I just wanted to say thanks to DonJuan
I was having the same problem as the poster when doing a fresh Stage 1 install with the 2005.0 live cd
My first impression was it was an issue with fstab or my kernel config which i reconfigured several times.
After testing with emerge devfsd I was very pleased to see all green on boot. I just made me so happy I went back and unemerged devfsd and
Used the guide to setup udev
Thanks so much for your post. :D :D :idea: :D
Back to top
View user's profile Send private message
donjuan
l33t
l33t


Joined: 11 May 2004
Posts: 760
Location: At Uni

PostPosted: Thu Mar 31, 2005 11:49 pm    Post subject: Reply with quote

No problem.
_________________
Command-line ACCEPT_KEYWORDS is considered harmful, use the package.* files.

The Stage 1 on 3 Install
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Apr 04, 2005 2:36 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-315935.html

Moved from Installing Gentoo.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum