Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing kde 3.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Wed Mar 30, 2005 5:28 am    Post subject: installing kde 3.4 Reply with quote

Hi! i'm having a few problems installing kde 3.4

i think that i have installed just some packages from 3.4 and the others are still from 3.3.2 :?

thats what i get when i want to install or upgrade...

Quote:

bash-2.05b# emerge --pretend kde3.4
--- Invalid atom in /etc/portage/package.unmask: =netscape-flash-7.0.25

These are the packages that I would merge, in order:

Calculating dependencies
emerge: there are no ebuilds to satisfy "kde3.4".

bash-2.05b# emerge --pretend kde
--- Invalid atom in /etc/portage/package.unmask: =netscape-flash-7.0.25

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] =kde-base/kcheckpass-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdebase-startkde-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kcminit-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/ksplashml-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kwin-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kreadconfig-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kpersonalizer-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdesktop-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/ksmserver-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdebase-data-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kcontrol-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdm-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/libkonq-3.4* (is blocking kde-base/kdebase-3.4.0)
[ebuild N ] dev-libs/cyrus-sasl-2.1.20-r2
[ebuild NS ] kde-base/kdebase-3.4.0
[ebuild N ] kde-base/kdeartwork-3.4.0
[ebuild N ] kde-base/kdegames-3.4.0
[ebuild N ] dev-libs/pth-2.0.3
[ebuild N ] app-crypt/gpgme-1.0.2
[ebuild N ] kde-base/kdepim-3.4.0-r1
[ebuild N ] media-libs/t1lib-5.0.2
[ebuild N ] x11-libs/motif-config-0.8
[ebuild NS ] sys-devel/autoconf-2.13
[ebuild N ] sys-devel/autoconf-wrapper-2-r1
[ebuild U ] sys-devel/autoconf-2.59-r6 [2.59-r5]
[ebuild UD] sys-devel/automake-1.5 [1.8.5-r1]
[ebuild NS ] sys-devel/automake-1.8.5-r3
[ebuild NS ] sys-devel/automake-1.9.5
[ebuild NS ] sys-devel/automake-1.6.3
[ebuild NS ] sys-devel/automake-1.7.9-r1
[ebuild N ] sys-devel/automake-wrapper-1-r1
[ebuild NS ] sys-devel/automake-1.4_p6
[ebuild N ] x11-libs/openmotif-2.2.3-r6
[ebuild N ] app-text/xpdf-3.00-r8
[ebuild N ] dev-libs/fribidi-0.10.4
[ebuild N ] kde-base/kdegraphics-3.4.0
[ebuild N ] app-crypt/qca-1.0-r2
[ebuild N ] app-crypt/qca-tls-1.0-r2
[ebuild N ] kde-base/kdenetwork-3.4.0
[ebuild N ] kde-base/kdetoys-3.4.0
[ebuild N ] kde-base/kdeadmin-3.4.0
[ebuild N ] media-libs/musicbrainz-2.1.1
[ebuild N ] media-libs/tunepimp-0.3.0-r1
[ebuild N ] sci-libs/fftw-3.0.1-r1
[ebuild N ] media-libs/libsamplerate-0.1.2
[ebuild N ] media-libs/taglib-1.3.1
[ebuild N ] media-sound/cdparanoia-3.9.8-r2
[ebuild N ] kde-base/kdemultimedia-3.4.0
[ebuild NS ] sys-libs/db-4.2.52_p2
[ebuild N ] kde-base/kdeaddons-3.4.0
[ebuild N ] kde-base/kdeedu-3.4.0
[ebuild N ] kde-base/kdeutils-3.4.0
[ebuild N ] kde-base/kde-3.4.0

bash-2.05b# emerge -U kde
--- Invalid atom in /etc/portage/package.unmask: =netscape-flash-7.0.25

*** Warning: --upgradeonly is a deprecated option in portage-2.0.51.19
*** and will likely be removed in a future version.

>>> --upgradeonly implies --update... adding --update to options.
Calculating dependencies ...done!

!!! Error: the <=app-emulation/emul-linux-x86-xlibs-1.2-r3 package conflicts with another package.
!!! both can't be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.


Thanks!
Back to top
View user's profile Send private message
martoni
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 244
Location: Tyresö, Sweden

PostPosted: Wed Mar 30, 2005 5:40 am    Post subject: Re: installing kde 3.4 Reply with quote

joseignaciobp wrote:

Calculating dependencies ...done!
[blocks B ] =kde-base/kcheckpass-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdebase-startkde-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kcminit-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/ksplashml-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kwin-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kreadconfig-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kpersonalizer-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdesktop-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/ksmserver-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdebase-data-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kcontrol-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdm-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/libkonq-3.4* (is blocking kde-base/kdebase-3.4.0)


This may indicate that you are mixing monolithic and meta ebuilds.
There are lots of threads on the installation of KDE 3.4 on the forums.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Mar 30, 2005 5:41 am    Post subject: Reply with quote

You can install 3.4 but you will need to remove the following packages from split ebuilds:

Quote:
[blocks B ] =kde-base/kcheckpass-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdebase-startkde-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kcminit-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/ksplashml-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kwin-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kreadconfig-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kpersonalizer-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdesktop-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/ksmserver-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdebase-data-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kcontrol-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/kdm-3.4* (is blocking kde-base/kdebase-3.4.0)
[blocks B ] =kde-base/libkonq-3.4* (is blocking kde-base/kdebase-3.4.0)


These packs are part of kdebase itselft, so you just uninstall these and kdebase will be installed, containing all of these plus many other things.

This other thing

Code:
--- Invalid atom in /etc/portage/package.unmask: =netscape-flash-7.0.25


Means what it says, you must edit /etc/portage/package.unmask and change that line for:
Code:
=net-www/netscape-flash-7.0.25


This is true not only for package.unmask, but also for package.[use/mask/keywords], theh package needs to have the full name, including the subgroup prefix. This is this way because there are some packages in different subgroups that have the same name, and portage would get confused this way.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Wed Mar 30, 2005 1:08 pm    Post subject: Reply with quote

Gracias! (thanks for the answers)

but...

[blocks B ] =kde-base/kdm-3.4* (is blocking kde-base/kdebase-3.4.0)

should i uninstall kdm?

if i start from xdm and xterm, maybe i'll can

when i want to install all kde 3.4... how can i do this?

yesterday i use emerge kdm

and thats what i get!!

half kde installed :?

Saludos!
Back to top
View user's profile Send private message
microry
n00b
n00b


Joined: 27 Feb 2004
Posts: 33

PostPosted: Wed Mar 30, 2005 1:31 pm    Post subject: Reply with quote

Don't worry about kdm : if you emerge kdebase, kdm will be installed too.
kdebase is a monolithic ebuild while kdm is a part from splitted ebuilds... but
Quote:
there are lots of threads on the installation of KDE 3.4 on the forums.
;)

if you want install all kde 3.4 with monolithics ebuilds just type
Code:
emerge kde


...vive portage :)
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Wed Mar 30, 2005 1:52 pm    Post subject: Reply with quote

well i uninstall with emerge -C all the packages that appear in the list.

now i'm doing an emerge kde

maybe tomorrow i can post good news :wink:

thanks!

bye!
_________________
Buenos Aires, Argentina - Alcalá de Henares, España
Back to top
View user's profile Send private message
martoni
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 244
Location: Tyresö, Sweden

PostPosted: Wed Mar 30, 2005 3:19 pm    Post subject: Reply with quote

As I understand it - Gentoo is leaving the monolithic KDE ebuilds.
Hopefully it doesn't get back to bite you later ;-)
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Mar 30, 2005 5:02 pm    Post subject: Reply with quote

As I stated above you can safely uninstall all this packages, since then are split ebuilds that are fully containen into kdebase itselft. And yes, gentoo is migrating to the split ebuilds, but will also support monolitic ones. So, if you use all the kdebase programas you can still emerge kdebase-meta, or kde-meta, to emerge all the kde stuff. These -meta packages are just fake ebuilds that pull up all the split ebuild that conform a given monolitic package.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Wed Mar 30, 2005 7:45 pm    Post subject: Reply with quote

there ara some things that i can't understand very well...

if i make emerge kde...
what I obtain?

the entire kde?

i hope so!

how bad is my English! :lol:
_________________
Buenos Aires, Argentina - Alcalá de Henares, España
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Mar 30, 2005 8:09 pm    Post subject: Reply with quote

Well, let's start from the beginning.

In portage there are many versions of kde. Actually the last considered stable is kde-3.3.x (don't recall what is x right now, i think it is 5 or so). That's what you get if your emerge kde in the normal way. It do not need to be unmasked of anything since it is stable and available for everyone without any system files modification. This package (kde-3.3.x) is just a meta-package, which means that it really does not contain anything, it's just like a container that will pull on all the kde-3.3.x related packages (for example kdebase-3.3.x, kdegraphics-3.3.x, kdeadmin-3.3.x, and so on).

In the opposite, kde-3.4 is now considered as a beta version, so it is not in stable branch of portage, and it needs you to modify some files like package.unmask and package.keywords for it to emerge properly. Since this 3.4 version there are in portage what we call 'split ebuilds'. This means that we can install, for example, only konqueror and kickers, and do not install kwin if we dont need. These three packages that i named as examples contains programs that are contained on kdebase as well, so, what's the difference: to sum up, that if you emerge kdebase you will get all the stuff contained on that package, while if you emerge only a couple of split ebuilds you will only get these two programs you need.

In kde-3.4, then, you can choose between split and monolithic (old) ebuild types. Since you are a kde user, you should probably install kdebase as monolithic, this is: the complete kde, and the command would be:
Code:
emerge kde-meta


The system, as you see differs from the 3.3.x branch of kde. This has been made to remark that you can choose split or monolithic system. In 3.4 if you want to emerge the whole kde then you emerge kde-meta, if you want to emerge kdebase then you emerge kdebase-meta, if you want kdeadmin then kdeadmin-meta....... you catch the idea.

And if you want to emerge a single program but not the whole monolithic pack then you simply emerge that program, like in
Code:
emerge kpackage

this one, i.e. belongs to kdeadmini, but if you do not want the rest of the stuff in kdeadmin then you just emerge that little piece.

I know is a little confusing at the beginning but you will get it with the time. Another thing: I noticed you can talk spanish, so, if you don't understand anything just say and I will tell you in our native language, tío. :D
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Wed Mar 30, 2005 10:21 pm    Post subject: Reply with quote

Hi!
thanks for the answers

i understand english when i read it, but i'm very bad writing!

well, i make: emerge kde

when i use porthole (i use it to view information), if i select kde, it says that the installed version is kde 3.4.0

i don't modify anything with masked packages, i only modified make.conf with ACCEPT_KEYWORDS="~amd64"

then i uninstall all that packages that looked blocked, and i emerge kde

theoretically it installed kde 3.4.0 but when i look in the about windows, it says that is 3.3.2

now i'm emerging kde-i18n with LINGUAS="es" emerge -u kde-i18n

Maybe the problem in the version is on the translate...

i don't know...


thanks!!
bye!
_________________
Buenos Aires, Argentina - Alcalá de Henares, España
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Wed Mar 30, 2005 11:25 pm    Post subject: Reply with quote

:P :P :P

Now i'm in kde 3.4.0 !!!

thanks to everybody!

now i see that i have both... 3.3.2 and 3.4

should i delete /usr/kde/3.3??
_________________
Buenos Aires, Argentina - Alcalá de Henares, España
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Mar 30, 2005 11:35 pm    Post subject: Reply with quote

Surely yes, but since i do not use 3.4 i can confirm, the safest thing would be to rename it to 3.3~ for example, and work a few days with the box, if it does not complain then remove that dir. :D
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
robfish
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2002
Posts: 137
Location: New Zealand

PostPosted: Wed Mar 30, 2005 11:54 pm    Post subject: Reply with quote

What exactly should I put in
package.keywords and package.unmask?

I tried putting
kde-base/kde-meta ~x86
into package.keywords
but then I get

beast root # emerge -p kde-meta

These are the packages that I would merge, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy "~kde-base/kdeedu-meta-3.4.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdeedu-meta-3.4.0 (masked by: ~x86 keyword)

If I then put kde-base/kdeedu-meta into package.keywords I get another dependancy needs unmasking.
_________________
RobFish
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Thu Mar 31, 2005 12:04 am    Post subject: Reply with quote

package.unmask

Code:

kde-base/kde-meta
 kde-base/kdeaccessibility-meta
 kde-base/kdeaddons-meta
 kde-base/kdeadmin-meta
 kde-base/kdebase-meta
 kde-base/kdeedu-meta
 
 kde-base/kdegames-meta
 kde-base/kdegraphics-meta
 kde-base/kdemultimedia-meta
 kde-base/kdenetwork-meta
 kde-base/kdepim-meta
 kde-base/kdesdk-meta
 kde-base/kdetoys-meta
 kde-base/kdeutils-meta
 kde-base/kdewebdev-meta
 kde-base/kdeartwork-meta
 kde-base/kdelibs
 kde-base/arts
 kde-base/kde-i18n
 kde-base/kmag
 kde-base/kdeaccessibility-iconthemes
 kde-base/kmousetool
 kde-base/kbstateapplet
 kde-base/ksayit
 kde-base/kttsd
 kde-base/kmouth
 kde-base/atlantikdesigner
 kde-base/knewsticker-scripts
 kde-base/ksig
 kde-base/vimpart
 kde-base/kaddressbook-plugins
 kde-base/kate-plugins
 kde-base/kicker-applets
 kde-base/kdeaddons-kfile-plugins
 kde-base/konqueror-akregator
 kde-base/konq-plugins
 kde-base/renamedlg-audio
 kde-base/renamedlg-images
 kde-base/noatun-plugins
 kde-base/kcron
 kde-base/kdat
 kde-base/kdeadmin-kfile-plugins
 kde-base/kuser
 kde-base/lilo-config
 kde-base/secpolicy
 kde-base/kdebase-applnk
 kde-base/drkonqi
 kde-base/kappfinder
 kde-base/kate
 kde-base/kcheckpass
 kde-base/kcminit
 kde-base/kcontrol
 kde-base/kdcop
 kde-base/kdebugdialog
 kde-base/kdepasswd
 kde-base/kdeprint
 kde-base/kdesktop
 kde-base/kdesu
 kde-base/kdialog
 kde-base/kdm
 kde-base/kfind
 kde-base/khelpcenter
 kde-base/khotkeys
 kde-base/kicker
 kde-base/kdebase-kioslaves
 kde-base/klipper
 kde-base/kmenuedit
 kde-base/konqueror
 kde-base/konsole
 kde-base/kpager
 kde-base/kpersonalizer
 kde-base/kreadconfig
 kde-base/kscreensaver
 kde-base/ksmserver
 kde-base/ksplashml
 kde-base/kstart
 kde-base/ksysguard
 kde-base/ksystraycmd
 kde-base/ktip
 kde-base/kwin
 kde-base/kxkb
 kde-base/kdebase-l10n
 kde-base/libkonq
 kde-base/nsplugins
 kde-base/kdebase-pics
 kde-base/knetattach
 kde-base/kdebase-startkde
 kde-base/kig
 kde-base/kalzium
 kde-base/khangman
 kde-base/kpercentage
 kde-base/kiten
 kde-base/kvoctrain
 kde-base/kturtle
 kde-base/kverbos
 kde-base/kdeedu-applnk
 kde-base/kbruch
 kde-base/keduca
 kde-base/kmessedwords
 kde-base/klatin
 kde-base/kmplot
 kde-base/kstars
 kde-base/ktouch
 kde-base/klettres
 kde-base/kmathtool
 kde-base/kwordquiz
 kde-base/atlantik
 kde-base/kasteroids
 kde-base/katomic
 kde-base/kbackgammon
 kde-base/kbattleship
 kde-base/kblackbox
 kde-base/kbounce
 kde-base/kenolaba
 kde-base/kfouleggs
 kde-base/kgoldrunner
 kde-base/kjumpingcube
 kde-base/klickety
 kde-base/klines
 kde-base/kmahjongg
 kde-base/kmines
 kde-base/kolf
 kde-base/konquest
 kde-base/kpat
 kde-base/kpoker
 kde-base/ktron
 kde-base/ktuberling
 kde-base/ksame
 kde-base/kshisen
 kde-base/ksirtet
 kde-base/ksmiletris
 kde-base/ksnake
 kde-base/ksokoban
 kde-base/kspaceduel
 kde-base/kreversi
 kde-base/kwin4
 kde-base/lskat
 kde-base/kamera
 kde-base/kcoloredit
 kde-base/kdegraphics-kfile-plugins
 kde-base/kdvi
 kde-base/kfax
 kde-base/kgamma
 kde-base/kghostview
 kde-base/kiconedit
 kde-base/kmrml
 kde-base/kolourpaint
 kde-base/kooka
 kde-base/libkscan
 kde-base/kpdf
 kde-base/kpovmodeler
 kde-base/kruler
 kde-base/ksnapshot
 kde-base/ksvg
 kde-base/kuickshow
 kde-base/kview
 kde-base/kviewshell
 kde-base/dcoprss
 kde-base/kdenetwork-filesharing
 kde-base/kdict
 kde-base/kget
 kde-base/knewsticker
 kde-base/kopete
 kde-base/kpf
 kde-base/kppp
 kde-base/krdc
 kde-base/krfb
 kde-base/ksirc
 kde-base/ktalkd
 kde-base/kwifimanager
 kde-base/librss
 kde-base/kdnssd
 kde-base/kdenetwork-kfile-plugins
 kde-base/lisa
 kde-base/artsplugin-audiofile
 kde-base/artsplugin-mpeglib
 kde-base/artsplugin-mpg123
 kde-base/artsplugin-xine
 kde-base/juk
 kde-base/kaboodle
 kde-base/kaudiocreator
 kde-base/akode
 kde-base/kdemultimedia-arts
 kde-base/krec
 kde-base/noatun)
 kde-base/kdemultimedia-kappfinder-data
 kde-base/kdemultimedia-kfile-plugins
 kde-base/kdemultimedia-kioslaves
 kde-base/kmid
 kde-base/kmix
 kde-base/kscd
 kde-base/libkcddb
 kde-base/mpeglib
 kde-base/certmanager
 kde-base/kaddressbook
 kde-base/kalarm
 kde-base/kandy
 kde-base/karm
 kde-base/kdepim-kioslaves
 kde-base/kdepim-kresources
 kde-base/kdepim-wizards
 kde-base/kitchensync
 kde-base/kmail
 kde-base/kmailcvt
 kde-base/kmobile
 kde-base/knode
 kde-base/knotes
 kde-base/kode
 kde-base/konsolekalendar
 kde-base/kontact
 kde-base/korganizer
 kde-base/korn
 kde-base/kpilot
 kde-base/ksync
 kde-base/ktnef
 kde-base/libkcal
 kde-base/libkdenetwork
 kde-base/libkdepim
 kde-base/libkmime
 kde-base/libkpimexchange
 kde-base/libkpimidentities
 kde-base/libksieve
 kde-base/mimelib
 kde-base/networkstatus
 kde-base/libkmime
 kde-base/libkpgp
 kde-base/libkholidays
 kde-base/amor
 kde-base/eyesapplet
 kde-base/fifteenapplet
 kde-base/kmoon
 kde-base/kodo
 kde-base/kteatime
 kde-base/ktux
 kde-base/kweather
 kde-base/kworldwatch
 kde-base/ark
 kde-base/kcalc
 kde-base/kcharselect
 kde-base/kdelirc
 kde-base/kdf
 kde-base/kedit
 kde-base/kfloppy
 kde-base/kgpg
 kde-base/khexedit
 kde-base/kjots
 kde-base/klaptopdaemon
 kde-base/kmilo
 kde-base/kregexpeditor
 kde-base/ksim
 kde-base/ktimer
 kde-base/kwalletmanager
 kde-base/kdeartwork-emoticons
 kde-base/kdeartwork-iconthemes
 kde-base/kdeartwork-icewm-themes
 kde-base/kdeartwork-kscreensaver
 kde-base/kdeartwork-kwin-styles
 kde-base/kdeartwork-kworldclock
 kde-base/kdeartwork-sounds
 kde-base/kdeartwork-styles
 kde-base/kdeartwork-wallpapers
 kde-base/cervisia
 kde-base/kapptemplate
 kde-base/kbabel
 kde-base/kbugbuster
 kde-base/kcachegrind
 kde-base/kdesdk-kfile-plugins
 kde-base/kdesdk-misc
 kde-base/kdesdk-scripts
 kde-base/kmtrace
 kde-base/kompare
 kde-base/kspy
 kde-base/kuiviewer
 kde-base/kdesdk-kioslaves
 kde-base/umbrello
 kde-base/kfilereplace
 kde-base/kimagemapeditor
 kde-base/klinkstatus
 kde-base/kommander
 kde-base/kxsldbg
 kde-base/quanta
 kde-base/akregator
 kde-base/libkdeedu
 kde-base/kdeaddons-docs-konq-plugins
 kde-base/libkdegames
 kde-base/noatun
 kde-base/libksirtet
 kde-base/kdebase-pam
 kde-base/kontact-specialdates
 kde-base/kdebase-data
 


package.keywords

Code:

kde-base/kde-meta ~x86
 kde-base/kdeaccessibility-meta ~x86
 kde-base/kdeaddons-meta ~x86
 kde-base/kdeadmin-meta ~x86
 kde-base/kdebase-meta ~x86
 kde-base/kdeedu-meta ~x86
 kde-base/kdegames-meta ~x86
 kde-base/kdegraphics-meta ~x86
 kde-base/kdemultimedia-meta ~x86
 kde-base/kdenetwork-meta ~x86
 kde-base/kdepim-meta ~x86
 kde-base/kdesdk-meta ~x86
 kde-base/kdetoys-meta ~x86
 kde-base/kdeutils-meta ~x86
 kde-base/kdewebdev-meta ~x86
 kde-base/kdeartwork-meta ~x86
 kde-base/kdelibs ~x86
 kde-base/arts
 kde-base/kde-i18n ~x86
 kde-base/kmag ~x86
 kde-base/kdeaccessibility-iconthemes ~x86
 kde-base/kmousetool ~x86
 kde-base/kbstateapplet ~x86
 kde-base/ksayit ~x86
 kde-base/kttsd ~x86
 kde-base/kmouth ~x86
 kde-base/atlantikdesigner ~x86
 kde-base/knewsticker-scripts ~x86
 kde-base/ksig ~x86
 kde-base/vimpart ~x86
 kde-base/kaddressbook-plugins ~x86
 kde-base/kate-plugins ~x86
 kde-base/kicker-applets ~x86
 kde-base/kdeaddons-kfile-plugins ~x86
 kde-base/konqueror-akregator ~x86
 kde-base/renamedlg-audio ~x86
 kde-base/renamedlg-images ~x86
 kde-base/noatun-plugins ~x86
 kde-base/konq-plugins ~x86
 kde-base/kcron ~x86
 kde-base/kdat ~x86
 kde-base/kdeadmin-kfile-plugins ~x86
 kde-base/kuser ~x86
 kde-base/lilo-config ~x86
 kde-base/secpolicy ~x86
 kde-base/kdebase-applnk ~x86
 kde-base/drkonqi ~x86
 kde-base/kappfinder ~x86
 kde-base/kate ~x86
 kde-base/kcheckpass ~x86
 kde-base/kcminit ~x86
 kde-base/kcontrol ~x86
 kde-base/kdcop ~x86
 kde-base/kdebugdialog ~x86
 kde-base/kdepasswd ~x86
 kde-base/kdeprint ~x86
 kde-base/kdesktop ~x86
 kde-base/kdesu ~x86
 kde-base/kdialog ~x86
 kde-base/kdm ~x86
 kde-base/kfind ~x86
 kde-base/khelpcenter ~x86
 kde-base/khotkeys ~x86
 kde-base/kicker ~x86
 kde-base/kdebase-kioslaves ~x86
 kde-base/klipper ~x86
 kde-base/kmenuedit ~x86
 kde-base/konqueror ~x86
 kde-base/konsole ~x86
 kde-base/kpager ~x86
 kde-base/kpersonalizer ~x86
 kde-base/kreadconfig ~x86
 kde-base/kscreensaver ~x86
 kde-base/ksmserver ~x86
 kde-base/ksplashml ~x86
 kde-base/kstart ~x86
 kde-base/ksysguard ~x86
 kde-base/ksystraycmd ~x86
 kde-base/ktip ~x86
 kde-base/kwin ~x86
 kde-base/kxkb ~x86
 kde-base/kdebase-l10n ~x86
 kde-base/libkonq ~x86
 kde-base/nsplugins ~x86
 kde-base/kdebase-pics ~x86
 kde-base/knetattach ~x86
 kde-base/kdebase-startkde ~x86
 kde-base/kig ~x86
 kde-base/kalzium ~x86
 kde-base/khangman ~x86
 kde-base/kpercentage ~x86
 kde-base/kiten ~x86
 kde-base/kvoctrain ~x86
 kde-base/kturtle ~x86
 kde-base/kverbos ~x86
 kde-base/kdeedu-applnk ~x86
 kde-base/kbruch ~x86
 kde-base/keduca ~x86
 kde-base/kmessedwords ~x86
 kde-base/klatin ~x86
 kde-base/kmplot ~x86
 kde-base/kstars ~x86
 kde-base/ktouch ~x86
 kde-base/klettres ~x86
 kde-base/kmathtool ~x86
 kde-base/kwordquiz ~x86
 kde-base/atlantik ~x86
 kde-base/kasteroids ~x86
 kde-base/katomic ~x86
 kde-base/kbackgammon ~x86
 kde-base/kbattleship ~x86
 kde-base/kblackbox ~x86
 kde-base/kbounce ~x86
 kde-base/kenolaba ~x86
 kde-base/kfouleggs ~x86
 kde-base/kgoldrunner ~x86
 kde-base/kjumpingcube ~x86
 kde-base/klickety ~x86
 kde-base/klines ~x86
 kde-base/kmahjongg ~x86
 kde-base/kmines ~x86
 kde-base/kolf ~x86
 kde-base/konquest ~x86
 kde-base/kpat ~x86
 kde-base/kpoker ~x86
 kde-base/ktron ~x86
 kde-base/ktuberling ~x86
 kde-base/ksame ~x86
 kde-base/kshisen ~x86
 kde-base/ksirtet ~x86
 kde-base/ksmiletris ~x86
 kde-base/ksnake ~x86
 kde-base/ksokoban ~x86
 kde-base/kspaceduel ~x86
 kde-base/kreversi ~x86
 kde-base/kwin4 ~x86
 kde-base/lskat ~x86
 kde-base/kamera ~x86
 kde-base/kcoloredit ~x86
 kde-base/kdegraphics-kfile-plugins ~x86
 kde-base/kdvi ~x86
 kde-base/kfax ~x86
 kde-base/kgamma ~x86
 kde-base/kghostview ~x86
 kde-base/kiconedit ~x86
 kde-base/kmrml ~x86
 kde-base/kolourpaint ~x86
 kde-base/kooka ~x86
 kde-base/libkscan ~x86
 kde-base/kpdf ~x86
 kde-base/kpovmodeler ~x86
 kde-base/kruler ~x86
 kde-base/ksnapshot ~x86
 
 kde-base/ksvg ~x86
 kde-base/kuickshow ~x86
 kde-base/kview ~x86
 kde-base/kviewshell ~x86
 kde-base/dcoprss ~x86
 kde-base/kdenetwork-filesharing ~x86
 kde-base/kdict ~x86
 kde-base/kget ~x86
 kde-base/knewsticker ~x86
 kde-base/kopete ~x86
 kde-base/kpf ~x86
 kde-base/kppp ~x86
 kde-base/krdc ~x86
 kde-base/krfb ~x86
 kde-base/ksirc ~x86
 kde-base/ktalkd ~x86
 kde-base/kwifimanager ~x86
 kde-base/librss ~x86
 kde-base/kdnssd ~x86
 kde-base/kdenetwork-kfile-plugins ~x86
 kde-base/lisa ~x86
 kde-base/artsplugin-audiofile ~x86
 kde-base/artsplugin-mpeglib ~x86
 kde-base/artsplugin-mpg123 ~x86
 kde-base/artsplugin-xine ~x86
 kde-base/juk ~x86
 kde-base/kaboodle ~x86
 kde-base/kaudiocreator ~x86
 kde-base/akode ~x86
 kde-base/kdemultimedia-arts ~x86
 kde-base/krec ~x86
 kde-base/noatun) ~x86
 kde-base/kdemultimedia-kappfinder-data ~x86
 kde-base/kdemultimedia-kfile-plugins ~x86
 kde-base/kdemultimedia-kioslaves ~x86
 kde-base/kmid ~x86
 kde-base/kmix ~x86
 kde-base/kscd ~x86
 kde-base/libkcddb ~x86
 kde-base/mpeglib ~x86
 kde-base/certmanager ~x86
 kde-base/kaddressbook ~x86
 kde-base/kalarm ~x86
 kde-base/kandy ~x86
 kde-base/karm ~x86
 kde-base/kdepim-kioslaves ~x86
 kde-base/kdepim-kresources ~x86
 kde-base/kdepim-wizards ~x86
 kde-base/kitchensync ~x86
 kde-base/kmail ~x86
 kde-base/kmailcvt ~x86
 kde-base/kmobile ~x86
 kde-base/knode ~x86
 kde-base/knotes ~x86
 kde-base/kode ~x86
 kde-base/konsolekalendar ~x86
 kde-base/kontact ~x86
 kde-base/korganizer ~x86
 kde-base/korn ~x86
 kde-base/kpilot ~x86
 kde-base/ksync ~x86
 kde-base/ktnef ~x86
 kde-base/libkcal ~x86
 kde-base/libkdenetwork ~x86
 kde-base/libkdepim ~x86
 kde-base/libkmime ~x86
 kde-base/libkpimexchange ~x86
 kde-base/libkpimidentities ~x86
 kde-base/libksieve ~x86
 kde-base/mimelib ~x86
 kde-base/networkstatus ~x86
 kde-base/libkmime ~x86
 kde-base/libkpgp ~x86
 kde-base/libkholidays ~x86
 kde-base/amor ~x86
 kde-base/eyesapplet ~x86
 kde-base/fifteenapplet ~x86
 kde-base/kmoon ~x86
 kde-base/kodo ~x86
 kde-base/kteatime ~x86
 kde-base/ktux ~x86
 kde-base/kweather ~x86
 kde-base/kworldwatch ~x86
 kde-base/ark ~x86
 kde-base/kcalc ~x86
 kde-base/kcharselect ~x86
 kde-base/kdelirc ~x86
 kde-base/kdf ~x86
 kde-base/kedit ~x86
 kde-base/kfloppy ~x86
 kde-base/kgpg ~x86
 kde-base/khexedit ~x86
 kde-base/kjots ~x86
 kde-base/klaptopdaemon ~x86
 kde-base/kmilo ~x86
 kde-base/kregexpeditor ~x86
 kde-base/ksim ~x86
 kde-base/ktimer ~x86
 kde-base/kwalletmanager ~x86
 kde-base/kdeartwork-emoticons ~x86
 kde-base/kdeartwork-iconthemes ~x86
 kde-base/kdeartwork-icewm-themes ~x86
 kde-base/kdeartwork-kscreensaver ~x86
 kde-base/kdeartwork-kwin-styles ~x86
 kde-base/kdeartwork-kworldclock ~x86
 kde-base/kdeartwork-sounds ~x86
 kde-base/kdeartwork-styles ~x86
 kde-base/kdeartwork-wallpapers ~x86
 kde-base/cervisia ~x86
 kde-base/kapptemplate ~x86
 kde-base/kbabel ~x86
 kde-base/kbugbuster ~x86
 kde-base/kcachegrind ~x86
 kde-base/kdesdk-kfile-plugins ~x86
 kde-base/kdesdk-misc ~x86
 kde-base/kdesdk-scripts ~x86
 kde-base/kmtrace ~x86
 kde-base/kompare ~x86
 kde-base/kspy ~x86
 kde-base/kuiviewer ~x86
 kde-base/kdesdk-kioslaves ~x86
 kde-base/umbrello ~x86
 kde-base/kfilereplace ~x86
 kde-base/kimagemapeditor ~x86
 kde-base/klinkstatus ~x86
 kde-base/kommander ~x86
 kde-base/kxsldbg ~x86
 kde-base/quanta ~x86
 kde-base/akregator ~x86
 kde-base/libkdeedu ~x86
 kde-base/kdeaddons-docs-konq-plugins ~x86
 kde-base/libkdegames ~x86
 kde-base/noatun ~x86
 kde-base/libksirtet ~x86
 kde-base/kdebase-pam ~x86
 kde-base/kontact-specialdates ~x86
 kde-base/kdebase-data ~x86


I haven't tried myself, i dont use kde so much (happy with fvwm) but it should work, in case it reports any other package then add by hand.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Thu Mar 31, 2005 5:38 am    Post subject: Reply with quote

maybe it would be more easy to make unstable your gentoo with ACCEPT_KEYWORDS="~XXX" in your make.conf

then you install kde.

I supose that you can make your gentoo stable again deleting that line after you install kde

bye!
_________________
Buenos Aires, Argentina - Alcalá de Henares, España
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Thu Mar 31, 2005 5:42 am    Post subject: Reply with quote

Easier yes, but the right way to do it is this. This way you know exactly what you deal with, and there are no surprises.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
joseignaciobp
n00b
n00b


Joined: 21 Dec 2004
Posts: 63

PostPosted: Sun Apr 03, 2005 12:18 pm    Post subject: Reply with quote

Hi again!

well i was traying the way you said but it doesn't work for me

i added all the files to package.unmask and .keyword but it falis...

Quote:
Calculating dependencies
!!! All ebuilds that could satisfy "kde-meta" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kde-meta-3.4.0 (masked by: missing keyword)
- kde-base/kde-meta-3.4.0_rc1 (masked by: missing keyword)
# <danarmak@gentoo.org> (14 Jan 2005)
# Prereleases of KDE 3.4 - split ebuilds


in package.keyword i tryed with thinks like this:
=kde-base/kde-meta ~amd64
or
>=kde-base/kde-meta ~amd64
or
=kde-base/kde-meta-3.4.0 ~amd64

With all packages
What am i doing wrong?

Thanks!
_________________
Buenos Aires, Argentina - Alcalá de Henares, España
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun Apr 03, 2005 3:54 pm    Post subject: Reply with quote

Remove '=' and version number.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Mon Sep 26, 2005 3:00 pm    Post subject: Reply with quote

Moved from Gentoo on AMD64 to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum