Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mkraid fails: cannot determine md version: 25
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mordor35
n00b
n00b


Joined: 31 May 2004
Posts: 2

PostPosted: Mon May 31, 2004 4:50 pm    Post subject: mkraid fails: cannot determine md version: 25 Reply with quote

Hi guys,

We are encountering a very specific RAID problem. The symptoms are that any command in the raidtools ebuild fails to run, resulting in the following error:

mordor etc # mkraid -f /dev/md
cannot determine md version: 25.

We have two 120gb Maxtor 7200 devices on seperate channels
on a Promise 20276 raid controller, onboard a Gigabyte GA7VRXP motherboard. Kernel has MD and Promise (ata) built in, and raidtab is fine.

The RAID controller bios is disabled, and the device is in "ATA" mode, presenting the disks as /dev/hdf and /dev/hdh. We are attemping SOFTWARE RAID mode 1. The disks have a single partition on them, type Linux Auto Raid.

linux-2.6.5-gentoo-r1
sys-fs/raidtools 1.00.3-r1

If anyone could help us troubleshoot this issue please get in touch,

Thanks,

Chris + Tom
Back to top
View user's profile Send private message
danone
Guru
Guru


Joined: 18 Jan 2004
Posts: 398
Location: Germany

PostPosted: Mon May 31, 2004 5:29 pm    Post subject: Reply with quote

Do you have Multidevice Support in your kernel?
2. do you have the partitions fstype "fd" linux raid autodetect
3.You are missing the leading 0 or n md is global

mkraid -R or --really-force /dev/md0
_________________
[:: Processor: Intel Core 2 Duo E6300 ]::[ Mainboard: ASUS P5B Deluxe ]::[ GPU: nVidia 7900GTO ::]
[:: RAM: HyperX DDR2 800 ]::[ Samsung SH-183A SATA:: CREATiVE X-Fi XtremeMusic :: ]
Back to top
View user's profile Send private message
mordor35
n00b
n00b


Joined: 31 May 2004
Posts: 2

PostPosted: Mon May 31, 2004 6:19 pm    Post subject: No luck Reply with quote

Hi thanks for the reply. I can confirm the partition type of the seperate drives for use in the RAID ahve a single partition (p1) of type fd

We have Multiple Device support compiled in the kernel. The arrey is named /dev/md as defined in /etc/raidtab

Irrespective of the command line we pass to mkraid, raidstart, raidstop etc we always get the same error.

We have tried to fix this for a couple of days now and have tried all trivial soltuions.


Thanks, Chris + Tom :oops:
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Wed Jul 20, 2005 2:06 pm    Post subject: Reply with quote

See this thread.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum