Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VFS: Cannot open root device "hda3" or unknown-blo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
lbharti
n00b
n00b


Joined: 29 Mar 2005
Posts: 7

PostPosted: Thu Mar 31, 2005 12:34 am    Post subject: VFS: Cannot open root device "hda3" or unknown-blo Reply with quote

Hi I am not able to boot my system at all. The error I recieve is:

VFS: Cannot open root device "hda3" or unknown-block(3,3)
Please append a correct "root=" boot option
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,3)

my grub.conf:

default 0

timeout 9

#splashimage=(hd0,2)/grub/splash.xpm.gz

title=Linux 2.6.9
root (hd0,2)
kernel /boot/kernel-2.6.9-gentoo-r14 root=/dev/hda3 video=vesafb:mtrr,ywrap,1024x768-32@60 udev

title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1


I even tried:

kernel /boot/kernel-2.6.9-gentoo-r14 root=/dev/hda3 video=vesafb:mtrr,ywrap,1024x768-32@60 init=/linuxrc udev

I have custom kernel and I compiled all the files in the kernel.

Please help.

My system configuration:
HP pavillion zv5000
AMD64 3700+
1256 RAM
hda1 winxp
hda2 swap
hda3 /
hard drive type:ATA
Back to top
View user's profile Send private message
weyhan
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 245

PostPosted: Thu Mar 31, 2005 7:00 am    Post subject: Re: even udev is not helping Reply with quote

lbharti wrote:
...

My system configuration:
HP pavillion zv5000
AMD64 3700+
1256 RAM
hda1 winxp
hda2 swap
hda3 /
hard drive type:ATA
Humm... I notice a trend...

Anyway, I think this is a different problem. Please start a new thread. You'll get a higher chance to solve the problem now that this one is marked as solved.
_________________
Han.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Mar 31, 2005 9:10 am    Post subject: Reply with quote

The solution to this problem is in the first post of the grub error collection.

Split from https://forums.gentoo.org/viewtopic-t-315689.html
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum