Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem With rebooting into linux
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Jaelan Alianto
n00b
n00b


Joined: 31 Mar 2005
Posts: 7

PostPosted: Thu Mar 31, 2005 10:25 pm    Post subject: Problem With rebooting into linux Reply with quote

Hey all,
I'm fairly new to the whole linux world, and so I chose Gentoo to start plunging into it because someone recommended it to me. But I've run into a problem. I installed a stage3 from a liveCD (2005.0). I went through the installation guide and everything went perfectly. Until I tried to reboot into linux.

The error that was given was this:
Mount: Mounting devfs on /dev failed: No such device
Error opening file: ".devfsd" No such file or directory

This was followed up with the error:
block device /dev/hdb3 is not a valid root device

I assume the second error was caused from the first error, but just in case, I'm going to provide some information about my system to give as detailed a picture as possible.

I'm installing this on a pentium 4 machine with 2 harddrives. I am dual booting, and windows xp is on the first hard drive. My partition system on the second disk looks like this:

Code:
Disk /dev/hdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1           5       40131   83  Linux
/dev/hdb2               6          68      506047+  82  Linux swap / Solaris
/dev/hdb3              69        3716    29302560   83  Linux
/dev/hdb4            3717        9729    48299422+  83  Linux


hdb1, 3, 4 are all ext3 filesystems

And so, my /etc/fstab file looks like this:

Code:
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hdb1               /boot           ext3            defaults,noatime        1 2
/dev/hdb2               none            swap            sw                      0 0
/dev/hdb3               /               ext3            noatime                 0 1
/dev/hdb4               /home           ext3            noatime                 0 1
/dev/cdroms/cdrom0      /mnt/cdrom      auto            noauto,usr              0 0
#/dev/fd0               /mnt/floppy     auto            noauto                  0 0

# NOTE: The next line is critical for boot!
none                    /proc           proc            defaults                0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none                    /dev/shm        tmpfs           defaults                0 0


and finally, my grub.conf file looks like so:

Code:
default 0
timeout 30
splashimage=(hd1,0)/grub/splash.xpm.gz

title=Gentoo Linux
root (hd1,0)
kernel /kernel-2.6.11-gentoo-r4 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hdb3 video=vesafb:mtrr,ywrap,1024x768-32@60
initrd /initrd-2.6.11-gentoo-r4

title=Windows XP
root (hd0, 0)
makeactive
chainloader +1


I hope this gives someone enough information to help me out. I'm hoping it is just as simple as me missing something in the installation guide. One last thing, I used the 'grub' command to manually install grub on the mbr...root (hd1,0) setup (hd0)

Any advice?

Jaelan Alianto
Back to top
View user's profile Send private message
funduk
n00b
n00b


Joined: 17 Jan 2005
Posts: 72
Location: Toronto, Ontario

PostPosted: Thu Mar 31, 2005 10:30 pm    Post subject: Reply with quote

Looks like you forgot to enable devfs and 'automatically mount at boot' in your kernel.

Also:

Code:
kernel /kernel-2.6.11-gentoo-r4 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hdb3 video=vesafb:mtrr,ywrap,1024x768-32@60


That line looks like insanity to me... Why do you have /dev/ram0 and all that in there?
Back to top
View user's profile Send private message
Jaelan Alianto
n00b
n00b


Joined: 31 Mar 2005
Posts: 7

PostPosted: Thu Mar 31, 2005 11:09 pm    Post subject: Reply with quote

hrm, i used genkernel --udev all (2.6 kernel), so I didn't actually enable anything...is there something I should have done w/ genkernel to enable devfs?

As for the line in my grub.conf file..who knows why i did it...I can only plead insanity and the fact that I was using the gentoo installation guide (that's the line that they give for genkernel grub.conf file) minus the video= part...that, i garnered from a bit further up in the install directions...

Jaelan Alianto
Back to top
View user's profile Send private message
funduk
n00b
n00b


Joined: 17 Jan 2005
Posts: 72
Location: Toronto, Ontario

PostPosted: Thu Mar 31, 2005 11:11 pm    Post subject: Reply with quote

Ohh, riiiight, genkernel... I had forgotten about that...

Uhm... sorry, I really can't be of that much help then. :cry:
Back to top
View user's profile Send private message
taurus
l33t
l33t


Joined: 21 Sep 2004
Posts: 657
Location: I need to be somewhere...

PostPosted: Thu Mar 31, 2005 11:25 pm    Post subject: Reply with quote

Try to remove "root=/dev/ram0" from the entry for kernel...
Code:
kernel /kernel-2.6.11-gentoo-r4 init=/linuxrc ramdisk=8192 real_root=/dev/hdb3 video=vesafb:mtrr,ywrap,1024x768-32@60

taurus
Back to top
View user's profile Send private message
Jaelan Alianto
n00b
n00b


Joined: 31 Mar 2005
Posts: 7

PostPosted: Thu Mar 31, 2005 11:46 pm    Post subject: Reply with quote

Hey,
That worked like a charm! Thanks. It did seem odd why it was in there twice, but I figured since it was in the install guide, it should be there :) Oh well. Thanks for the help!
Back to top
View user's profile Send private message
taurus
l33t
l33t


Joined: 21 Sep 2004
Posts: 657
Location: I need to be somewhere...

PostPosted: Thu Mar 31, 2005 11:50 pm    Post subject: Reply with quote

Yes, I think that is perhaps a typo. Just took a quick look at the latest version of the Handbook and it is, root=/dev/ram0, still there for genkernel!!! :roll:

taurus
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Apr 08, 2005 8:01 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-315935.html

Moved from Installing Gentoo.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum