Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Another 2005.0 install error?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Stewie Griffin
n00b
n00b


Joined: 31 Mar 2005
Posts: 34

PostPosted: Fri Apr 01, 2005 4:35 am    Post subject: Another 2005.0 install error? Reply with quote

I just got to the "emerge --emptytree system" step in the install, and it was running for a while and then crapped out with this:

Code:

>>> md5 src_uri ;-) sysvinit-2.84.tar.gz
>>> md5 src_uri ;-) rc-scripts-1.4.16.tar.bz2
>>> Unpacking source...
>>> Unpacking sysvinit-2.84.tar.gz to /var/tmp/portage/baselayout-1.9.4-r6/work
>>> Unpacking rc-scripts-1.4.16.tar.bz2 to /var/tmp/portage/baselayout-1.9.4-r6/work
 * Applying rc-scripts-1.4.16-splash.patch ...                                         [ ok ]
 * Applying rc-scripts-1.4.16-livecd.patch ...                                         [ ok ]
 * Applying rc-scripts-1.4.16-livecd-hvc.patch ...

 * Failed Patch: rc-scripts-1.4.16-livecd-hvc.patch !
 *  ( /usr/portage/sys-apps/baselayout/files/rc-scripts-1.4.16-livecd-hvc.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/baselayout-1.9.4-r6/temp/rc-scripts-1.4.16-livecd-hvc.patch-15217.out


!!! ERROR: sys-apps/baselayout-1.9.4-r6 failed.
!!! Function epatch, Line 401, Exitcode 0
!!! Failed Patch: rc-scripts-1.4.16-livecd-hvc.patch!
!!! If you need support, post the topmost build error, NOT this status message.



Here's the ouput of /var/tmp/portage/baselayout-1.9.4-r6/temp/rc-scripts-1.4.16-livecd-hvc.patch-15217.out

Code:



***** rc-scripts-1.4.16-livecd-hvc.patch *****

===============================================================

PATCH COMMAND:  patch -p0 -g0 < /usr/portage/sys-apps/baselayout/files/rc-scripts-1.4.16-liv$

===============================================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- rc-scripts-1.4.16/sbin/livecd-functions.sh.orig    2005-03-22 20:40:25.912265336 -0600
|+++ rc-scripts-1.4.16/sbin/livecd-functions.sh 2005-03-22 20:43:08.497311240 -0600
--------------------------
No file to patch.  Skipping patch.
3 out of 3 hunks ignored
===============================================================

PATCH COMMAND:  patch -p1 -g0 < /usr/portage/sys-apps/baselayout/files/rc-scripts-1.4.16-liv$

===============================================================
patching file sbin/livecd-functions.sh
Hunk #1 FAILED at 150.
Hunk #2 succeeded at 184 with fuzz 2 (offset 5 lines).
Hunk #3 FAILED at 198.
2 out of 3 hunks FAILED -- saving rejects to file sbin/livecd-functions.sh.rej
===============================================================

PATCH COMMAND:  patch -p2 -g0 < /usr/portage/sys-apps/baselayout/files/rc-scripts-1.4.16-liv$

===============================================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- rc-scripts-1.4.16/sbin/livecd-functions.sh.orig    2005-03-22 20:40:25.912265336 -0600
|+++ rc-scripts-1.4.16/sbin/livecd-functions.sh 2005-03-22 20:43:08.497311240 -0600
--------------------------
No file to patch.  Skipping patch.
3 out of 3 hunks ignored
===============================================================

PATCH COMMAND:  patch -p3 -g0 < /usr/portage/sys-apps/baselayout/files/rc-scripts-1.4.16-liv$

===============================================================
missing header for unified diff at line 3 of patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- rc-scripts-1.4.16/sbin/livecd-functions.sh.orig    2005-03-22 20:40:25.912265336 -0600
|+++ rc-scripts-1.4.16/sbin/livecd-functions.sh 2005-03-22 20:43:08.497311240 -0600
--------------------------
No file to patch.  Skipping patch.
3 out of 3 hunks ignored
===============================================================

PATCH COMMAND:  patch -p4 -g0 < /usr/portage/sys-apps/baselayout/files/rc-scripts-1.4.16-liv$

===============================================================
missing header for unified diff at line 3 of patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- rc-scripts-1.4.16/sbin/livecd-functions.sh.orig    2005-03-22 20:40:25.912265336 -0600
|+++ rc-scripts-1.4.16/sbin/livecd-functions.sh 2005-03-22 20:43:08.497311240 -0600
--------------------------
No file to patch.  Skipping patch.
3 out of 3 hunks ignored

Can anyone help out?

Thanks
Back to top
View user's profile Send private message
rerror
n00b
n00b


Joined: 15 Dec 2004
Posts: 3

PostPosted: Fri Apr 01, 2005 6:21 am    Post subject: Reply with quote

I have the same problem here with the exact same output in .out file.
I'm using stage1-x86-2005.0.tar.bz2 and portage-20050330.tar.bz2. MD5 checksums are ok.

/edit: Just noticed that Stewie Grifin has this problem during emerge --emptytree system. I have it during bootstrap.sh

Thanks
Back to top
View user's profile Send private message
volospin
Apprentice
Apprentice


Joined: 06 Aug 2002
Posts: 156
Location: Hong Kong

PostPosted: Fri Apr 01, 2005 8:50 am    Post subject: Reply with quote

rerror wrote:
I have the same problem here with the exact same output in .out file.
I'm using stage1-x86-2005.0.tar.bz2 and portage-20050330.tar.bz2. MD5 checksums are ok.

/edit: Just noticed that Stewie Grifin has this problem during emerge --emptytree system. I have it during bootstrap.sh

Thanks


I also use the files... stage1-x86-2005.0 and portage-20050330
and added the .out file at Buzilla 87503
_________________
PIII-S 1.4G / 512MB / TUSL2-M / 3C920 x 2 / Seagate Barracuda IV 40GB
Back to top
View user's profile Send private message
peka
l33t
l33t


Joined: 16 Mar 2005
Posts: 773
Location: Płońsk, Poland

PostPosted: Fri Apr 01, 2005 10:07 am    Post subject: Reply with quote

I have used stage1-x86-2005.0.tar.bz2 and portage-20050331.tar.bz2.
I had to boot from a LiveCD from here b/c I have a VIA VT6410 RAID controller.

In my install I did:
- use 2.6.11 kernel-headers from the start
- use gcc-3.4 from the start
I've got some errors in bootstrap but I overcame them by emerging whatever bootstrap wanted by hand starting from gcc, glibc, libc and so on...
Emerging system went without problems.
_________________
p3k4

Seize the time, Meribor. Live now; make now always the most precious time. Now will never come again...
Jean-Luc Picard, Star Trek TNG - The Inner Light
Back to top
View user's profile Send private message
amne
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6378
Location: Graz / EU

PostPosted: Fri Apr 01, 2005 3:56 pm    Post subject: Reply with quote

Moved from IG. Please follow up to Failure bootstraping 2005.0 install.
_________________
Dinosaur week! (Ok, this thread is so last week)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum