Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2005.0 on an external USB drive -- can it be done?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Syzygy
n00b
n00b


Joined: 30 Apr 2004
Posts: 31
Location: Beloit, WI

PostPosted: Sat Apr 02, 2005 6:02 am    Post subject: 2005.0 on an external USB drive -- can it be done? Reply with quote

I'm in the middle of installing the PPC64 2005.0 from LiveCD on an external USB drive plugged into my G5. Everything is going (mostly) swimmingly in the install. (mac-fdisk lists the USB drive as /dev/sdb and I'm kinda assuming that that will always be the case.)

Now, I run into a problem when configuring yaboot-static. The conf file requires the OF name of the boot drive, but ofpath claims USB drives are unsupported. Am I SOL or is there a way to get yaboot-static configured for a USB drive? (Or some other boot loader I can use?)

(Side note: This drive is actually an ATA drive on a FireWire/USB2 external chassis. Normally I plug it into the FireWire port, but Gentoo won't even recognize it then, so I switched it to the USB port.)

UPDATE: I tried manually booting from the disk at the OF prompt, after formatting the boot partition according to the example shown on this Debian site. I forget how to list my device tree in OF, so I just typed "boot usb<port>/disk@<loc>:yaboot", incrementing <port> and <loc> until something happened. (For the sake of posterity, my drive is the only device plugged into the G5's front panel USB port.) As one would expect, most of the time it simply returned Unable to open, but for usb4/disk@0, it continued with the boot, and I was presented with the circle-slash screen. An improvement...?

With this clue that perhaps my drive is at usb4/disk@0, I am going to see if installing yaboot on it does the trick. Hopefully I don't have to change anything else in the conf.

Would yaboot work if I proceeded as normal, somehow finding the OF address for the drive and leaving all else the same? Can someone provide a yaboot.conf file configured appropriately for USB booting? And also -- any other considerations I should know during the Gentoo install?
Back to top
View user's profile Send private message
FearlessSpiff
n00b
n00b


Joined: 26 Sep 2004
Posts: 69

PostPosted: Thu Apr 07, 2005 9:40 pm    Post subject: Reply with quote

Did it work? I'm thinking about doing the same, but i'm not sure if it works...
Back to top
View user's profile Send private message
Pylon
Retired Dev
Retired Dev


Joined: 17 Jan 2003
Posts: 279
Location: Cologne

PostPosted: Thu Apr 07, 2005 11:35 pm    Post subject: Reply with quote

There are solutions with Gentoo on an external FireWire drive attached to a G5 in this forum. Use the search ;-) I guess, USB may be the same.

Probably you want to build a kernel with an initrd that boots from the RAM, searches for other devices via coldplug and then mount the root-partition from USB. That's the way we do it with the LiveCD (only that we use the squashfs on the CD-ROM as root-partition). You can compile such a kernel and initrd with genkernel and then tell the correct pathes in the append of the yaboot-conf. yaboot should be able to boot a kernel even from an HFS+ partition, so you don't need to change your partitions on the built-in disk. Just copy your kernel and initrd somewhere on that disk.
_________________
hacking is not a crime
Back to top
View user's profile Send private message
Little Nemo
l33t
l33t


Joined: 29 Mar 2004
Posts: 623
Location: Berlin, Germany

PostPosted: Fri Apr 08, 2005 6:30 am    Post subject: Reply with quote

That's what I'm just trying (on a Firewire drive). Yaboot works properly now with the append stuff (root=/dev/ram0 real_root=/dev/sdb5), but the initrd produced by genkernel includes no modules whatsoever, and the /dev/sdxx devices aren't there). I ran genkernel with --udev, but I guess I need to modify linuxrc and somehow tell genkernel which modules I want included. What's the best way to do that?
Back to top
View user's profile Send private message
davidblewett
Apprentice
Apprentice


Joined: 15 Feb 2004
Posts: 274
Location: Indiana

PostPosted: Tue Jul 12, 2005 8:50 pm    Post subject: Reply with quote

I have an external 40gig hard drive connected to my laptop through a USB2 enclosure. I have a boot, swap and root partition set up on it.

Everything runs fine, but it looks like Software Suspend isn't going to work. It looks like the USB drivers are loaded *just* after software suspend tries to resolve the device name (/dev/sdb3), so it doesn't find it. If I wait a second, then tell it to continue, it boots just fine. I'm using kernel 2.6.12.2 with CKO patches.

I'm getting pretty good transfer rate, not sure of the exact amount. How can I benchmark that? I'm compiling xorg right now, and it's zooming through it.
_________________
No guilt in life, no fear in death
this is the power of Christ in me
From life’s first cry to final breath
Jesus commands my destiny
-- Newsboys, "In Christ Alone", "Adoration: The Worship Album"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum