Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GCC update fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
aeonflux
n00b
n00b


Joined: 29 Jan 2005
Posts: 8
Location: Los Angeles

PostPosted: Sat Apr 02, 2005 9:18 am    Post subject: GCC update fails Reply with quote

Hi,

I'm having trouble updating gcc; the compile fails. Here's what happens:

Code:
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.3/../../../libc.so when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.3/../../../libc.a when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
/usr/x86_64-pc-linux-gnu/bin/ld: cannot find -lc
collect2: ld returned 1 exit status
make[3]: *** [32/libgcc_s_32.so] Error 1
make[3]: Leaving directory `/var/tmp/portage/gcc-3.4.3-r1/work/build/gcc'
make[2]: *** [stmp-multilib] Error 2
make[2]: Leaving directory `/var/tmp/portage/gcc-3.4.3-r1/work/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.4.3-r1/work/build/gcc'
make: *** [profiledbootstrap] Error 2

!!! ERROR: sys-devel/gcc-3.4.3-r1 failed.
!!! Function gcc_do_make, Line 1138, Exitcode 2
!!! make failed with profiledbootstrap
!!! If you need support, post the topmost build error, NOT this status message.


This is my "emerge info":

Code:
Portage 2.0.51.19 (default-linux/amd64/2004.3, gcc-3.4.3, glibc-2.3.4.20041102-r1, 2.6.9-gentoo-r14 x86_64)
=================================================================
System uname: 2.6.9-gentoo-r14 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 31 2005, 03:55:58)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.9.4, 1.5, 1.8.5-r3, 1.6.3, 1.7.9-r1, 1.4_p6
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r4
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox"
GENTOO_MIRRORS="http://mirrors.usc.edu/pub/linux/distributions/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi aim alsa amd64 arts avi bash-completion berkdb bitmap-fonts bluetooth bmp bzlib cdparanoia cdr crypt cups curl directfb divx4linux dv dvd dvdr dvdread emacs emul-linux-x86 encode esd exif f77 fam fbcon ffmpeg fftw flac font-server fortran ftp gdbm gif glut gnome gnutls gphoto2 gpm gstreamer gtk gtk2 imagemagick imap imlib ipv6 jabber java javascript joystick jp2 jpeg kde kerberos libwww lirc lzw lzw-tiff lzw_tiff mad mbox mime motif mozilla mp3 mpeg msn multilib nas ncurses netboot nls nptl nvidia ogg oggvorbis opengl oss pam pdflib perl plotutils png python qt quicktime readline samba sasl scanner sdl session slang speex spell ssl svg tcltk tcpd tetex theora tidy tiff truetype truetype-fonts type1-fonts unicode usb userlocales v4l vcd videos wifi wmf xine xinerama xml2 xmms xpm xprint xrandr xv xvid yahoo zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY


Thanks for looking into this,

A
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Sat Apr 02, 2005 12:50 pm    Post subject: Reply with quote

have you already checked https://bugs.gentoo.org/ ?
Back to top
View user's profile Send private message
aeonflux
n00b
n00b


Joined: 29 Jan 2005
Posts: 8
Location: Los Angeles

PostPosted: Sat Apr 02, 2005 5:55 pm    Post subject: Reply with quote

One of the forum posts had a link to a bug, but that was for x86, not amd64. If it applies to amd64 too, I guess I'll have to wait it out :)

Thanks,
A
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Apr 05, 2005 3:40 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-309902.html

Moved from Gentoo on AMD64.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum