Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trouble upgrading gcc... wants gcc-4.2-r4?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
koz
n00b
n00b


Joined: 06 Dec 2002
Posts: 27

PostPosted: Sat Apr 02, 2005 11:10 pm    Post subject: Trouble upgrading gcc... wants gcc-4.2-r4? Reply with quote

I apparently screwed up my portage somehow. I've been slowly moving to a new hard drive and transitioning from a 2.4 kernel to 2.6 kernel. I was doing well until I tried to upgrade to xorg-x11. It failed to compile, so I thought I might try getting a new gcc while I was working. However, when I try:

emerge gcc

I get

emerge: there are no ebuilds to satisfy ">=sys-devel/gcc-4.2-r4".

While that's clearly true, I cannot figure out how why it wants gcc-4.2-r4. If I try

emerge =gcc-3.4.3-r1

I get the same result. I tried grepping the entire file structure but I cannot find any reference to gcc-4.2-r4. Google search turns up 3 results, with one of them saying that if you get this error, something is wrong, but it doesn't say what.

I tried removing all files in portage and syncing again, no luck. Any suggestions?
Back to top
View user's profile Send private message
Unther
Apprentice
Apprentice


Joined: 20 Feb 2005
Posts: 163

PostPosted: Sun Apr 03, 2005 12:33 am    Post subject: Reply with quote

Try waiting till the gcc dev's do the 4.0, and 4.1 releases.:lol:

The 4.0 beta build isn't yet available according to the online package database.
Back to top
View user's profile Send private message
rhill
Retired Dev
Retired Dev


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Sun Apr 03, 2005 3:19 am    Post subject: Reply with quote

do you happen to have an old 2.9x version of GCC installed? you can check with 'emerge -Cp gcc'.
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
koz
n00b
n00b


Joined: 06 Dec 2002
Posts: 27

PostPosted: Sun Apr 03, 2005 5:47 am    Post subject: Reply with quote

dirtyepic wrote:
do you happen to have an old 2.9x version of GCC installed? you can check with 'emerge -Cp gcc'.


Yes, I do have an old gcc. I have:
2.95.3-r5
2.95.3-r8
3.3

I can switch between 2.95.3 and 3.3 using gcc-config. Unfortunately, I get the same portage error in both cases.

Ah! But for anyone else; removing the 2.95.3-r5 version fixed the problem. Thanks!
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Sat May 21, 2005 11:55 am    Post subject: Reply with quote

Moved from Portage & Programming in favour of https://forums.gentoo.org/viewtopic-t-243175.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum