Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem Emerging mjpegtools
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
ShadowMetis
Apprentice
Apprentice


Joined: 03 Feb 2005
Posts: 179
Location: Newburgh, NY

PostPosted: Sun Apr 03, 2005 5:53 pm    Post subject: Problem Emerging mjpegtools Reply with quote

I'm trying to install k3b and the dependency 'mjpegtools' is giving me problems.
Quote:

creating liblavrec.la
(cd .libs && rm -f liblavrec.la && ln -s ../liblavrec.la liblavrec.la)
if /bin/sh ../libtool --mode=compile i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF ".deps/liblavplay_la-liblavplay.Tpo" \
-c -o liblavplay_la-liblavplay.lo `test -f 'liblavplay.c' || echo './'`liblavplay.c; \
then mv -f ".deps/liblavplay_la-liblavplay.Tpo" ".deps/liblavplay_la-liblavplay.Plo"; \
else rm -f ".deps/liblavplay_la-liblavplay.Tpo"; exit 1; \
fi
i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF .deps/liblavplay_la-liblavplay.Tpo -c liblavplay.c -fPIC -DPIC -o .libs/liblavplay_la-liblavplay.o
i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF .deps/liblavplay_la-liblavplay.Tpo -c liblavplay.c -o liblavplay_la-liblavplay.o >/dev/null 2>&1
if /bin/sh ../libtool --mode=compile i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF ".deps/liblavplay_la-audiolib.Tpo" \
-c -o liblavplay_la-audiolib.lo `test -f 'audiolib.c' || echo './'`audiolib.c; \
then mv -f ".deps/liblavplay_la-audiolib.Tpo" ".deps/liblavplay_la-audiolib.Plo"; \
else rm -f ".deps/liblavplay_la-audiolib.Tpo"; exit 1; \
fi
i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF .deps/liblavplay_la-audiolib.Tpo -c audiolib.c -fPIC -DPIC -o .libs/liblavplay_la-audiolib.o
i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF .deps/liblavplay_la-audiolib.Tpo -c audiolib.c -o liblavplay_la-audiolib.o >/dev/null 2>&1
/bin/sh ../libtool --mode=link i586-pc-linux-gnu-gcc -O3 -mcpu=i586 -pipe -mno-sse2 -o liblavplay.la -rpath /usr/lib -version-info 2:2:2 -release 1.6 -export-dynamic liblavplay_la-liblavplay.lo liblavplay_la-audiolib.lo
i586-pc-linux-gnu-gcc -shared .libs/liblavplay_la-liblavplay.o .libs/liblavplay_la-audiolib.o -mcpu=i586 -mno-sse2 -Wl,-soname -Wl,liblavplay-1.6.so.0 -o .libs/liblavplay-1.6.so.0.2.2
(cd .libs && rm -f liblavplay-1.6.so.0 && ln -s liblavplay-1.6.so.0.2.2 liblavplay-1.6.so.0)
(cd .libs && rm -f liblavplay.so && ln -s liblavplay-1.6.so.0.2.2 liblavplay.so)
i586-pc-linux-gnu-ar cru .libs/liblavplay.a liblavplay_la-liblavplay.o liblavplay_la-audiolib.o
i586-pc-linux-gnu-ranlib .libs/liblavplay.a
creating liblavplay.la
(cd .libs && rm -f liblavplay.la && ln -s ../liblavplay.la liblavplay.la)
if i586-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=i586 -pipe -mno-sse2 -MT lavplay.o -MD -MP -MF ".deps/lavplay.Tpo" \
-c -o lavplay.o `test -f 'lavplay.c' || echo './'`lavplay.c; \
then mv -f ".deps/lavplay.Tpo" ".deps/lavplay.Po"; \
else rm -f ".deps/lavplay.Tpo"; exit 1; \
fi
/bin/sh ../libtool --mode=link i586-pc-linux-gnu-gcc -O3 -mcpu=i586 -pipe -mno-sse2 -o lavplay lavplay.o ../utils/libmjpegutils.la liblavplay.la liblavjpeg.la liblavfile.la -lpthread -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -lX11
i586-pc-linux-gnu-gcc -O3 -mcpu=i586 -pipe -mno-sse2 -o .libs/lavplay lavplay.o -Wl,-rpath -Wl,/usr/lib ../utils/.libs/libmjpegutils.so ./.libs/liblavplay.so ./.libs/liblavjpeg.so -L/usr/i586-pc-linux-gnu/bin -L/usr/i586-pc-linux-gnu/lib ./.libs/liblavfile.so -L/usr/lib /usr/lib/libquicktime.so -lz /usr/lib/libjpeg.so /usr/lib/libSDL.so //usr/lib/gcc-lib/i586-pc-linux-gnu/3.3.5/libstdc++.so -L/usr/lib/gcc-lib/i586-pc-linux-gnu/3.3.5 -L/usr/lib/gcc-lib/i586-pc-linux-gnu/3.3.5/../../../../i586-pc-linux-gnu/lib -lgcc_s -lc /usr/lib/libasound.so -lm -ldl -lXext -lvga -lpthread -lX11 -Wl,--rpath -Wl,//usr/lib/gcc-lib/i586-pc-linux-gnu/3.3.5
./.libs/liblavfile.so: undefined reference to `quicktime_read_audio'
collect2: ld returned 1 exit status
make[2]: *** [lavplay] Error 1
make[2]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.2-r3/work/mjpegtools-1.6.2/lavtools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.2-r3/work/mjpegtools-1.6.2'
make: *** [all] Error 2
Back to top
View user's profile Send private message
ShadowMetis
Apprentice
Apprentice


Joined: 03 Feb 2005
Posts: 179
Location: Newburgh, NY

PostPosted: Sun Apr 03, 2005 6:19 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-308176-highlight-mjpegtools.html

I shoul've looked before I asked.
Back to top
View user's profile Send private message
^PsYcHo
n00b
n00b


Joined: 27 Feb 2005
Posts: 25

PostPosted: Mon Apr 04, 2005 8:47 pm    Post subject: Reply with quote

Thanks for the link.
_________________
-m3h s3x11 sCr33n1e-
Back to top
View user's profile Send private message
rthealey
n00b
n00b


Joined: 08 Apr 2005
Posts: 19
Location: Rochester, NY

PostPosted: Fri Apr 08, 2005 1:28 am    Post subject: Reply with quote

Quote:
https://forums.gentoo.org/viewtopic-t-308176-highlight-mjpegtools.html


Thanks for the link!! I was ready to make a new post for this problem myself. Worked like a charm.
_________________
--Toshiba Satellite 5105-S901--
Pentium 4 M 2GHz, Intel 845MP Chipset, 512MB RAM, nVidia GeForce4 440 Go 64MB DDR, DVD/CDRW multi-drive, Integrated 802.11b, Integrated 10/100 LAN, Integrated 56K modem, Integrated Bluetooth, cPad pointing device
Back to top
View user's profile Send private message
Marx
n00b
n00b


Joined: 07 Dec 2004
Posts: 19
Location: Sweden

PostPosted: Fri Apr 08, 2005 9:59 pm    Post subject: Reply with quote

Once again, thanks for the link.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Apr 22, 2005 6:18 pm    Post subject: Reply with quote

ShadowMetis wrote:
https://forums.gentoo.org/viewtopic-t-308176-highlight-mjpegtools.html

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum