Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no access on external hdd [RESOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Sun Apr 03, 2005 6:18 pm    Post subject: no access on external hdd [RESOLVED] Reply with quote

Hi!
I run a Debian Sarge on PPC and finally also a Gentoo seems to become working, but Gentoo is also my x86-system. I have an external hdd formatted with three partitions, ext3 and vfat and I got problems with the data-exchange as the ppc-systems don't see it when it has a x86-partition map and the other way round. Now it has a ppc-partition map, but also on the ppc I can mount /dev/sda2 (ext3) and see the files but when I try to access them or to copy them back to my internal hdd the processes become "D" or "D+" (usb-storage and cp). I don't know where the problem lies. Has anyone any idea? Any comment is appreciated, I would like to get my mail backup back on the internal hdd, unfortunately I did not burn it on cd the last time...
Thanks.


Last edited by Bjosch on Sun Oct 16, 2005 10:44 am; edited 1 time in total
Back to top
View user's profile Send private message
fw146
n00b
n00b


Joined: 29 Dec 2003
Posts: 42

PostPosted: Tue Apr 05, 2005 1:40 pm    Post subject: Re: no access on external hdd Reply with quote

Bjosch wrote:
Hi!
I run a Debian Sarge on PPC and finally also a Gentoo seems to become working, but Gentoo is also my x86-system. I have an external hdd formatted with three partitions, ext3 and vfat and I got problems with the data-exchange as the ppc-systems don't see it when it has a x86-partition map and the other way round. Now it has a ppc-partition map, but also on the ppc I can mount /dev/sda2 (ext3) and see the files but when I try to access them or to copy them back to my internal hdd the processes become "D" or "D+" (usb-storage and cp). I don't know where the problem lies. Has anyone any idea? Any comment is appreciated, I would like to get my mail backup back on the internal hdd, unfortunately I did not burn it on cd the last time...
Thanks.


I am not sure about the "D" (dead?) processes, but some info on the partition maps. You can definitely access both PPC and dos (x86) partitioned disks, on both PPC and x86 linux systems. You have to build in support for this into the kernel. Select the "Advanced Partition Selection" under
Code:
File Systems-->Partition Types
Then check/select the appropriate partition types.
EDIT: The appropriate options being
Code:
[*] Macintosh partition map support
[*] PC BIOS (MSDOS partition tables) support

Hope this helps.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Tue Apr 05, 2005 2:24 pm    Post subject: Reply with quote

Hi,
thanks for this. Indeed I know, someone else told me, yet. But it should not be the problem because beside the mail backup there are some folders with mp3 files and I was able to copy them without any problem to my internal hdd. I don't understand why I cannot access the mails; the copying of .mozilla-thunderbird starts and it copies the folder's structure, it blocks after about 4% when getting to the folder's files. Maybe a problem with the data integrity. A hardware problem?? I remember when playing the mp3s some songs caused the same status, so amarok o juk just stopped and did not work any longer, juk even was not able to load all the files in its library. As the time being I don't trust my hdd any longer.
Thanks again, I will check the kernel config.
-Bjoern.
Back to top
View user's profile Send private message
fw146
n00b
n00b


Joined: 29 Dec 2003
Posts: 42

PostPosted: Wed Apr 06, 2005 1:19 pm    Post subject: Reply with quote

Bjosch wrote:
Hi,
thanks for this. Indeed I know, someone else told me, yet. But it should not be the problem because beside the mail backup there are some folders with mp3 files and I was able to copy them without any problem to my internal hdd. I don't understand why I cannot access the mails; the copying of .mozilla-thunderbird starts and it copies the folder's structure, it blocks after about 4% when getting to the folder's files. Maybe a problem with the data integrity. A hardware problem?? I remember when playing the mp3s some songs caused the same status, so amarok o juk just stopped and did not work any longer, juk even was not able to load all the files in its library. As the time being I don't trust my hdd any longer.
Thanks again, I will check the kernel config.
-Bjoern.

Hardware wise, there could be several possibilities.
The USB interface on the external unit. One way to check this is to take the hard-disk out of the external USB enclosure, and connect it as an "internal" drive. An easier way, and probably you already tried it, is to try and copy stuff on a different computer.
Your computer? Sometimes bad memory can have very strange symptoms. If you have not already done this, a memory test would be good idea. Come to think of it, I don't know of a memtest utility for PPC. Perhaps someone else can chime in with asuggestion for this?

IMHO, data integrity should not be the problem. Well it is a problem :) but should not hang cp. You are more likely to get garbage in your files. Filesystem integrity is a different matter. I hope you did not change the partition map from dos to PPC with your data on the disk. Hopefully you can recover your data atleast by the first method.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Sun Apr 10, 2005 11:26 am    Post subject: Reply with quote

Thanks for the advices. Maybe I should try to build it into my mac, but anyway I yet attached it on another computer and it's the same thing. I was even able to access the first directory level, but than nothing else. When I try to copy it hangs at about 4%. Now I installed smartmontools, because I once run it a couple of times over exactly the same disk: now it tells me that the hdd does not support smart. Might this mean that there is a hardware problem?
-Bjoern
Back to top
View user's profile Send private message
fw146
n00b
n00b


Joined: 29 Dec 2003
Posts: 42

PostPosted: Sun Apr 10, 2005 7:46 pm    Post subject: Reply with quote

Bjosch wrote:
Thanks for the advices. Maybe I should try to build it into my mac, but anyway I yet attached it on another computer and it's the same thing. I was even able to access the first directory level, but than nothing else. When I try to copy it hangs at about 4%. Now I installed smartmontools, because I once run it a couple of times over exactly the same disk: now it tells me that the hdd does not support smart. Might this mean that there is a hardware problem?
-Bjoern

OK So let me summarize. You tried to access the external hdd from two different compters. It gets stuck at approximately the same location. Sounds like hardware problem.

I guess the one option still available to you, as I suggested before, is to take out the hard-disk from the external enclosure and put it in a PC/Mac. The external drives are usually, atleast the firewire and usb ones, good old ide/atapi (internal) drives with a bridge (or convertor/adpater). So the harwdware failure could be the bridge or it could be the drive itself. I have to caution you though: You may void your warranty if you open the external drive. Best of luck.

I am not familiar with smartmontools, but any monitoring tools could also fail because the bridge has gone bad.
Back to top
View user's profile Send private message
Bjosch
Tux's lil' helper
Tux's lil' helper


Joined: 04 Feb 2004
Posts: 148

PostPosted: Sun Oct 16, 2005 10:43 am    Post subject: Reply with quote

Actually it seems that it was a hardware problem. I bought a new one and everything works fine. Thanks for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum