Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
grub.conf error somewhere... [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Stewie Griffin
n00b
n00b


Joined: 31 Mar 2005
Posts: 34

PostPosted: Mon Apr 04, 2005 5:21 pm    Post subject: grub.conf error somewhere... [SOLVED] Reply with quote

Code:

Booting 'gentoo linux'
root (hd0,0)
filesystem type is ext2fs, partition type 0x83
kernel /kernel-2.6.11-gentoo-r5 root=/dev/hda3 video=vesafb:ywrap,pmipal,1024x768-16@85 vga=0x317
[Linux-bzImage, setup=0x1400, size=0x20f544]

you passed an underfined mode number
Press <RETURN> to saee video modes available, <SPACE> to continue or wait 30 secs


So i pressed return twice and it started loading, and it applies my framebuffer settings fine... So I'm assuming there's some kind of weird error with the 'vga=' setting? So I searched, and I also tried using info from another thread that said to put vga=791, making the line read like this:
Code:

kernel /kernel-2.6.11-gentoo-r5 root=/dev/hda3 video=vesafb:ywrap,pmipal,1024x768-16@85 [b]vga=791[/b]

That also didn't work - gave me the same error...


Last edited by Stewie Griffin on Mon Apr 04, 2005 6:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Mon Apr 04, 2005 5:35 pm    Post subject: Reply with quote

What happens if you remove the vga parameter? (It shouldn't be passed to the kernel if you are using vesafb-tgn)
Back to top
View user's profile Send private message
Stewie Griffin
n00b
n00b


Joined: 31 Mar 2005
Posts: 34

PostPosted: Mon Apr 04, 2005 6:24 pm    Post subject: Reply with quote

excellent, that worked... Thank you :)
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Mon Apr 04, 2005 7:15 pm    Post subject: Reply with quote

Stewie Griffin wrote:
excellent, that worked... Thank you :)


Moved to Duplicate Threads. This is covered in the Gentoo Handbook: http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap1

Quote:

First of all you need to know what type of framebuffer device you're using. If you use a Gentoo patched kernel tree (such as gentoo-sources) you will have had the possibility of selecting vesafb-tng as the VESA driver type (which is default for these kernel sources). If this is the case, you are using vesafb-tng and do not need to set a vga statement. Otherwise you are using the vesafb driver and need to set the vga statement.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum