Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem with xorg-unichrome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
kaltag
Tux's lil' helper
Tux's lil' helper


Joined: 28 Apr 2004
Posts: 116
Location: Boise, ID

PostPosted: Wed Apr 06, 2005 2:58 am    Post subject: problem with xorg-unichrome Reply with quote

Good evening. I've gotten around to installing Gentoo on my Epia 600 board and everything has worked great until I tried to follow the instructions for getting the xorg-unichrome build going. It keeps failing with a linker error. Anyone else had any problems building xorg-unichrome? I have changed my cflags and USE flags to minimal settings and it didn't change anything. Thanks for nay help you can provide.

Edit: here's the error
Code:
URCE                             -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO   -DXENVIRONMENT    -c -o pswstring.o pswstring.c
i586-pc-linux-gnu-gcc -Os -march=i586 -fomit-frame-pointer -pipe -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w     -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                            -D_POSIX_SOURCE -D_XOPEN_SOURCE                                 -D_BSD_SOURCE -D_SVID_SOURCE                             -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO   -DXENVIRONMENT    -c -o pswsemantics.o pswsemantics.c
rm -f pswrap
i586-pc-linux-gnu-gcc -o pswrap -Os -march=i586 -fomit-frame-pointer -pipe -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w     -L../../exports/lib   main.o pswparser.o lexer.o pswdict.o pswfile.o    systemnames.o psw.o pswstring.o pswsemantics.o     -lfl  -Wl,-rpath-link,../../exports/lib
/usr/lib/gcc-lib/i586-pc-linux-gnu/3.3.5/../../../../i586-pc-linux-gnu/bin/ld: cannot find -lfl
collect2: ld returned 1 exit status
distcc[19311] ERROR: compile (null) on localhost failed
make[4]: *** [pswrap] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-unichrome-6.8.0-r29/work/xc/config/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-unichrome-6.8.0-r29/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-unichrome-6.8.0-r29/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-unichrome-6.8.0-r29/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-unichrome-6.8.0-r29 failed.
!!! Function src_compile, Line 286, Exitcode 2
!!! make World failed
!!! If you need support, post the topmost build error, NOT this status message.


Second edit: It appears that the regular xorg-x11 is failing as well. So the problem lyes somewhere else.
_________________
Yeah, I know about the recovery console. Usually, it doesn't do anything more than I can do with a match, a weedwhacker, and a sledgehammer. Actually, it does a whole lot less. - Caffinehog
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun May 08, 2005 9:15 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-295915.html

Moved from Desktop Environments.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum