Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"emerge --unmerge" Failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Karl_R
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2004
Posts: 118
Location: Sydney

PostPosted: Wed Apr 06, 2005 10:47 am    Post subject: "emerge --unmerge" Failing Reply with quote

Hi,

I have had problems for a while with Gnome in particular I get mesages like "gconf may not be configured properly" when trying to set my background or theme etc.

So I had a bit of time and tried to completely remove gnome and gconf and re-install them.

I got the list of all packages the "gnome" needs buy using
Code:
emerge -p --emptytree gnome

and then set about removing any thing gnomey from my system.

However it borked at gconf. here is the error.

Code:

myhost root # emerge --unmerge gconf

 gnome-base/gconf
    selected: 1.0.9
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging gnome-base/gconf-1.0.9...
No package files given... Grabbing a set.

QA Notice: ECLASS 'libtool' inherited illegally in gnome-base/gconf-1.0.9


QA Notice: ECLASS 'gnome.org' inherited illegally in gnome-base/gconf-1.0.9


QA Notice: ECLASS 'eutils' inherited illegally in gnome-base/gconf-1.0.9


QA Notice: ECLASS 'multilib' inherited illegally in gnome-base/gconf-1.0.9

/usr/lib/portage/bin/ebuild.sh: /var/db/pkg/gnome-base/gconf-1.0.9/gconf-1.0.9.ebuild: line 33: syntax error near unexpected token `sys-devel/gettext'
/usr/lib/portage/bin/ebuild.sh: /var/db/pkg/gnome-base/gconf-1.0.9/gconf-1.0.9.ebuild: line 33: `       nls? ( sys-devel/gettext )"'

!!! ERROR: gnome-base/gconf-1.0.9 failed.
!!! Function , Line 1702, Exitcode 1
!!! error sourcing ebuild
!!! If you need support, post the topmost build error, NOT this status message.

!!! FAILED prerm: 1


incidentaly if I want to emerge gconf this is what will be installed in a new slot
Code:

myhost root # emerge -pu gconf

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  NS   ] gnome-base/gconf-2.8.1-r1


Does anyone know how I can unmerge gconf especially version 1.0.9 , or should I just re-emerge it? then try again?

cheers

Karl
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Wed Apr 06, 2005 12:21 pm    Post subject: Reply with quote

Moved to dups. Please see can't unmerge gconf 1.0.9 and Unexpected EOF error on unmerging.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum