Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
block device unspecified or not detected
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
spinnekop
n00b
n00b


Joined: 04 Apr 2005
Posts: 1

PostPosted: Mon Apr 04, 2005 11:22 pm    Post subject: Reply with quote

Hi, I'm new to Gentoo, trying 2005.0

I get this error :(

>> Determining root device...
>> Block device /dev/sda2 is not a valid root device
The root block device is unspecified or not detected
Please specify a device to boot, or "shell" for a shell...
boot()::

What am I doing wrong? Below is my lilo.conf, I suspect the problem is at
the real_root part - but I'm not sure. Please help!


boot=/dev/sda # Install LILO in the MBR
prompt # Give the user the chance to select another section
timeout=50 # Wait 5 (five) seconds before booting the default section
default=gentoo # When the timeout has passed, boot the "gentoo" section

# For genkernel users
image=/boot/kernel-2.6.11-gentoo-r3
label=gentoo
read-only
root=/dev/ram0
append="init=/linuxrc ramdisk=8192 doscsi real_root=/dev/sda2"
initrd=/boot/initrd-2.6.11-gentoo-r3

# The next two lines are only if you dualboot with a Windows system.
# In this case, Windows is hosted on /dev/hda6.
other=/dev/sda1
label=windows
Back to top
View user's profile Send private message
loki99
Advocate
Advocate


Joined: 10 Oct 2003
Posts: 2056
Location: Vienna, €urope

PostPosted: Wed Apr 06, 2005 7:10 pm    Post subject: Reply with quote

spinnekop wrote:
Hi, I'm new to Gentoo, trying 2005.0

I get this error :(

>> Determining root device...
>> Block device /dev/sda2 is not a valid root device
The root block device is unspecified or not detected
Please specify a device to boot, or "shell" for a shell...
boot()::

What am I doing wrong? Below is my lilo.conf, I suspect the problem is at
the real_root part - but I'm not sure. Please help!




sorry, i don't know what the solution to your prob is, but you should start your own thread, if you want to get some community support. :wink:

--------------
loki99
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Fri Apr 08, 2005 12:08 am    Post subject: Reply with quote

Split from original thread: https://forums.gentoo.org/viewtopic-t-319064.html

Moved to Duplicate Threads in favor of https://forums.gentoo.org/viewtopic-t-320782.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum