Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge xorg problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
SiberianX37
n00b
n00b


Joined: 28 Mar 2005
Posts: 23

PostPosted: Mon Apr 11, 2005 1:59 pm    Post subject: emerge xorg problems Reply with quote

Hi Everyone. I just put a brand new gentoo tux on my computer, and i'm trying to get a desktop environment now. the problem is, when I emerge xorg-x11, it goes through a bunch of folders and tells me there's nothing to do in them. here's the code for the error. sorry for any misspellings.
Code:

cllect 2: id returned 1 exit status
make [4] ***[pswrap] Error 1
make [4] leaving directory /var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap
make[3] *** [../../config/pswrap/pswrap[ Error 2
make [3] Leaving directory /var/tmp/portage/xorg-x11-6.8.2-r1//work/xc/lib/dps
make [2]***[includes] error2
make [2] Leaving directory /var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib
make [1]***[includes] error2
make [1] Leaving directory /var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/
make: *** [World} Error 2


and the code of make.conf


Code:

CFLAGS = "-02"
CHOST = "X86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
Gentoo mirrors ----- well there's  a bunch there


any ideas guys? i am sooo lost
Back to top
View user's profile Send private message
Gherald
Veteran
Veteran


Joined: 23 Aug 2004
Posts: 1399
Location: CLUAConsole

PostPosted: Mon Apr 11, 2005 2:03 pm    Post subject: Reply with quote

You need to post the error message further back.. so we can see what caused the 1 exit status...
Back to top
View user's profile Send private message
namrewolf
n00b
n00b


Joined: 28 Jun 2004
Posts: 5

PostPosted: Mon Apr 11, 2005 3:32 pm    Post subject: Reply with quote

I had the same problems. I solve the problem by downgrade the package, flex from the latest 2.5.31 *i think* to the 2nd latest version which is 2.5.4a. I am not too sure if 2.5.31 will cause any problems for other packages, but i will be using 2.5.4a for now

I hope this will solve your problem.
Back to top
View user's profile Send private message
SiberianX37
n00b
n00b


Joined: 28 Mar 2005
Posts: 23

PostPosted: Mon Apr 11, 2005 8:36 pm    Post subject: Reply with quote

Hi guys. I will post the code a little later not at my computer now. However i have a question. first, how do you downgrade (i'm a n00b) and also is there any way i can scroll up in the code. thanks
Back to top
View user's profile Send private message
Gherald
Veteran
Veteran


Joined: 23 Aug 2004
Posts: 1399
Location: CLUAConsole

PostPosted: Mon Apr 11, 2005 8:45 pm    Post subject: Reply with quote

SiberianX37 wrote:
Hi guys. I will post the code a little later not at my computer now. However i have a question. first, how do you downgrade (i'm a n00b) and also is there any way i can scroll up in the code. thanks

Ctrl+pageup usually, but here's a better solution:

mkdir /var/log/portage
echo "PORT_LOGDIR=/var/log/portage" >> /etc/make.conf

Now when you emerge logs will be created in /var/log/portage. Very, very, very... no, _extremely_ handy.
Back to top
View user's profile Send private message
namrewolf
n00b
n00b


Joined: 28 Jun 2004
Posts: 5

PostPosted: Tue Apr 12, 2005 12:48 am    Post subject: Reply with quote

SiberianX37 wrote:
Hi guys. I will post the code a little later not at my computer now. However i have a question. first, how do you downgrade (i'm a n00b) and also is there any way i can scroll up in the code. thanks


This may not be the correct/best way but I would
Code:
 cd /usr/portage/sys-devel/flex
then
Code:
emerge flex-2.5.4a-r6.ebuild
Back to top
View user's profile Send private message
Gherald
Veteran
Veteran


Joined: 23 Aug 2004
Posts: 1399
Location: CLUAConsole

PostPosted: Tue Apr 12, 2005 2:16 am    Post subject: Reply with quote

The correct way is to put

">sys-devel/flex-2.5.4a-r6" in /etc/portage/package.mask
Back to top
View user's profile Send private message
SiberianX37
n00b
n00b


Joined: 28 Mar 2005
Posts: 23

PostPosted: Tue Apr 12, 2005 5:00 am    Post subject: Reply with quote

there's soo much stuff i wanna post. i probably won't be able to type it all. is there any way i can copy and paste? possibly SSH? it's telling me something about a config file, not recognizing distro and saying that i already have xorg installed. is there any way i can ssh into there
Back to top
View user's profile Send private message
Gherald
Veteran
Veteran


Joined: 23 Aug 2004
Posts: 1399
Location: CLUAConsole

PostPosted: Tue Apr 12, 2005 7:43 pm    Post subject: Reply with quote

Code:
/etc/init.d/sshd start
rc-update add sshd default

Then you can transfer files with scp or sftp.
Back to top
View user's profile Send private message
SiberianX37
n00b
n00b


Joined: 28 Mar 2005
Posts: 23

PostPosted: Wed Apr 13, 2005 5:35 am    Post subject: Reply with quote

Sweet. Thanks Gherald. Ok Here's some peculiar things i found
[/code]^[[32;01m*^[[0m Previous xorg-x11 installation detected[code]
and
[code]
Building Release 6.8.2.

I hope you checked the configuration parameters in ./config/cf
to see if you need to pass BOOTSTRAPCFLAGS.
[/code]

and

[code]
make -f xmakefile - --jobserver-fds=3,4 -j VerifyOS
make[1]: Entering directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make[1]: warning: jobserver unavailable: using -j1. Add `+' to parent make rule.

Building on Linux 2.6.11-gentoo-r3 x86_64 [ELF] (2.6.11).

Linux Distribution: Unknown
libc version: 6.3.4
binutils version: 2.9

GCC version: 3.4
[/code]
and the last chunk of code.

[code]
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/GLw'
including in lib/dps...
make[3]: Entering directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
checking ../../config/pswrap/pswrap over in ../../config/pswrap first...
make[4]: Entering directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap'
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
bison -y -d pswparser.y
conflicts: 1 shift/reduce
mv -f y.tab.c pswparser.c
+ mv -f y.tab.h pswparser.h
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
flex -l -t lexer.l > lexer.c
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
rm -f pswfile.o
x86_64-pc-linux-gnu-gcc -c -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include $
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
x86_64-pc-linux-gnu-gcc -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -I../.. -I../../exports/include -$
rm -f pswrap
x86_64-pc-linux-gnu-gcc -o pswrap -O2 -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -L../../exports/lib mai$
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lfl
collect2: ld returned 1 exit status
make[4]: *** [pswrap] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [World] Error 2
[/code]

I hope some of the things i posted on here are relevant. please let me know. thanks
Back to top
View user's profile Send private message
marklap
n00b
n00b


Joined: 13 Apr 2005
Posts: 1

PostPosted: Wed Apr 13, 2005 2:57 pm    Post subject: Thanks! Reply with quote

I was having the exact same problem. I followed the instructions mentioned in this thread (see below) and I'm compiling x11 as I type. Thanks again.

Code:
echo \>sys-devel/flex-2.5.4a-r6 >> /etc/portage/package.mask
emerge flex
emerge x11


:D
_________________
-Mark
Back to top
View user's profile Send private message
toffelsen
n00b
n00b


Joined: 22 Apr 2004
Posts: 24
Location: Germany

PostPosted: Thu Apr 14, 2005 10:29 am    Post subject: auch ein emerge xorg-x11 fehler Reply with quote

wie genau heißt denn nu der echo ... flex Befehl?
So wie es da steht, ist da doch ein Tippfheler drin, oder?
_________________
AMD Athlon64™ 3000+, Asus K8V-F (Targa Edition), Chipset VIA K8T800 + VT8237,
512 MB DDR-RAM PC3200, ATI® RADEON® 9800 PRO AIW
Back to top
View user's profile Send private message
Gherald
Veteran
Veteran


Joined: 23 Aug 2004
Posts: 1399
Location: CLUAConsole

PostPosted: Thu Apr 14, 2005 8:04 pm    Post subject: Re: auch ein emerge xorg-x11 fehler Reply with quote

toffelsen wrote:
wie genau heißt denn nu der echo ... flex Befehl?
So wie es da steht, ist da doch ein Tippfheler drin, oder?

Are you lost? Here are some directions.
Back to top
View user's profile Send private message
Pithlit
l33t
l33t


Joined: 27 Dec 2003
Posts: 887
Location: fuhen

PostPosted: Thu Apr 14, 2005 8:10 pm    Post subject: Reply with quote

Toffelsen: there's no typo in that line... ">" is a special character and needs "\" in front of it for the line to work correctly.
_________________
If someone solves a problem for you say thanks... and put [SOLVED] in the title!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun May 08, 2005 9:18 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-295915.html

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum