Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge mod_php fails after GCC upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dalamarian
n00b
n00b


Joined: 08 May 2003
Posts: 30

PostPosted: Mon Apr 11, 2005 3:34 pm    Post subject: emerge mod_php fails after GCC upgrade Reply with quote

I know there have been several posts about this, but I have followed their advice to no avail.

I get the error below.

Code:
make: *** [libphp4.la] Error 1
make: *** Waiting for unfinished jobs....
libtool: link: cannot find the library `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.4/libstdc++.la'
make: *** [sapi/cli/php] Error 1


The location of the library is actually

Code:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/libstdc++.la


My gcc version is 3.3.5-20050130.

I tried:

Code:
fix_libtool_files.sh 3.3.4

Code:
fix_libtool_files.sh 3.3.5

Code:
fix_libtool_files.sh 3.3.5-2005130


Each didn't work.

What shall I do?

Thanks.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Apr 11, 2005 3:52 pm    Post subject: Reply with quote

weeeell, if nothing else seems to work, you could always create a symlink /usr/lib/gcc-lib/i386-pc-linux-gnu pointing to /usr/lib/gcc-lib/i686-pc-linux-gnu.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Apr 11, 2005 4:51 pm    Post subject: Reply with quote

Please see this sticky: https://forums.gentoo.org/viewtopic-t-278673.html, and this FAQ: https://forums.gentoo.org/viewtopic-t-279020.html. In your case, I think you should look at the --oldarch option as the library looked for seems to have been built with an i386 CHOST. This should work:
Code:
fix_libtool_files.sh 3.3.4 --oldarch i386-pc-linux-gnu


Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum