Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
testing memory?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
dannysauer
n00b
n00b


Joined: 23 Sep 2004
Posts: 60
Location: Lincoln, IL

PostPosted: Mon Apr 11, 2005 4:17 pm    Post subject: testing memory? Reply with quote

I'm having some bizzare problems on a G4, and the problems have been getting worse recently. I'm suspecting memory problems, since tar xzf'ing some known good .tgz files is failing with a signal 11 now, and I get other weird problems (like sometimes booting fails just after the kernel initializes the serial driver). Anyway, were this a PC, I'd just fire up memtest86 and let it run for a while. I don't think that memtext86 sounds like somnething that'll run well on a non-x86 platform, though. :) Any suggestions for something that I *can* run that'll actually identify what piece of hardware in this thing is actually causing the problems - if any?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Apr 11, 2005 4:36 pm    Post subject: Reply with quote

perhaps memtester:
Code:
The last stable version is:
  [ N] sys-apps/memtester (4.0.3): Memory testing utility

_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
dannysauer
n00b
n00b


Joined: 23 Sep 2004
Posts: 60
Location: Lincoln, IL

PostPosted: Mon Apr 11, 2005 8:42 pm    Post subject: Reply with quote

Aww, crap.

Code:

>>> md5 src_uri ;-) memtester-4.0.3.tar.gz
>>> Unpacking source...
>>> Unpacking memtester-4.0.3.tar.gz to /var/tmp/portage/memtester-4.0.3/work
/usr/lib/portage/bin/ebuild.sh: line 360: 27965 Segmentation fault      tar xzf"${DISTDIR}/${x}" ${tarvars}

!!! ERROR: sys-apps/memtester-4.0.3 failed.
!!! Function unpack, Line 375, Exitcode 139
!!! failure unpacking memtester-4.0.3.tar.gz
!!! If you need support, post the topmost build error, NOT this status message.


I guess I'll install Gentoo on another machine so I can build packages, then install the binaries. Argh. Or maybe I'll just swap out the memory and see what happens. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum