Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo hangs (or appears to) at login after installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mattwood2000
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2005
Posts: 146

PostPosted: Thu Apr 14, 2005 5:18 pm    Post subject: Gentoo hangs (or appears to) at login after installation Reply with quote

I just installed Gentoo successfully on my G3 PowerBook. When the boot process finishes the login prompt is displayed on screen, but when I try to type root nothing is displayed on the screen. I tried typing root then hitting enter and then my password to see if it was a graphics problem, but nothing happens. Anyone have this problem or hear about it? Thanks. Matt.
Back to top
View user's profile Send private message
jpl888
Guru
Guru


Joined: 13 Apr 2005
Posts: 337
Location: Piltown, Co. Kilkenny, Ireland.

PostPosted: Fri Apr 15, 2005 6:47 pm    Post subject: Reply with quote

Did you try an external keyboard, in case it is something to do with that?
Back to top
View user's profile Send private message
mattwood2000
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2005
Posts: 146

PostPosted: Fri Apr 15, 2005 7:18 pm    Post subject: Reply with quote

My G3 doesnt have an external PS/2 keyboard input and I do not have any USB keyboards. I see that someone else is having this same problem as well. I've been following their posts and replys. Hopefully I'll find a solution. I'll try recompiling the kernel again with differnet support. Thanks. Matt.
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Fri Apr 15, 2005 7:55 pm    Post subject: Reply with quote

Moved from Installing - it's more likely you'll get help here.
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Fri Apr 15, 2005 9:48 pm    Post subject: Reply with quote

The fix should be as simple as compiling ADB support into your kernel, the keyboard and mouse are ADB devices in all but the most recent Powerbooks.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
mattwood2000
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2005
Posts: 146

PostPosted: Sun Apr 17, 2005 4:56 pm    Post subject: Reply with quote

Well that definately did the trick. I compiled ADB support and the keyboard works fine now. I guess when the manual says not to compile ADB support they are assuming it is a new G3. Thanks for the help. Matt.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Apr 17, 2005 6:47 pm    Post subject: Reply with quote

Sorry about the confusion with the handbook, it doesn't say to disable ADB, just ADB raw keycodes which isn't an option in 2.6 kernels! I'll get that fixed ASAP, thanks. :)
Back to top
View user's profile Send private message
mattwood2000
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2005
Posts: 146

PostPosted: Sun Apr 17, 2005 9:34 pm    Post subject: Reply with quote

No problem glad I could help
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum