Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 3.4 emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
avieth
Veteran
Veteran


Joined: 17 Sep 2004
Posts: 1945
Location: Canada

PostPosted: Sat Apr 16, 2005 10:21 pm    Post subject: KDE 3.4 emerge Reply with quote

I type

Code:

emerge -p kde


It shows me packages for kde 3.3.2! I just reinstalled yesturday! How can I get my system to emerge KDE 3.4?
Back to top
View user's profile Send private message
nrdu
n00b
n00b


Joined: 17 Apr 2004
Posts: 66

PostPosted: Sat Apr 16, 2005 11:57 pm    Post subject: Reply with quote

As far as I know, kde 3.4 is still masked in portage.

http://gentoo-wiki.com/Masked
Back to top
View user's profile Send private message
Gherald
Veteran
Veteran


Joined: 23 Aug 2004
Posts: 1399
Location: CLUAConsole

PostPosted: Sun Apr 17, 2005 12:08 am    Post subject: Reply with quote

Yep.

If you want to see what versions of a package are masked, emerge eix

Once you set it up, simply "eix <pkgname>". Masked versions will have a ~ in front of them.

"etcat -v" from gentoolkit also works, but is much slower

Or you could just go to packages.gentoo.org if you're more of a GUI person:

http://packages.gentoo.org/search/?sstring=kde-base
Back to top
View user's profile Send private message
Galuvian
n00b
n00b


Joined: 16 Sep 2004
Posts: 30

PostPosted: Sun Apr 17, 2005 4:54 am    Post subject: Reply with quote

Try this to see what version you'll get from kde-meta
Code:
emerge -pv kde-meta


You'll probably need to add ~arch to your package.keywords file in order to emerge it
Code:
ls /usr/portage/kde-base | awk '{ print ">=kde-base/"$1" ~x86" }' >> /etc/portage/package.keywords


The kde 3.4 packages don't have the ~amd64 flag yet (last I checked anyway), if you are running x86 skip this...
Code:

emerge gentoolkit-dev
ekeyword \~amd64 /usr/portage/kde-base/*/*.ebuild



If you are still on the 2004.3 profile you'll also need to run:
Code:
ls /usr/portage/kde-base | awk '{ print ">=kde-base/"$1"" }' >> /etc/portage/package.unmask


FINALLY, emerge the packages you want from kde. If you want everything and the kitchen sink run
Code:
emerge kde-meta


If you want a light install just specify which packages you want. Search the forums for the packages other people are using.
Back to top
View user's profile Send private message
CyD
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jul 2004
Posts: 117

PostPosted: Sun Apr 17, 2005 4:59 am    Post subject: Reply with quote

i did an amd64 install last week, ~amd64 keyword is there :)
Back to top
View user's profile Send private message
iainvt
Guru
Guru


Joined: 12 Sep 2004
Posts: 462
Location: UK

PostPosted: Sat Apr 23, 2005 8:18 am    Post subject: Reply with quote

Galuvian wrote:
Try this to see what version you'll get from kde-meta
Code:
emerge -pv kde-meta


You'll probably need to add ~arch to your package.keywords file in order to emerge it
Code:
ls /usr/portage/kde-base | awk '{ print ">=kde-base/"$1" ~x86" }' >> /etc/portage/package.keywords


The kde 3.4 packages don't have the ~amd64 flag yet (last I checked anyway), if you are running x86 skip this...
Code:

emerge gentoolkit-dev
ekeyword \~amd64 /usr/portage/kde-base/*/*.ebuild



If you are still on the 2004.3 profile you'll also need to run:
Code:
ls /usr/portage/kde-base | awk '{ print ">=kde-base/"$1"" }' >> /etc/portage/package.unmask


FINALLY, emerge the packages you want from kde. If you want everything and the kitchen sink run
Code:
emerge kde-meta


If you want a light install just specify which packages you want. Search the forums for the packages other people are using.


very useful thankyou
_________________
iain
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18070

PostPosted: Sun Jul 17, 2005 6:57 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-304042-highlight-kde+unmask.html
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum