Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Another PHP compilation problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
fwph
n00b
n00b


Joined: 18 Jun 2004
Posts: 3

PostPosted: Sun Apr 17, 2005 5:40 pm    Post subject: Another PHP compilation problem Reply with quote

Code:

/bin/sh /var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/sysvsem/ -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/sysvsem/ -DPHP_ATOM_INC -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/include -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/main -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11 -I/usr/include/libxml2 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/imap -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/mbstring/mbregex -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/mbstring/libmbfl -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/usr/include/pspell -I/usr/qt/3/include -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/xml/expat -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/TSRM -I/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/Zend    -O2 -march=athlon-mp -funroll-loops -pipe  -prefer-non-pic -c /var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/sysvsem/sysvsem.c -o ext/sysvsem/sysvsem.lo
/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/swf/swf.c: In function `zif_swf_openfile':
/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/swf/swf.c:256: error: label at end of compound statement
make: *** [ext/swf/swf.lo] Error 1
make: *** Waiting for unfinished jobs....
/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/sysvmsg/sysvmsg.c: In function `zif_msg_receive':
/var/tmp/portage/mod_php-4.3.11/work/php-4.3.11/ext/sysvmsg/sysvmsg.c:318: warning: passing arg 2 of `php_var_unserialize' from incompatible pointer type

!!! ERROR: dev-php/mod_php-4.3.11 failed.
!!! Function php-sapi_src_compile, Line 544, Exitcode 2
!!! compile problem
!!! If you need support, post the topmost build error, NOT this status message.


Any suggestions?
Back to top
View user's profile Send private message
keyson
l33t
l33t


Joined: 10 Jun 2003
Posts: 829
Location: Sweden

PostPosted: Sun Apr 17, 2005 6:10 pm    Post subject: Reply with quote

Hi.

This is a bug in the portage. The new mod_php can't build
with flash support.

So if you do.

Code:
USE="-flash" emerge mod_php

Then it should compile. If you need flash
look for the bugg report (i think there is one)
and se what have been done so far.
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3829
Location: Essen, Germany

PostPosted: Mon Apr 18, 2005 7:09 am    Post subject: Reply with quote

Take a look here for a solution: https://forums.gentoo.org/viewtopic-p-2313549.html#2313549
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Mon Apr 18, 2005 7:56 am    Post subject: Reply with quote

Moved from Portage & Programming.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum