Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Yabootconfig OpenFirmware issue... [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
abyssknight
n00b
n00b


Joined: 17 Apr 2005
Posts: 8

PostPosted: Sun Apr 17, 2005 7:10 pm    Post subject: Yabootconfig OpenFirmware issue... [SOLVED] Reply with quote

I'm a complete newbie when it comes to Gentoo, but I followed the 2005.0 installation guide, using the Universal install cd and I got as far as the bootloader, and I can't seem to figure out what to do next!

Here's the issue:

I emerge yaboot, exit the chroot (as it says to), run yabootconfig --chroot /mnt/gentoo and the program asks for the kernel location, the location won't work, it rejects it. So I assume that maybe the guide was wrong, and I needed to stay in chroot, so I try it again from inside the chroot environment, and it works just fine until I've entered everything and it aborts saying:

"ofpath: /dev/ROOT/: No such file or directory.

yabootconfig: Unable to determine OpenFirmware device name to /dev/ROOT, aborting..."


Machine Info:

G4 Sawtooth AGP Graphics (350Mhz PPC, 128mb Ram, ATI Rage, Zip, CD/DVD Rom, 10gb HD)

Install Info:

Used genkernel
Used Universal installation live cd


Any help you all can provide would be greatly appreciated.

Thanks,
-Abyss


Last edited by abyssknight on Sun Apr 17, 2005 10:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 419
Location: London, U.K. & Lisbon, Portugal

PostPosted: Sun Apr 17, 2005 7:41 pm    Post subject: Reply with quote

you have to substitute /dev/ROOT for you real root device. in your case, i guess it's /dev/hda, but you better check that out first. :)
Back to top
View user's profile Send private message
abyssknight
n00b
n00b


Joined: 17 Apr 2005
Posts: 8

PostPosted: Sun Apr 17, 2005 8:11 pm    Post subject: Reply with quote

Where do I set that up?

This is in the yabootconfig program where I am getting the error... not sure how I can fix this.

In my fstab I have hda4 as the root linux partition...
Back to top
View user's profile Send private message
mil0t
n00b
n00b


Joined: 24 Jun 2003
Posts: 62

PostPosted: Sun Apr 17, 2005 9:35 pm    Post subject: Reply with quote

Hi,

When yabootconfig --chroot /mnt/gentoo asks for kernel path you must enter the path like this:

Code:

/mnt/gentoo/boot/bzImage


or

Code:

/mnt/gentoo/boot/vmlinux


and i hope it works if you have /dev/hda4 in /etc/fstab as /

//mil0t
_________________
emerge --pretend love | genlop --pretend
Back to top
View user's profile Send private message
abyssknight
n00b
n00b


Joined: 17 Apr 2005
Posts: 8

PostPosted: Sun Apr 17, 2005 10:19 pm    Post subject: Reply with quote

Awesome, that worked.

Thanks a lot for the responses.

That seems to have solved both issues.

Time to move on!
Back to top
View user's profile Send private message
mil0t
n00b
n00b


Joined: 24 Jun 2003
Posts: 62

PostPosted: Sun Apr 17, 2005 10:35 pm    Post subject: Reply with quote

abyssknight wrote:
Awesome, that worked.

Thanks a lot for the responses.

That seems to have solved both issues.

Time to move on!


Congrats, and don't forget to put [SOLVED] on the subject ;).

//mil0t
_________________
emerge --pretend love | genlop --pretend
Back to top
View user's profile Send private message
abyssknight
n00b
n00b


Joined: 17 Apr 2005
Posts: 8

PostPosted: Sun Apr 17, 2005 10:41 pm    Post subject: More issues with Yaboot Reply with quote

Of course now it will only boot if I have the cd in, and then its still just the live cd.

It gets to the orange/pink "Loading second stage bootstrap..." screen and just cycles until I either put the cd in or turn it off.

Any thoughts?

I'm guessing I've gotten the bootloader incorrect or something of that nature...

Just noticed this is probably another issue, so I'll start a new thread. This one is now marked solved. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum