Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerging xorg-x11 results in weird error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Johny the Ripper
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2004
Posts: 135
Location: EU - Belgium

PostPosted: Sun Apr 17, 2005 10:05 pm    Post subject: emerging xorg-x11 results in weird error Reply with quote

This is the error:
Code:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lfl
collect2: ld returned 1 exit status
make[4]: *** [pswrap] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.8.2-r1 failed.
!!! Function build, Line 954, Exitcode 2
!!! make World failed
!!! If you need support, post the topmost build error, NOT this status message.

My /etc/make.conf is standard (stage2):
Code:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -gnome"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"

I've searched bugs.gentoo.org but at first sight I didn't find anything that had anything to do with this crash; I have no idea what to do next...
In either case, thanks to anyone in advance for the help!
_________________
De omnis Belgae bravissimi ... erant
Back to top
View user's profile Send private message
monkey89
Guru
Guru


Joined: 08 Mar 2004
Posts: 596

PostPosted: Sun Apr 17, 2005 10:12 pm    Post subject: Re: emerging xorg-x11 results in weird error Reply with quote

Johny the Ripper wrote:
This is the error:
Code:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lfl
collect2: ld returned 1 exit status
make[4]: *** [pswrap] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.8.2-r1 failed.
!!! Function build, Line 954, Exitcode 2
!!! make World failed
!!! If you need support, post the topmost build error, NOT this status message.

My /etc/make.conf is standard (stage2):
Code:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -gnome"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"

I've searched bugs.gentoo.org but at first sight I didn't find anything that had anything to do with this crash; I have no idea what to do next...
In either case, thanks to anyone in advance for the help!


I doubt this is causing it, but -gnome is a USE flag, not a CFLAG.

-Monkey
Back to top
View user's profile Send private message
wjholden
l33t
l33t


Joined: 01 Mar 2004
Posts: 826
Location: Augusta, GA

PostPosted: Sun Apr 17, 2005 10:36 pm    Post subject: Reply with quote

I agree, it doesn't look like you specified any USE flags. Figure out what you want in terms of USE flags using the Gentoo Handbook if you haven't put them in there, then you may want to run "emerge -eDv world" to clean everything. It may be helpful to run "revdep-rebuild" beforehand.
Back to top
View user's profile Send private message
Johny the Ripper
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2004
Posts: 135
Location: EU - Belgium

PostPosted: Sun Apr 17, 2005 10:40 pm    Post subject: Re: emerging xorg-x11 results in weird error Reply with quote

monkey89 wrote:

-gnome is a USE flag, not a CFLAG.

It's late here :lol:
*fixed it, but indeed, it doesn't help :(
_________________
De omnis Belgae bravissimi ... erant
Back to top
View user's profile Send private message
Johny the Ripper
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2004
Posts: 135
Location: EU - Belgium

PostPosted: Sun Apr 17, 2005 11:44 pm    Post subject: Reply with quote

destuxor wrote:
I agree, it doesn't look like you specified any USE flags. Figure out what you want in terms of USE flags using the Gentoo Handbook if you haven't put them in there, then you may want to run "emerge -eDv world" to clean everything. It may be helpful to run "revdep-rebuild" beforehand.

Hmm you are right... I was using a rather old install guide which did not stressed the importance of USE flags. I've just taken the time to look at all the possible USE flags and pick those out that I think are usefull and now I'm re-installing the world packages. In either case, it WILL be better :)
_________________
De omnis Belgae bravissimi ... erant
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Apr 18, 2005 7:50 am    Post subject: Reply with quote

Please follow up here: https://forums.gentoo.org/viewtopic-t-295915.html

Moved from Installing Gentoo.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum