Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mjpegtools emerge error.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
chrism
Guru
Guru


Joined: 15 Jul 2004
Posts: 526

PostPosted: Tue Apr 19, 2005 12:45 pm    Post subject: mjpegtools emerge error. Reply with quote

Hi,

I tried to emerge mjpegtools and got the following error:

Code:

...............
nclude/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF ".deps/liblavplay_la-liblavplay.Tpo" \
  -c -o liblavplay_la-liblavplay.lo `test -f 'liblavplay.c' || echo './'`liblavplay.c; \
then mv -f ".deps/liblavplay_la-liblavplay.Tpo" ".deps/liblavplay_la-liblavplay.Plo"; \
else rm -f ".deps/liblavplay_la-liblavplay.Tpo"; exit 1; \
fi
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF .deps/liblavplay_la-liblavplay.Tpo -c liblavplay.c  -fPIC -DPIC -o .libs/liblavplay_la-liblavplay.o
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF .deps/liblavplay_la-liblavplay.Tpo -c liblavplay.c -o liblavplay_la-liblavplay.o >/dev/null 2>&1
if /bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\"  -I/usr/include/quicktime  -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF ".deps/liblavplay_la-audiolib.Tpo" \
  -c -o liblavplay_la-audiolib.lo `test -f 'audiolib.c' || echo './'`audiolib.c; \
then mv -f ".deps/liblavplay_la-audiolib.Tpo" ".deps/liblavplay_la-audiolib.Plo"; \
else rm -f ".deps/liblavplay_la-audiolib.Tpo"; exit 1; \
fi
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF .deps/liblavplay_la-audiolib.Tpo -c audiolib.c  -fPIC -DPIC -o .libs/liblavplay_la-audiolib.o
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF .deps/liblavplay_la-audiolib.Tpo -c audiolib.c -o liblavplay_la-audiolib.o >/dev/null 2>&1
/bin/sh ../libtool --mode=link i686-pc-linux-gnu-gcc  -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2   -o liblavplay.la -rpath /usr/lib -version-info 2:2:2 -release 1.6 -export-dynamic  liblavplay_la-liblavplay.lo liblavplay_la-audiolib.lo 
i686-pc-linux-gnu-gcc -shared  .libs/liblavplay_la-liblavplay.o .libs/liblavplay_la-audiolib.o   -mcpu=pentium3 -march=pentium3 -mno-sse2 -Wl,-soname -Wl,liblavplay-1.6.so.0 -o .libs/liblavplay-1.6.so.0.2.2
(cd .libs && rm -f liblavplay-1.6.so.0 && ln -s liblavplay-1.6.so.0.2.2 liblavplay-1.6.so.0)
(cd .libs && rm -f liblavplay.so && ln -s liblavplay-1.6.so.0.2.2 liblavplay.so)
i686-pc-linux-gnu-ar cru .libs/liblavplay.a  liblavplay_la-liblavplay.o liblavplay_la-audiolib.o
i686-pc-linux-gnu-ranlib .libs/liblavplay.a
creating liblavplay.la
(cd .libs && rm -f liblavplay.la && ln -s ../liblavplay.la liblavplay.la)
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\"  -I/usr/include/quicktime  -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT lavplay.o -MD -MP -MF ".deps/lavplay.Tpo" \
  -c -o lavplay.o `test -f 'lavplay.c' || echo './'`lavplay.c; \
then mv -f ".deps/lavplay.Tpo" ".deps/lavplay.Po"; \
else rm -f ".deps/lavplay.Tpo"; exit 1; \
fi
/bin/sh ../libtool --mode=link i686-pc-linux-gnu-gcc  -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2   -o lavplay  lavplay.o ../utils/libmjpegutils.la liblavplay.la liblavjpeg.la liblavfile.la -lpthread -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread  -lX11
i686-pc-linux-gnu-gcc -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -o .libs/lavplay lavplay.o -Wl,-rpath -Wl,/usr/lib  ../utils/.libs/libmjpegutils.so ./.libs/liblavplay.so ./.libs/liblavjpeg.so ./.libs/liblavfile.so -L/usr/lib /usr/lib/libquicktime.so /usr/lib/libjpeg.so /usr/lib/libSDL.so /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/libstdc++.so -L/usr/i686-pc-linux-gnu/bin -L/usr/i686-pc-linux-gnu/lib -L/usr/lib/gcc-lib/i686-pc-linux-gnu/../../../i686-pc-linux-gnu/lib -lgcc_s -lc /usr/lib/libasound.so -lm -ldl -lXext -lvga -lpthread -lX11 -Wl,--rpath -Wl,/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130
./.libs/liblavfile.so: undefined reference to `lqt_last_audio_position'
./.libs/liblavfile.so: undefined reference to `lqt_encode_audio_track'
./.libs/liblavfile.so: undnclude/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF ".deps/liblavplay_la-liblavplay.Tpo" \
  -c -o liblavplay_la-liblavplay.lo `test -f 'liblavplay.c' || echo './'`liblavplay.c; \
then mv -f ".deps/liblavplay_la-liblavplay.Tpo" ".deps/liblavplay_la-liblavplay.Plo"; \
else rm -f ".deps/liblavplay_la-liblavplay.Tpo"; exit 1; \
fi
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF .deps/liblavplay_la-liblavplay.Tpo -c liblavplay.c  -fPIC -DPIC -o .libs/liblavplay_la-liblavplay.o
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-liblavplay.lo -MD -MP -MF .deps/liblavplay_la-liblavplay.Tpo -c liblavplay.c -o liblavplay_la-liblavplay.o >/dev/null 2>&1
if /bin/sh ../libtool --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\"  -I/usr/include/quicktime  -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF ".deps/liblavplay_la-audiolib.Tpo" \
  -c -o liblavplay_la-audiolib.lo `test -f 'audiolib.c' || echo './'`audiolib.c; \
then mv -f ".deps/liblavplay_la-audiolib.Tpo" ".deps/liblavplay_la-audiolib.Plo"; \
else rm -f ".deps/liblavplay_la-audiolib.Tpo"; exit 1; \
fi
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF .deps/liblavplay_la-audiolib.Tpo -c audiolib.c  -fPIC -DPIC -o .libs/liblavplay_la-audiolib.o
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\" -I/usr/include/quicktime -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT liblavplay_la-audiolib.lo -MD -MP -MF .deps/liblavplay_la-audiolib.Tpo -c audiolib.c -o liblavplay_la-audiolib.o >/dev/null 2>&1
/bin/sh ../libtool --mode=link i686-pc-linux-gnu-gcc  -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2   -o liblavplay.la -rpath /usr/lib -version-info 2:2:2 -release 1.6 -export-dynamic  liblavplay_la-liblavplay.lo liblavplay_la-audiolib.lo 
i686-pc-linux-gnu-gcc -shared  .libs/liblavplay_la-liblavplay.o .libs/liblavplay_la-audiolib.o   -mcpu=pentium3 -march=pentium3 -mno-sse2 -Wl,-soname -Wl,liblavplay-1.6.so.0 -o .libs/liblavplay-1.6.so.0.2.2
(cd .libs && rm -f liblavplay-1.6.so.0 && ln -s liblavplay-1.6.so.0.2.2 liblavplay-1.6.so.0)
(cd .libs && rm -f liblavplay.so && ln -s liblavplay-1.6.so.0.2.2 liblavplay.so)
i686-pc-linux-gnu-ar cru .libs/liblavplay.a  liblavplay_la-liblavplay.o liblavplay_la-audiolib.o
i686-pc-linux-gnu-ranlib .libs/liblavplay.a
creating liblavplay.la
(cd .libs && rm -f liblavplay.la && ln -s ../liblavplay.la liblavplay.la)
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.2\"  -I/usr/include/quicktime  -I /usr/X11R6/include -I../utils -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include     -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -MT lavplay.o -MD -MP -MF ".deps/lavplay.Tpo" \
  -c -o lavplay.o `test -f 'lavplay.c' || echo './'`lavplay.c; \
then mv -f ".deps/lavplay.Tpo" ".deps/lavplay.Po"; \
else rm -f ".deps/lavplay.Tpo"; exit 1; \
fi
/bin/sh ../libtool --mode=link i686-pc-linux-gnu-gcc  -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2   -o lavplay  lavplay.o ../utils/libmjpegutils.la liblavplay.la liblavjpeg.la liblavfile.la -lpthread -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread  -lX11
i686-pc-linux-gnu-gcc -O3 -mcpu=pentium3 -march=pentium3 -pipe -fomit-frame-pointer -mno-sse2 -o .libs/lavplay lavplay.o -Wl,-rpath -Wl,/usr/lib  ../utils/.libs/libmjpegutils.so ./.libs/liblavplay.so ./.libs/liblavjpeg.so ./.libs/liblavfile.so -L/usr/lib /usr/lib/libquicktime.so /usr/lib/libjpeg.so /usr/lib/libSDL.so /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/libstdc++.so -L/usr/i686-pc-linux-gnu/bin -L/usr/i686-pc-linux-gnu/lib -L/usr/lib/gcc-lib/i686-pc-linux-gnu/../../../i686-pc-linux-gnu/lib -lgcc_s -lc /usr/lib/libasound.so -lm -ldl -lXext -lvga -lpthread -lX11 -Wl,--rpath -Wl,/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130
./.libs/liblavfile.so: undefined reference to `lqt_last_audio_position'
./.libs/liblavfile.so: undefined reference to `lqt_encode_audio_track'
./.libs/liblavfile.so: undefined reference to `lqt_decode_audio_track'
collect2: ld returned 1 exit status
make[2]: *** [lavplay] Error 1
make[2]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.2-r3/work/mjpegtools-1.6.2/lavtools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.2-r3/work/mjpegtools-1.6.2'
make: *** [all] Error 2

!!! ERROR: media-video/mjpegtools-1.6.2-r3 failed.
!!! Function src_compile, Line 111, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.
efined reference to `lqt_decode_audio_track'
collect2: ld returned 1 exit status
make[2]: *** [lavplay] Error 1
make[2]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.2-r3/work/mjpegtools-1.6.2/lavtools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.2-r3/work/mjpegtools-1.6.2'
make: *** [all] Error 2

!!! ERROR: media-video/mjpegtools-1.6.2-r3 failed.
!!! Function src_compile, Line 111, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.


any ideas?

Thanks,
Chris
Back to top
View user's profile Send private message
bkunlimited
l33t
l33t


Joined: 18 Jun 2004
Posts: 672

PostPosted: Tue Apr 19, 2005 1:42 pm    Post subject: Reply with quote

please post your output of "emerge --info"
Back to top
View user's profile Send private message
w0rm
n00b
n00b


Joined: 08 May 2004
Posts: 67

PostPosted: Tue Apr 19, 2005 1:51 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=85432

try the 3rd link (Patch for mjpegtools-1.6.2-r3.ebuild).

It's known that CFLAGS may break this ebuild. If the patch won't help your, try to remove cflags when compiling this package or try to use some older or some newer (~x86, or even -x86) version. GL
Back to top
View user's profile Send private message
chrism
Guru
Guru


Joined: 15 Jul 2004
Posts: 526

PostPosted: Tue Apr 19, 2005 3:09 pm    Post subject: Reply with quote

bkunlimited wrote:
please post your output of "emerge --info"


Here you go:
Code:
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.10 i686)
=================================================================
System uname: 2.6.10 i686 Intel(R) Pentium(R) M processor 1500MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 12 2005, 19:17:38)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.8.5-r3, 1.7.9-r1, 1.5, 1.6.3, 1.4_p6, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS=""
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi bash-completion berkdb bitmap-fonts bonobo calendar cdr crypt cups curl divx4linux doc dvd dvdr emboss encode esd exif fam fbcon fdftk flac flash foomaticdb fortran ftp gb gdbm gif gpm gstreamer gtk gtk2 gtkhtml icq imagemagick imlib ipv6 java jikes jpeg libg++ libwww mad mikmod ming motif mozilla mp3 mpeg msn ncurses nls ogg oggvorbis opengl oss pam pcmcia pda pdflib perl php png python quicktime readline samba sdl slang spell ssl svga tcpd tiff truetype truetype-fonts type1-fonts unicode usb videos vorbis wavelan xine xml2 xmms xosd xv xvid zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY



Hope that helps.

Chris
Back to top
View user's profile Send private message
chrism
Guru
Guru


Joined: 15 Jul 2004
Posts: 526

PostPosted: Tue Apr 19, 2005 3:26 pm    Post subject: Reply with quote

Thanks,
it's working now.

Chris
Back to top
View user's profile Send private message
hseldon79
n00b
n00b


Joined: 20 Apr 2005
Posts: 3

PostPosted: Wed Apr 20, 2005 12:38 am    Post subject: Reply with quote

how did you have it work?

It still doesn't work to me, maybe i just don't know how to patch the ebuilds without loosing the checksums...

Omar.
Back to top
View user's profile Send private message
w0rm
n00b
n00b


Joined: 08 May 2004
Posts: 67

PostPosted: Wed Apr 20, 2005 3:05 pm    Post subject: Reply with quote

try -r4 ebuild
Back to top
View user's profile Send private message
hseldon79
n00b
n00b


Joined: 20 Apr 2005
Posts: 3

PostPosted: Wed Apr 20, 2005 5:07 pm    Post subject: Reply with quote

ebuild /usr/portage/media-video/mjpegtools/mjpegtools-1.6.2-r4.ebuild merge


It doesn't work either. the very same error :(
Back to top
View user's profile Send private message
chatgris
Guru
Guru


Joined: 14 Oct 2002
Posts: 383
Location: Canada

PostPosted: Wed Apr 20, 2005 10:10 pm    Post subject: Reply with quote

Same here, errors on both the stable and -r4 ebuilds.
_________________
Open your mind. Open your source.

Due credit for avatar from http://www.aikida.net
Back to top
View user's profile Send private message
[loki]
n00b
n00b


Joined: 07 Jul 2002
Posts: 29
Location: Granby / Québec

PostPosted: Thu Apr 21, 2005 1:20 pm    Post subject: Reply with quote

You have to make sure that media-libs/libquicktime-0.9.4 is unmasked with ~x86.
Once this version of libquicktime is installed, mpegtools will compile OK.
_________________
« L'absurdité est surtout le divorce de l'homme et du monde. »
-Albert Camus (L'étranger)
Back to top
View user's profile Send private message
hseldon79
n00b
n00b


Joined: 20 Apr 2005
Posts: 3

PostPosted: Thu Apr 21, 2005 2:49 pm    Post subject: Reply with quote

It did work, even if other packages still don't compile (transcode 0.6.11). I'm compiling k3b without encode flag, and wait some future release.

Anyway, i'm too much gentoo enthusiast not to be concerned about the breaking of more and more ebuilds...

Thank you for helping!

Omar.
Back to top
View user's profile Send private message
[loki]
n00b
n00b


Joined: 07 Jul 2002
Posts: 29
Location: Granby / Québec

PostPosted: Fri Apr 22, 2005 1:57 am    Post subject: Reply with quote

Yes, it actually breaks the transcode ebuild, I noticed that after I posted... The solution I used was to put "media-video/transcode -quicktime" in my /etc/portage/package.use file. Then, transcode builds without Quicktime support but with no error.

Effectively, I noticed also how many ebuilds are broken nowadays. Even on a stable "x86" system you get strange dependencies problems and building errors.
_________________
« L'absurdité est surtout le divorce de l'homme et du monde. »
-Albert Camus (L'étranger)
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Apr 22, 2005 6:17 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-308176.html

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum