Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
docbook-sgml-utils-0.6.14 requires a old version of opensp
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Mr.QNo
n00b
n00b


Joined: 21 Mar 2005
Posts: 74

PostPosted: Wed Apr 20, 2005 8:33 am    Post subject: docbook-sgml-utils-0.6.14 requires a old version of opensp Reply with quote

Hi,

Compilation of app-text/docbook-sgml-utils-0.6.14 fails with

Code:

jade: error while loading shared libraries: libosp.so.3: cannot open shared object file: No such file or directory


app-text/opensp is installed, but it provides libosp.so.4.0.0. For me, it seems that an older version of opensp is required. Am i right? How can i install that version?

TIA
Chris
Back to top
View user's profile Send private message
Karsten from Berlin
Guru
Guru


Joined: 28 Feb 2004
Posts: 446
Location: Berlin/Germany

PostPosted: Wed Apr 20, 2005 10:54 am    Post subject: Reply with quote

Well, maybe you could try to create a symlink

ln -s libosp.so.4.0.0 libosp.so.3 && env-update

and try again the compilation.
_________________
Heaven: The police are British, the chefs Italian, the mechanics German, the lovers French and it's organized by the Swiss.
Hell: The police are German, the chefs British, the mechanics French, the lovers Swiss and it's organized by the Italians.
Back to top
View user's profile Send private message
Mr.QNo
n00b
n00b


Joined: 21 Mar 2005
Posts: 74

PostPosted: Wed Apr 20, 2005 1:54 pm    Post subject: Reply with quote

SEEMS to work. No error messages. But:

Code:
Making all in HTML
make[2]: Entering directory `/var/tmp/portage/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
SGML_CATALOG_FILES=/etc/sgml/catalog \
SGML_SEARCH_PATH=../..:../../doc:.. \
        jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
                -V '%use-id-as-filename%' ../../doc/docbook-utils.sgml
SGML_CATALOG_FILES=/etc/sgml/catalog \
SGML_SEARCH_PATH=../..:../../doc:.. \
        jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
                -V '%use-id-as-filename%' ../../doc/docbook-utils.sgml


Another version seems to be required.


Last edited by Mr.QNo on Wed Apr 20, 2005 2:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
Karsten from Berlin
Guru
Guru


Joined: 28 Feb 2004
Posts: 446
Location: Berlin/Germany

PostPosted: Wed Apr 20, 2005 2:11 pm    Post subject: Reply with quote

Hmmm,

did you enable ACCEPT_KEYWORDS="~amd64" for some packages? If not, it's probably a bug and you should post in bugzilla.
_________________
Heaven: The police are British, the chefs Italian, the mechanics German, the lovers French and it's organized by the Swiss.
Hell: The police are German, the chefs British, the mechanics French, the lovers Swiss and it's organized by the Italians.
Back to top
View user's profile Send private message
Mr.QNo
n00b
n00b


Joined: 21 Mar 2005
Posts: 74

PostPosted: Sun Apr 24, 2005 10:19 am    Post subject: Reply with quote

This has been my first gentoo installation. I got eventually confused by different ACCEPT_KEYWORDS and OVERLAYs, so i decided to reinstall. Next time, i'll be more careful ;-)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Mon Jul 18, 2005 11:15 am    Post subject: Reply with quote

Moved from Gentoo on AMD64 to Duplicate Threads in favour of https://forums.gentoo.org/viewtopic-t-312018-highlight-jade+libosp.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum