Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hotkeys for sound not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Sat Apr 23, 2005 4:14 pm    Post subject: hotkeys for sound not working Reply with quote

hello,

i have an iBook G4 and everything is working except the hotkeys for sound. I have pbbutons installed an changing the brightness of the display or ejecting a cd with the eject-button(F12) is working fine. But changing the volume won`t do !! I checked the key-numbers in the pbbuttonsd.conf with showkey, everything seems to be ok. I have alsa up and running with modules for oss loaded, so that /dev/mixer ..... do exist.

i don`t know why the sound-keys won`t do ... ??ß

maybe someone has a solution for this ??

Fugee47
Back to top
View user's profile Send private message
arlequin
l33t
l33t


Joined: 16 Nov 2002
Posts: 707
Location: grep $USER /etc/passwd | cut -d':' -f6

PostPosted: Wed Apr 27, 2005 10:57 am    Post subject: Reply with quote

Maybe you need to emerge and/or launch kmilo service... that's work for me, but on x86 arch :wink:
_________________
J'vous dis ciao !
Au fait, ciao ça veut dire bye en anglais.
Back to top
View user's profile Send private message
cyberb0b
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Wed Apr 27, 2005 5:45 pm    Post subject: Reply with quote

1) What version of pbbuttonsd [and gtkpbbuttons, if installed] do you have installed?
2) What do you have in /etc/pbbuttonsd.conf (sound-specific)
3) How are you starting pbbuttonsd [and gtkpbbuttons, if installed]?

I had the same problem on my iBook G4 and fixed it with changing pbbuttonsd.conf settings. Also I start gtkpbbuttons with -a=/dev/null or something similar. I will check later and compare with your settings.
Back to top
View user's profile Send private message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Thu Apr 28, 2005 3:00 pm    Post subject: Reply with quote

ups

Last edited by Fugee47 on Thu Apr 28, 2005 3:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Thu Apr 28, 2005 3:11 pm    Post subject: Reply with quote

hello again .... :P

artequin: I have tried kmilo with no success.


cyberb0b:

1) pbbuttonsd Version is 0.6.9

2) pbbuttonsd.conf:
# [MODULE OSSMIXER]
Volume = 50
Speakers_muted = no
VolumeUpKey = 114
VolumeDownKey = 113
MuteKey = 115
dev_Mixer = "/dev/mixer"
MixerInitDelay = no
MixerChannels = "pcm"

the modules for alsa+oss are loaded (snd_pcm_oss, snd_mixer_oss ...) and the device /dev/mixer does exist.

3) I have added pbbuttonsd to the Bootup with "rc-update add pbbuttonsd default"

i have gtkpbbuttons installed but there is no gtkpbbuttonsd !! Starting it has the only effect, that there is another "gui" window showing the level of brightness when i change it.

thank you for your support ...
Back to top
View user's profile Send private message
quatsch
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2005
Posts: 104
Location: New York, NY

PostPosted: Thu Apr 28, 2005 5:30 pm    Post subject: Reply with quote

what are the permissions of the sound devices, i.e. the stuff in /dev/snd/ and /dev/mixer, etc. It might be that pbbuttonsd is running as root (or some other user) and doesn't have permission to change the volume. Try
chmod a+rw /dev/mixer
and see if it has any effects. If it does, it's a permissions problem.
Back to top
View user's profile Send private message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Thu Apr 28, 2005 5:45 pm    Post subject: Reply with quote

i have changed the permisson with no success.
Back to top
View user's profile Send private message
cyberb0b
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Thu Apr 28, 2005 7:47 pm    Post subject: Reply with quote

1) I am assuming you had an older version at one point.
2) Your config file includes options not listed in the 0.6.9 pbbuttonsd.conf man page. Looking at the changelog shows:
Code:

2005-03-16  0.6.7-5
   * obsolete configuration file options removed. Old configuration
     files can't be used anymore.
   * new configuration options for ALSA and OSS specific options.
   
     ! Please update your configuration file to the new options. !
     ! Some OSS related options have been renamed.               !

Check the man page for the latest options to play with: http://pbbuttons.sourceforge.net/projects/pbbuttonsd/man-pbbuttonsd.conf.html

3) n/a
Back to top
View user's profile Send private message
cyberb0b
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Fri Apr 29, 2005 1:26 am    Post subject: Reply with quote

here are my settings in case you are still having problems:

1) pbbuttonsd-0.6.9 and gtkpbbuttons-0.6.5

2)
Code:
# [MODULE MIXER]
SoundSystem           = auto
Speakers_muted        = no
VolumeUpKey           = 115
VolumeDownKey         = 114
MuteKey               = 113
OSS_Mixer             = "/dev/mixer"
OSS_Channels          = "volume, speaker"
ALSA_Card             = "default"
ALSA_Elements         = "Master, 'PC Speaker'"
MixerInitDelay        = no

3) pbbuttonsd is started by default as you have, the only way I could get gtkpbbuttons to work is:
/usr/bin/gtkpbbuttons -d -t Crystal -a /dev/null
Back to top
View user's profile Send private message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Fri Apr 29, 2005 11:46 am    Post subject: Reply with quote

wow, thanks a lot !! :D :D
now it works just fine !!!!!!!

cool work ....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum