Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QA Notice:has_version() in global scope: dev-php/mod_php-4.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Sun Apr 24, 2005 8:26 pm    Post subject: QA Notice:has_version() in global scope: dev-php/mod_php-4.3 Reply with quote

This showed up druing emerge -uDvp world. Any idea what's going on here and is it safe to emerge -uD world?

Code:
These are the packages that I would merge, in order:

Calculating world dependencies   -
QA Notice: has_version() in global scope: dev-php/mod_php-4.3.11
QA Notice: has_version() in global scope: dev-php/mod_php-4.3.11

_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Sun Apr 24, 2005 8:49 pm    Post subject: Reply with quote

Moved from Portage & Programming in favour of https://forums.gentoo.org/viewtopic.php?t=252049

See Genone's answer there. The message just means that has_version is called outside of all functions in the ebuild, which is a bad thing at least for performance.

Edit: https://bugs.gentoo.org/show_bug.cgi?id=54019
_________________
KDE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum