Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Annoying Konqueror Document Relations toolbar [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
opensas
Guru
Guru


Joined: 24 Nov 2004
Posts: 408
Location: Buenos Aires - Argentina

PostPosted: Tue Apr 26, 2005 2:44 am    Post subject: Annoying Konqueror Document Relations toolbar [SOLVED] Reply with quote

Everytime I Ctrl-Click on a link to open it on a new tab, an annoying toolbar appears to the lect side of the screen

It's a Document Relations toolbar, which has all its icons disabled.

I don't know what the heck is this thing for, and I'd like to know how to turn it off

Thanks a lot

Saludos

Sas


Last edited by opensas on Sun May 01, 2005 10:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
stustill
Guru
Guru


Joined: 25 Feb 2003
Posts: 333
Location: Aberdeen, Scotland

PostPosted: Tue Apr 26, 2005 4:15 am    Post subject: Reply with quote

I think this is a bug in KDE 3.3. Which version are you using, if you are not using 3.4, then I would suggest upgrading....

Stu
Back to top
View user's profile Send private message
opensas
Guru
Guru


Joined: 24 Nov 2004
Posts: 408
Location: Buenos Aires - Argentina

PostPosted: Tue Apr 26, 2005 5:16 pm    Post subject: Reply with quote

I'm using kde 3.3.2

Kde 3.4 is still masked, but I guess I'm about to give it a try.

By the way, ACCEPT_KEYWORDS="~x86" emerge kde should do it... right?

Saludos

Sas
Back to top
View user's profile Send private message
batzee
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 105

PostPosted: Tue Apr 26, 2005 5:29 pm    Post subject: Reply with quote

you would want to allow the keyword ~x86 only for the kde packages by adding some lines to /etc/portage/package.keywords instead:

kde-base/kdelibs ~x86
kde-base/kdebase ~x86
.
.
.

or if you'd like to use split ebuilds you will have to add some more lines.
Back to top
View user's profile Send private message
opensas
Guru
Guru


Joined: 24 Nov 2004
Posts: 408
Location: Buenos Aires - Argentina

PostPosted: Sun May 01, 2005 10:52 pm    Post subject: Reply with quote

It was a kde 3.3.2 bug

I emerged kde 3.4 and it was solved

Saludos

Sas
Back to top
View user's profile Send private message
julius malchovitch
Tux's lil' helper
Tux's lil' helper


Joined: 16 Sep 2003
Posts: 135
Location: Italia

PostPosted: Tue May 10, 2005 1:15 pm    Post subject: Reply with quote

opensas wrote:
It was a kde 3.3.2 bug

I emerged kde 3.4 and it was solved

Saludos

Sas


Sorry but installing a masked version of kde is not a solution at all.
Please remove the [SOLVED] tag from the thread title.
Back to top
View user's profile Send private message
Mad Merlin
Veteran
Veteran


Joined: 09 May 2005
Posts: 1155

PostPosted: Tue May 10, 2005 1:29 pm    Post subject: Reply with quote

Run "chmod 000 /usr/kde/3.3/lib/kde3/librellinksplugin.*" as root, that will make the plugin files unreadable to everyone and will disable the document relations plugin (which unfortunately is broken and unmaintained). You'll have to run that again if you reemerge or update kdeaddons.
Back to top
View user's profile Send private message
opensas
Guru
Guru


Joined: 24 Nov 2004
Posts: 408
Location: Buenos Aires - Argentina

PostPosted: Wed May 11, 2005 5:58 am    Post subject: Reply with quote

That's a nice workaround, Merlin

But I've already moved to kde 3.4, and it feels far more stable than 3.2 and 3.3

Saludos

Sas
Back to top
View user's profile Send private message
penix1
n00b
n00b


Joined: 25 Mar 2005
Posts: 7

PostPosted: Fri May 20, 2005 1:47 pm    Post subject: Reply with quote

[quote="Mad Merlin"]Run "chmod 000 /usr/kde/3.3/lib/kde3/librellinksplugin.*" as root, that will make the plugin files unreadable to everyone and will disable the document relations plugin (which unfortunately is broken and unmaintained). You'll have to run that again if you reemerge or update kdeaddons.[/quote]

There is an easier way....

Simply delete the plugin_rellinksrc from:

/usr/kde/3.3/share/apps/khtml/kpartplugins

Your way doesn't prevent the "document relations" toolbars from accumulating and eventually crashing konqueror. You are correct that it isn't maintained any more and is removed from 3.4. And as you say, if you re-emerge kdeaddons you will have to delete it again.

HTH
B.
Back to top
View user's profile Send private message
Mad Merlin
Veteran
Veteran


Joined: 09 May 2005
Posts: 1155

PostPosted: Sat May 21, 2005 9:44 pm    Post subject: Reply with quote

penix1 wrote:
Your way doesn't prevent the "document relations" toolbars from accumulating and eventually crashing konqueror. You are correct that it isn't maintained any more and is removed from 3.4. And as you say, if you re-emerge kdeaddons you will have to delete it again.


It works for me, I'm using Konqueror from KDE 3.3.2 as we speak and I haven't seen the "Document Relations" toolbar in ages.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 07, 2005 5:49 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.
Dupe of https://forums.gentoo.org/viewtopic-t-264606.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum