Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Warning: Couldn't extract MOZ_USER_DIR
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jabidof
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Tue May 03, 2005 6:13 am    Post subject: Warning: Couldn't extract MOZ_USER_DIR Reply with quote

Hi everybody!

Here is what i get when i launch TB from my gentoo 2.6.9 command line:

Code:
thunderbird
No running windows found
Warning: Couldn't extract MOZ_USER_DIR from /opt/thunderbird/thunderbird-bin
thunderbird-bin exited with non-zero status (1)
Warning: Couldn't extract MOZ_USER_DIR from /opt/thunderbird/thunderbird-bin


My problem occured this morning though it was ok yesterday :-(

Any idea of what's going on?
Back to top
View user's profile Send private message
dennisn
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2004
Posts: 107
Location: Montreal, Canada

PostPosted: Sun May 08, 2005 7:31 pm    Post subject: Reply with quote

i have the same problem with firefox-bin.

in my /usr/bin/firefox (-> /usr/libexec/mozilla-launcher), near the bottom of the launcher script at the top of the function moz_pis_startstop_scripts(), it tries to retrieve MOZ_USER_DIR from /opt/firefox/firefox-bin, which is a binary file, instead of from /opt/firefox/firefox, which is another script that contains the desired MOZ_USER_DIR= value. i'm sure the same is happening with thunderbird-bin.

hopefully the launcher script will be fixed soon?
Back to top
View user's profile Send private message
jabidof
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Sun May 08, 2005 9:12 pm    Post subject: Reply with quote

I found the following workaround:

unmerge thunderbird-bin
emerge thunderbird

probably not the most elegant solution but i can read my emails... at least :D
Back to top
View user's profile Send private message
msteinacher
n00b
n00b


Joined: 18 May 2005
Posts: 1

PostPosted: Wed May 18, 2005 9:56 am    Post subject: Reply with quote

I think there are two different things that go wrong:

1. Warning: Couldn't extract MOZ_USER_DIR from /opt/thunderbird/thunderbird-bin

This is a problem with mozilla-launcher as pointed out by dennisn, but has AFAIK no impact on the default installation and thunderbird should work properly.

2. thunderbird-bin exited with non-zero status (1)

I think this is the main problem and was the reason of the original post. Unfortunately thunderbird gives not much information about the problem and there could be many different reasons. If your system crashed recently there may be a leftover lockfile in your profiles directory. If so, check that no thunderbird instance is running and remove the file (symlink) "lock" from ~/.thunderbird/[profileid]/ or whereever your profile directory is located.

HTH
Marco
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed May 18, 2005 3:35 pm    Post subject: Reply with quote

Please follow up to https://forums.gentoo.org/viewtopic-t-323757.html

Moved from Other Things Gentoo.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum