Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge cant decide wich is newest
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jonasmattsson
n00b
n00b


Joined: 20 May 2004
Posts: 71
Location: Gothenburg, Sweden

PostPosted: Tue May 03, 2005 8:07 am    Post subject: emerge cant decide wich is newest Reply with quote

every time i want to "emerge world --deep --update", portage wants to down grade my "media-video/ati-drivers-8.10.19" to "...-8.8.25-r3". If i go ahead and do so and then want to do another "emerge world --deep --update" a few days later (or just one minute) it wants to reverse the downgrade, and so this goes on like a jojo. i think this have happend to me before six months ago. i guess it have to do with built in string comparision in python.

does anyone have any solution, or just a temporary fix for this package alone.

thanks
_________________
when he was six he believed that the moon overhead followed him
by nine he had deciphered the illusion, trading magic for fact
no tradebacks.
so this is what it's like to be an adult
if he only knew now what he knew then.
Back to top
View user's profile Send private message
Eskarel
Apprentice
Apprentice


Joined: 07 May 2004
Posts: 257
Location: Perth Australia

PostPosted: Tue May 03, 2005 10:31 am    Post subject: Reply with quote

This isn't a problem with portage, at least not the kind you're talking about.

When this happens it's nearly always a dependency problem. Some package you are using depends specifically on the 8.8.25-r3 version of the driver. For ati, the extras are usually a pretty good candidate for causing this problem, but if you do a pretend emerge with the -t argument it should show you what packages wants that version of the drivers.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Tue May 03, 2005 10:43 am    Post subject: Reply with quote

I'll put the upgrade/downgrade cycle on my FAQ TODO list. It happens from time to time with different packages. For tips and debugging the situation, please see
https://forums.gentoo.org/viewtopic-t-303764.html
https://forums.gentoo.org/viewtopic-t-188298.html
https://forums.gentoo.org/viewtopic-t-177319.html

Moved from Portage & Programming
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum