Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot install xorg (Solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Tue May 03, 2005 2:47 pm    Post subject: cannot install xorg (Solved) Reply with quote

Ok I cannot emerge xorg. It keeps erroring out. Now I know I have to post an error message but all I get is the bottom of the screen where there is no error messages. So how can I find out where the error message is so I can fix it? Is anyone else having issues like this with 2005.0? I know it is probably me. Any ideas here?

Last edited by JROCK2004 on Wed May 04, 2005 3:05 am; edited 1 time in total
Back to top
View user's profile Send private message
taurus
l33t
l33t


Joined: 21 Sep 2004
Posts: 657
Location: I need to be somewhere...

PostPosted: Tue May 03, 2005 2:54 pm    Post subject: Re: cannot install xorg Reply with quote

JROCK2004 wrote:
Ok I cannot emerge xorg. It keeps erroring out. Now I know I have to post an error message but all I get is the bottom of the screen where there is no error messages. So how can I find out where the error message is so I can fix it? Is anyone else having issues like this with 2005.0? I know it is probably me. Any ideas here?


What exactly did you type at the prompt to install xorg??? To be sure, add X in your USE flag and try to emerge it again as
Code:
emerge xorg-x11
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Tue May 03, 2005 3:05 pm    Post subject: Reply with quote

X was not in the USE so I added it. Looking at what I can see on the screen there are a couple of cannot make world errors. What could this mean?
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Tue May 03, 2005 3:25 pm    Post subject: Reply with quote

ok here is where the error messages start

Code:

bin/ld: cannot find -lfl
collect2: ld return 1 exit status
make[4]: *** [pswrap] Error 1
make[4]: Leave directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/cpmfog/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]:  Leave directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leave directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leave directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [world] Error 2

!!! Error: x11-base/xorg/x11-6.8.2-r1 failed.
!!! Function build, Line 954, Exitcode 2
!!! make world failed


Any ideas here? Should I install a previous version, if so which one? All I do is type emerge xorg-x11
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Tue May 03, 2005 4:24 pm    Post subject: Reply with quote

ok follow another post I reinstalled flex and that did it. I am installing now with no errors yet. thanks
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun May 08, 2005 9:20 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-295915.html

Moved from Desktop Environments.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum