Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Geforce FX 5200
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Tue May 03, 2005 4:31 pm    Post subject: [SOLVED] Geforce FX 5200 Reply with quote

Hi. I'm wondering how to install this graphics card. I don't see any difference with the nvidia kernel option enabled. I emerged nvidia-kernel and nvidia-glx but those won't work. I get the message "error inserting nvidia ... invalid module format. I read some threads but can't figure it out. I would like to post config files to help, but then I need to know which, and how to copy text from nano to firefox.

Last edited by Gentoo-Ed on Thu May 05, 2005 8:26 am; edited 1 time in total
Back to top
View user's profile Send private message
Temfate
n00b
n00b


Joined: 24 Feb 2004
Posts: 9

PostPosted: Tue May 03, 2005 5:52 pm    Post subject: Reply with quote

Did you compile rivafb support into your kernel? If so, it will conflict with the nvidia module. You need to unmerge nvidia-kernel, recompile your kernel without the rivafb, and re emerge nvidia-kernel.

At least that worked for me.
Back to top
View user's profile Send private message
macawgumbo
Apprentice
Apprentice


Joined: 28 May 2004
Posts: 165

PostPosted: Tue May 03, 2005 5:58 pm    Post subject: Reply with quote

On top of that, make sure your nvidia drivers are the latest. ( You may have to go outside of emerge ) 8O
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Tue May 03, 2005 6:23 pm    Post subject: Reply with quote

okay i can try that.
one minor noob question, how to unmerge?
i did emerge nvidia-kernel, then emerge nvidia-glx to install them.
Back to top
View user's profile Send private message
Elenyon
n00b
n00b


Joined: 11 Feb 2005
Posts: 44
Location: Philadelphia

PostPosted: Tue May 03, 2005 6:28 pm    Post subject: Reply with quote

Gentoo-Ed wrote:
okay i can try that.
one minor noob question, how to unmerge?
i did emerge nvidia-kernel, then emerge nvidia-glx to install them.


emerge --unmerge nvidia-kernel nvidia-glx will do the trick for you

Also you might want to try

ACCEPT_KEYWORDS="~x86" emerge nvidia-kernel nvidia-glx
Thats is assuming you have an x86 processor this is the only way my nvidia drivers would install also to get then to work in an X enviroment you have to edit your .conf file
_________________
Visit the Lug DUGLUG
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Tue May 03, 2005 7:13 pm    Post subject: Reply with quote

error inserting nvidia ... invalid module format

This is what I get, after emergeing with the keyword x86.
Back to top
View user's profile Send private message
Elenyon
n00b
n00b


Joined: 11 Feb 2005
Posts: 44
Location: Philadelphia

PostPosted: Wed May 04, 2005 3:50 am    Post subject: Reply with quote

Gentoo-Ed wrote:
error inserting nvidia ... invalid module format

This is what I get, after emergeing with the keyword x86.


You might have to go outside of portage to get your nvidia drivers to work.
Uninstall the nvidia drivers from portage and then download the current linux drivers
here
then follow their instructions also make sure that you don't have X loaded when trying to do this update
hop into a console
Code:
ctrl+alt+f1

go to run level 3
Code:
init 3

then run the installer.
_________________
Visit the Lug DUGLUG
Back to top
View user's profile Send private message
omnicloud
Guru
Guru


Joined: 10 Mar 2005
Posts: 550
Location: California

PostPosted: Wed May 04, 2005 8:55 am    Post subject: Reply with quote

Invalid module format sounds to me like a kernel error.

If you recently recompiled your kernel but booted from a different one (maybe different major version? Or from a same version but misconfigured), you will get this error because modules won't compile in the right format or be properly made.

Be sure to mount /boot and copy the bzImage, System.map, and .config to /boot, and make sure your grub (or lilo) config is ok, then reboot and do emerge nvidia-kernel nvidia-glx.

That should work and if not, I'll continue to help anyway I can.
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Wed May 04, 2005 10:13 am    Post subject: Reply with quote

I try these options tonight.
I made a "test" situation by coping my kernel from the "default" situation with:

cp /boot/kernel-default /boot/kernel-test
cp /boot/System.map-default /boot/System.map-test
cp /boot/cofig-default /boot/config-test

Then I also added a new grub entry. This results in a working test situation. Tonight I'll try to install the drivers from nvidia and post the result here. Install the portage drivers apparently didn't succeed for I already tried that on this kernel (also recompiled it to make sure I had a "clean" one).
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Wed May 04, 2005 5:27 pm    Post subject: Reply with quote

:cry:

It doesn't help. It still won't work (with the downloaded kernel file). It also gives errors, the same as portage but then in it's own interface. So I went back to the drawing board. A clean image waiting what to do next.
Back to top
View user's profile Send private message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Wed May 04, 2005 5:45 pm    Post subject: Reply with quote

Just a guess.. but this might be because your kernel is compiled with another version of gcc than the one you are using to compile the nvidia kernel module... so you should compile a new kernel with your current gcc, reboot to the new kernel, and then do the emerge nvidia-kernel nvidia-glx again.
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Wed May 04, 2005 6:26 pm    Post subject: Reply with quote

:oops:
Okay don't blame the noob. I admit I made a dumb mistake someware. I recompiled the kernel. Copied it. Emerged nvidia-kernel and nvidia-glx and the the module is loaded.

Now the next stap. Configuring it. My boot text still looks like 800x600. I don't know what to edit for I don't have the config files as mentioned in the nvidia handbook. Si what to do now?
Back to top
View user's profile Send private message
omnicloud
Guru
Guru


Joined: 10 Mar 2005
Posts: 550
Location: California

PostPosted: Wed May 04, 2005 7:59 pm    Post subject: Reply with quote

Configure it for what? X? Or during boot? If you want it to look good while booting, make sure you enable vesa or vesatng (vesatng is better) in your kernel, framebuffer support, bootsplash support, and emerge bootsplash. There is a tutorial somewhere here for how to get bootsplash working.
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Thu May 05, 2005 7:43 am    Post subject: Reply with quote

I meant the "resolution" at boot. After grub my letters are quite big. I'ld like them smaller. If this is bootsplash or something then let me know, I'll mark this thread solved for I don't want to go wondering off in this thread.
Back to top
View user's profile Send private message
omnicloud
Guru
Guru


Joined: 10 Mar 2005
Posts: 550
Location: California

PostPosted: Thu May 05, 2005 8:04 am    Post subject: Reply with quote

Set yout default framebuffer resolution in your kernel config then recompile.

Also remember to re-emerge any modules like alsa-driver or nvidia-kernel
Back to top
View user's profile Send private message
Gentoo-Ed
Guru
Guru


Joined: 21 Apr 2005
Posts: 442
Location: the Netherlands

PostPosted: Thu May 05, 2005 8:26 am    Post subject: Reply with quote

thanks that did it.
case closed :-)
Back to top
View user's profile Send private message
omnicloud
Guru
Guru


Joined: 10 Mar 2005
Posts: 550
Location: California

PostPosted: Thu May 05, 2005 9:15 am    Post subject: Reply with quote

Glad to help
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Sep 20, 2005 5:10 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Duplicate Threads in favour of 'modprobe nvidia' fails.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum