Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with PHP
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Tue May 03, 2005 6:16 pm    Post subject: Problem with PHP Reply with quote

When i ran emerge -uD world i got this error at php:


make: *** [sapi/cli/php] Error 1

!!! ERROR: dev-php/php-4.3.11 failed.
!!! Function php-sapi_src_compile, Line 544, Exitcode 2


How can i solve this?
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Tue May 03, 2005 10:42 pm    Post subject: Reply with quote

Can you post the lines that preceded those?
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Wed May 04, 2005 12:51 pm    Post subject: Reply with quote

This one?

libtool: link: cannot find the library `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la'
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Wed May 04, 2005 8:38 pm    Post subject: Reply with quote

Someone have an idea on what i've done? :p
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Thu May 05, 2005 10:02 pm    Post subject: Reply with quote

Can you try again and list a number of lines before that one? Basically, from the point where it starts spewing out errors.
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Sun May 08, 2005 11:11 am    Post subject: Reply with quote

Well, i did a emerge -C php on php and tried to emerge it but that didn't work either...

When i try emerge -uD world it wants to emerge mod_php first now, and when i try emerge php this comes up:

Calculating dependencies

!!! Problem in dev-php/php-4.3.11 dependencies.
!!! "Specific key requires an operator (dev-php/php-4.3.11) (try adding an '=')" exceptions


Screwed it up, hopefully i'll learn something of it. :)
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Sun May 08, 2005 12:14 pm    Post subject: Reply with quote

zeuz wrote:
This one?

libtool: link: cannot find the library `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la'
https://forums.gentoo.org/viewtopic-t-318790.html
https://forums.gentoo.org/viewtopic-t-318791.html
https://forums.gentoo.org/viewtopic-t-324801.html

Please search before you post.
zeuz wrote:
when i try emerge php this comes up:

Calculating dependencies

!!! Problem in dev-php/php-4.3.11 dependencies.
!!! "Specific key requires an operator (dev-php/php-4.3.11) (try adding an '=')" exceptions
Add an = in front of it, i.e.
Code:
emerge =dev-php/php-4.3.11
(note the equals sign). You need to use = every time you request a specific version of a package.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun May 08, 2005 12:23 pm    Post subject: Reply with quote

Moved from Networking & Security in favour of the threads moocha linked above.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum