Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to unmerge sys-kernel/vanilla-sources-2.6.10-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
gonzzor
Tux's lil' helper
Tux's lil' helper


Joined: 03 Nov 2004
Posts: 133

PostPosted: Fri May 06, 2005 3:27 pm    Post subject: Unable to unmerge sys-kernel/vanilla-sources-2.6.10-r1 Reply with quote

Hi..

Having some troulbe unmerging the sys-kernel/vanilla-sources-2.6.10-r1...

I do:

$ sudo emerge unmerge sys-kernel/vanilla-sources-2.6.10-r1

sys-kernel/vanilla-sources
selected: 2.6.10-r1
protected: none
omitted: 2.6.11.7
---
CUT HERE
---
--- !found dir /usr/src/linux-2.6.10-r1
Traceback (most recent call last):
File "/usr/bin/emerge", line 2828, in ?
if 1==unmerge(myaction, myfiles):
File "/usr/bin/emerge", line 2188, in unmerge
retval=portage.unmerge(mysplit[0],mysplit[1],portage.root,mysettings,unmerge_action not in ["clean","prune"])
File "/usr/lib/portage/pym/portage.py", line 2828, in unmerge
mylink.unmerge(trimworld=mytrimworld,cleanup=1)
File "/usr/lib/portage/pym/portage.py", line 6096, in unmerge
if not os.path.exists(obj):
File "/usr/lib/python2.3/posixpath.py", line 174, in exists
st = os.stat(path)
TypeError: stat() argument 1 must be (encoded string without NULL bytes), not str


I have manually cleaned out the /usr/src dir from this kernel version, but I want to remove it from the "World" also...

I have also tried to install that kernel version again from the portage tree but it failed since that ebuild doesn't exist...

Solutions?
_________________
After 5 hours trying to install PHP 4 on FreeBSD I missed my Gentoo machine...
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat May 07, 2005 12:06 pm    Post subject: Reply with quote

Quote:
$ sudo emerge unmerge sys-kernel/vanilla-sources-2.6.10-r1
is not right. you want emerge -C instead
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Sat May 07, 2005 1:25 pm    Post subject: Reply with quote

Please see the FAQ GF19: Emerge fails to unmerge a package It should be safe to just delete the vanilla-sources-2.6.10-r1 directory.

Moved from Portage & Programming.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum